19 Nov 2019 - TVDB are still in the process of fixing a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are still working to rectify the problems.

  •   
  • 1
  • 85
  • 86
  • 87(current)
  • 88
  • 89
  • 355
  •   
  Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
(2017-07-11, 20:03)movie78 Wrote: Is BD-J supported on LIBREELEC?

No.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2017-07-11, 19:39)Milhouse Wrote:
(2017-07-11, 18:15)ste0803 Wrote: I have had no IR input on any of these latest builds, running an intel kaby lake NUC. IR powers the NUC on from standby so the IR is definitely working just not within KODI.

Any Ideas? even the IRW command shows nothing coming in when pressing any buttons on my remote.

info: IR worked up to 0704, stopped in 0705.

Nothing obvious in #0705, are you sure #0705 is the first non-working build?

Can you provide a dmesg and debug kodi.log? Also have you tried disabling LIRC in LibreELEC Settings addon to see if that helps (these LE9 builds can use the kernel to decode IR rather than LIRC itself).

Hi. I've just rolled back through previous builds and Ir came back in 0704 but didn't work in 0710 or 0705. I'll give that a try and see what happens.
(2017-07-11, 20:04)Milhouse Wrote:
(2017-07-11, 11:53)macnb Wrote: Matter of interest, what was the problem and what did you do to fix it ?

You probably have more partitions in your system than most who run LibreELEC.

At bootup, as each partition is "seen" by udev, the new partition is mounted (/var/media/<blah>) and - if Samba auto-sharing is enabled - the partition is automatically shared by Samba.

In order for Samba to share the new partition the smbd/nmbd/samba-config services must be restarted and the new partition added to the Samba configuration. This means that smbd, nmbd and the samba-config service will be restarted up to 6 times in your case, once for each partition (/flash, /storage plus /dev/sda[2,4,5,6]).

There is a "5 restarts within 10 seconds" default limit in systemd (to prevent units/services going nuts) and unfortunately you were exceeding the 5 restart limit which resulted in the samba-config service eventually failing, which then caused the smbd and nmbd services to fail as they're both dependent on the failed samba-config service. Manually running "smbd" at the command line started the smbd daemon but you'd be missing 1 or 2 shares and nmbd would not be running (no NetBIOS support).

Both smbd and nmbd services already had this restart limit disabled, but samba-config did not. Disabling the restart limit on the samba-config service fixes the issue (and will be backported to the next LE8 official release) - thanks for reporting!

Thanks for the super clear and concise cause of the problem. Well spotted.
To confirm, I went back to one of your older builds and in LE-Settings->Services->Auto-Share External Drives = OFF and that brought up the LIBREELEC samba server.
Thanks for adding the fix to the next release.
New LibreELEC.tv Leia build #0711: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.11.9 #1 SMP Tue Jul 11 21:04:33 BST 2017 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20170711210313-#0711-g7661973 [Build #0711]

# Kodi version
(18.0-ALPHA1 Git:734cda1). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (76619734, changelog) and tip of XBMC master (6aceab23, changelog) with the following modifications: Build Highlights:
  1. RTL8812AU: Switch repo from zebulon2 to paspro
  2. net-booting: avoid hang on halt/reboot
Build Details:
  1. LibreELEC.tv:
    • samba: update to samba-4.x (PR:1469, 8 commits, 43 files changed)
  2. XBMC:
    • VideoPayer: fix VideoBufferSysMem (PR:12463, 1 commit, 5 files changed)
    • [addons] change OnEnabled and OnDisabled to use AddonPtr (PR:12444, 1 commit, 3 files changed)
    • ADD: [droid] network stuff via api (PR:12243, 2 commits, 10 files changed)
    • Modernize CEventGroup (PR:12458, 1 commit, 5 files changed)
    • [cmake] use normalized to lower case CORE_PLATFORM_NAME in conditionals (PR:12465, 1 commit, 2 files changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] compare: kodi updates
    • Added: [env] PR:1776: Don't cause system to hang on halt/reboot when net-booting
    • Added: [env] PR:1778: reduce $DEVICE complexity
    • Added: [pkg] PR:67: Revert "Revert "change smbd and nmbd location"" (service.libreelec.settings)
    • Added: [pkg] PR:12461: [cmake] cleanup FindOpenGLES.cmake
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2017-07-09, 22:03)sboa Wrote: I apologize for the difficulties of the interpreter, my native Russian. Wink

@sboa do you want to have another go at pasting what I've asked for?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Milhouse - is there any progress regarding Kaby Lake HD Pass through issues ?
I asked this before but didn't try to check for a while now, the issue is that the HDMI 2.0 can't output of DTS-HD and Dolby TrueHD outputs ...
Short answer: No HD audio passthrough on Kaby/Apollo-Lake under Linux via HDMI2.0 equipment. A solution seems far away and I'm getting more and more the feeling that a solution may never see the light of day because no one at Intel seems to feel responsible. But better to ask in the Apollo/Kaby-Lake thread, because this issue has nothing todo with the development builds of Milhouse.
I've uploaded vfs.rar in the addons section - it builds, no idea if it works.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2017-07-12, 16:21)Milhouse Wrote: I've uploaded vfs.rar in the addons section - it builds, no idea if it works.

Failed to install due to dependency on kodi.binary.global.general 1.0.2

Also disabling the LIRC has fixed my no IR issues. Smile Thanks
(2017-07-12, 19:15)ste0803 Wrote: Failed to install due to dependency on kodi.binary.global.general 1.0.2

Thanks, that's unfortunate - kodi.binary.global.general in the latest Kodi master is 1.0.2 so I've no idea why it's complaining, maybe a bug... oh well. Sad
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
OK so the deafening silence from nvidia users complaining that #0710/#0711 does not have working video made me question if the problem is with my system, and sure enough resetting guisettings.xml has restored nvidia (ION2) video in the latest builds, so somehow my settings had become corrupted (not surprising given the changes in the last few days - downgrading to a build older than anything from the past few days and keeping settings is virtually impossible).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Bugger. I've broken nvidia again, but at least I know what has caused it.

1. Start out with 100% default settings by shutting down Kodi, rm guisettings.xml, and restart kodi (or reboot)

2. Set "Player > Videos > Adjust display to refresh rate" to "Always", as below:

Image

3. Play a video (eg. 24fps video on a 24Hz capable TV while GUI is being displayed at 60Hz)
4. There's only a black screen (audio can be heard)
5. Stop video, set "Adjust display to refresh rate" to "Off" and the same video plays normally (seen and heard)

Kodi debug log showing #4, followed by #5: http://sprunge.us/bPGL

Hardware is a Revo 3700 with ION2.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Leia build #0712: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.11.9 #1 SMP Wed Jul 12 21:41:58 BST 2017 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20170712213905-#0712-gc9585fb [Build #0712]

# Kodi version
(18.0-ALPHA1 Git:734cda1). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (c9585fbd, changelog) and tip of XBMC master (9b949153, changelog) with the following modifications: Build Highlights:
  1. VideoPlayer fixes
  2. inputstream openstream cleanup (drop inputstream.rtmp again, doesn't build)
  3. libcec updates, several fixes
  4. inputstream.adaptive update
Build Details:
  1. LibreELEC.tv:
    • initramfs: enable DNS if network is up (PR:1764, 1 commit, 4 files changed)
    • LibreELEC-settings: update to LibreELEC-settings-a40fb4f (PR:1782, 1 commit, 1 file changed)
  2. XBMC:
    • VideoPlayer: cleanup / fix RenderManager (PR:12471, 1 commit, 2 files changed)
    • [addons] Fix compiler warning: xbmc/xbmc/addons/RepositoryUpdater.h: (PR:12468, 1 commit, 1 file changed)
    • [cleanup] Prefer 'override' usage (PR:12466, 3 commits, 3 files changed)
    • Support more yuv420p bitwidths for direct rendering on Linux (PR:12479, 2 commits, 7 files changed)
    • VideoPlayer: vaapi - fix c/p error (3fb3d0b8)
    • VideoPlayer: vdpau - fix c/p error (12035632)
    • InputstreamAddon::OpenStream / AddonVideoCodec::VideoBuffers cleanup (#12469) (7279ca5f)
  3. libcec:
    • Fix menu language string (PR:360, 1 commit, 1 file changed)
    • Add a Reinitialze action. Useful for after the device has been powered down (13af1b6d)
    • Merge branch 'pr299'. Closes #299 (f28c4e6e)
    • TDA995x: Fix logical address readback (ba979114)
    • TDA995x: Handle physical address change, optimize logical address setup (d2cc9447)
    • Merge branch 'pr303'. Closes #303 (3cd30dd7)
    • detect WIN64 in cmake automatically (2fa258a8)
    • Merge branch 'pr322'. Closes #322 (664cab56)
    • fix missing tinfo linking in cec-client (ab621bd1)
    • Merge branch 'pr341'. Closes #341 (774a544b)
    • Fix: set wrong variable (af50b294)
    • Merge branch 'pr352'. Closes #352. Closes #343. Closes #343 (00afa793)
    • Update README.developers.md (031ed00d)
    • Merge branch 'pr330'. Closes #330 (2c71510e)
    • added: Panasonic media control info to the readme. Thanks @9000h. Issue (f8eb6c43)
    • fixed: LG - don't activate the source when receiving vendor command 0xB (1a8dc6c9)
  4. inputstream.adaptive:
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: inputstream.rtmp: disable outdated addons that no longer build
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2017-07-12, 20:59)Milhouse Wrote: OK so the deafening silence from nvidia users complaining that #0710/#0711 does not have working video made me question if the problem is with my system, and sure enough resetting guisettings.xml has restored nvidia (ION2) video in the latest builds, so somehow my settings had become corrupted (not surprising given the changes in the last few days - downgrading to a build older than anything from the past few days and keeping settings is virtually impossible).

Just tried build #0712 on my Revo RL100 which has ION GPU and have no problems playing videos.

Code:
LibreELEC:~ # lspci
00:00.0 RAM memory: NVIDIA Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: NVIDIA Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: NVIDIA Corporation MCP61 SMBus (rev a2)
00:02.0 USB controller: NVIDIA Corporation MCP61 USB 1.1 Controller (rev a3)
00:02.1 USB controller: NVIDIA Corporation MCP61 USB 2.0 Controller (rev a3)
00:04.0 PCI bridge: NVIDIA Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: NVIDIA Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: NVIDIA Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: NVIDIA Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: NVIDIA Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: NVIDIA Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Link Control
02:00.0 VGA compatible controller: NVIDIA Corporation GT218 [ION] (rev a2)
02:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
04:00.0 Network controller: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe
LibreELEC:~ #
(2017-07-13, 01:00)macnb Wrote: Just tried build #0712 on my Revo RL100 which has ION GPU and have no problems playing videos.

Thanks. Do you see any difference with "Adjust display to refresh rate" set to "Always" (make sure you test a video that causes a refresh rate change).

A Skylake NUC has no problem adjusting refresh rate so this seems to be nvidia specific (possibly ION2 specific...)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 85
  • 86
  • 87(current)
  • 88
  • 89
  • 355
  •   
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 18.0)4.524