•   
  • 1
  • 81
  • 82
  • 83(current)
  • 84
  • 85
  • 111
  •   
Beta Spotify for Kodi
Hi.

Just wanted to report back....

I updated to 1.1.34 yesterday morning and proceeded to play a random spotify playlist of 100 tracks. The stability was very good, a few silent passages around the 60th track, then random sound drop outs completely, until I forwarded onto the next track. A marked improvement though.

With the drop outs I thought it might be my ISP, but given its a 200 Mbit link I'm not so sure? And, assume its not Spotify themselves! Deffo silent parts, but no stuttering as such that I could hear, just drop outs in the sound, playing to the device, no connect in use.

Thanks for the efforts!

Kodi 17.4. Libreelec 8.02e Community. Beelink S912 Dev 2G/16G.

UPDATE: Just updated to 1.1.36 so running a few playlists to test and report in general. Connect is off, cache is on.
Reply
(2017-07-17, 10:24)cugel Wrote: After taking a look into the error the solution that i've fount is to include this lines In file httpproxy.py (now, everything is working fine):

Please test again with version 1.1.36, that change should not be needed anymore as I switched from full wsgi to the more simple cherrypy server.
Reply
(2017-07-17, 10:39)gazzauk71 Wrote: UPDATE: Just updated to 1.1.36 so running a few playlists to test and report in general. Connect is off, cache is on.

Can you let me know the test results with version 1.1.36 ? I changed the buffer size a bit which should solve that stuttering issue you noticed.
Reply
(2017-07-16, 20:33)timjon Wrote: Um, no, I'm running Win 7 Home Premium, 64 bit - just checked in case I was going crazy! The machine has 8GB RAM and reports 7.9 usable so I'm pretty confident on this one. Smile

If Kodi 17 is working, though, that's probably the kick in the pants I need to get around to upgrading!

Oh, strange. Your log stated Windows 32 bits so I assumed you were running a 32bits OS.
Maybe because Kodi itself is 32bits on Windows that it also lists the OS as 32 bits, will have to check on that.

Strange why the librespot/spotty executable won't run on your machine.
You can try to open a command prompt, navigate to the Kodi addons folder and try to run spotty.exe manual from plugin.audio.spotify\resources\lib\spotty\windows

I'm very curious what you get as output.
Reply
(2017-07-16, 13:22)marcelveldt Wrote:
(2017-07-16, 12:29)Jefachtig Wrote: For me it's now not working at all with the latest update. The ones before played but then stopped after more or less 30 seconds. Or started stuttering.

With latest version it didn't even start. I'm using OSMC for raspberry pi.

I used to have spotlight working like a charm on my old openelec setup but needed to update for ither addons. Since then no more spotify for me? I hope this addon will work!

What model raspberry pi ? Note that the Pi 1 or zero is not supported.
Do you have a Kodi logfile for me ?

EDIT: wait, found the issue. It was specific to OSMC. Please test the next version 1.1.36

Okay so the first song played completely! I'll let you know if something happens later but so far so good! Thnx a lot marcelveldt!

Ps. I have a raspberry pi 2 i think.. not quite sure.
Reply
(2017-07-16, 07:59)marcelveldt Wrote:
(2017-07-16, 07:47)AussieFries Wrote: Same here: Kodi 16, navigation fine but no sound (both with 1.1.33 and 1.1.34)

Can you send me your full Kodi logfile please ?
Did you install the add-on from my repo ?
What do you have selected as playback device ?

Thank you for your reply. After reinstalling 1.1.36 everything seems to be working fine.
I'll report back with log file should I experience any problems. Great work!
Reply
(2017-07-17, 13:45)marcelveldt Wrote:
(2017-07-17, 10:39)gazzauk71 Wrote: UPDATE: Just updated to 1.1.36 so running a few playlists to test and report in general. Connect is off, cache is on.

Can you let me know the test results with version 1.1.36 ? I changed the buffer size a bit which should solve that stuttering issue you noticed.

I've ran a 60 song playlist without fail today whilst working from home, and I'll run another with higher volume levels within the next few hours. So far it seems much more robust than the previous versions Smile
Reply
(2017-07-17, 13:49)marcelveldt Wrote: Strange why the librespot/spotty executable won't run on your machine.
You can try to open a command prompt, navigate to the Kodi addons folder and try to run spotty.exe manual from plugin.audio.spotify\resources\lib\spotty\windows

I'm very curious what you get as output.

Success!

On trying to launch spotty.exe from the command line, I got a dialog popup with "The program can't start because VCRUNTIME140.dll is missing from your computer. Try reinstalling the program to fix this problem."

I manually installed the VC++ 2015 redistributable package from https://www.microsoft.com/en-US/download...x?id=53587 , after which spotty.exe launched fine, and testing within Kodi I now get audio playback. Smile

I'm guessing most regular PCs will already have this installed from one package or another, hence the reason most people aren't seeing this? My NUC pretty much only has Kodi installed, though.

Many thanks for your help. Smile Not sure if there's any way you can detect the missing DLL and flag it up to end users, but if nothing else, hopefully this thread will help anyone else with the same problem.
Reply
(2017-07-17, 16:52)gazzauk71 Wrote:
(2017-07-17, 13:45)marcelveldt Wrote:
(2017-07-17, 10:39)gazzauk71 Wrote: UPDATE: Just updated to 1.1.36 so running a few playlists to test and report in general. Connect is off, cache is on.

Can you let me know the test results with version 1.1.36 ? I changed the buffer size a bit which should solve that stuttering issue you noticed.

I've ran a 60 song playlist without fail today whilst working from home, and I'll run another with higher volume levels within the next few hours. So far it seems much more robust than the previous versions Smile

Just ran a full 50 song playlist, went out, came back and it was still continuing without error as far as I can make out, so pretty much sorted. Might have had a drop out and restart of Kodi on Libreelec once today though. But, much more stable now. So many thanks for the work.
Reply
Hi all,

Marcel, first of all many thanks for the awesome work! Surely this is gonna be a killer-app for Kodi once it reaches version 2.0. For as long as the add-on works, it looks and works great. However, after 2:40 min tracks stop playing, after which occasionally the next track begins, or the system crashes.

I'm running LibreELEC on a raspberry pi 2, see attached the error log. Seems that something is causing timeouts of the stream which leads the thing to fail. Any idea's how to fix this would be greatly appreciated!

Many thanks and best regards,
Sam

errorlog: https://paste.ubuntu.com/25118603/

line 1667 and onwards
Reply
I just tried to install the plugin on my Raspberry Pi 3 with LibreElec but it will not login.
Logs are at:
https://pastebin.com/7LppSxgA
Reply
(2017-07-17, 22:07)gazzauk71 Wrote:
(2017-07-17, 16:52)gazzauk71 Wrote:
(2017-07-17, 13:45)marcelveldt Wrote: Can you let me know the test results with version 1.1.36 ? I changed the buffer size a bit which should solve that stuttering issue you noticed.

I've ran a 60 song playlist without fail today whilst working from home, and I'll run another with higher volume levels within the next few hours. So far it seems much more robust than the previous versions Smile

Just ran a full 50 song playlist, went out, came back and it was still continuing without error as far as I can make out, so pretty much sorted. Might have had a drop out and restart of Kodi on Libreelec once today though. But, much more stable now. So many thanks for the work.

Updates: Tues 18/7/17

OK, running a 50 song playlist gave me no errors on the S912 (8.0.2.e) development device Kodi 17.4 Libreelec. Seemed pretty much rock solid @ 1.1.36. Did not hear any drops or have failures of Kodi, crash out to restart of Kodi.

So went and updated my S905X Kodi device, same Libreelec version Dev 8.0.2e from KSZAQ, using Spotify vers: 1.1.36. Seems solid in playback mode, although out of first 5 tracks one track 'cut' paused sound and then went onto the next track ok. Continuing testing for the next few hours, until the missus wants the TV back!

Update: Playing track 35 out of 50 playlist, sound stopped for 30 seconds or so, but then resumed playing again.... strange. Kodi didn't fail and the spotify addon didn't exit.
Reply
(2017-07-17, 20:22)timjon Wrote: I manually installed the VC++ 2015 redistributable package from https://www.microsoft.com/en-US/download...x?id=53587 , after which spotty.exe launched fine, and testing within Kodi I now get audio playback. Smile

Thanks for sorting it out. I assumed the VC runtime is installed by Kodi but I was wrong with that assumption.
I'll try to fix the VC++ RT dependency or else I'll include a warning message.
Reply
(2017-07-18, 15:12)sammolenaar Wrote: Marcel, first of all many thanks for the awesome work! Surely this is gonna be a killer-app for Kodi once it reaches version 2.0. For as long as the add-on works, it looks and works great. However, after 2:40 min tracks stop playing, after which occasionally the next track begins, or the system crashes.

I'm running LibreELEC on a raspberry pi 2, see attached the error log. Seems that something is causing timeouts of the stream which leads the thing to fail. Any idea's how to fix this would be greatly appreciated!

Hmm, strange. The range requests by the Kodi player seem to be failing somehow on your system.
Did you test with version 1.1.36 of the add-on ? Does it always stop at 2:40 min ?
Reply
(2017-07-18, 17:05)Rouzax Wrote: I just tried to install the plugin on my Raspberry Pi 3 with LibreElec but it will not login.
Logs are at:
https://pastebin.com/7LppSxgA

Are you 100% sure you've entered the correct credentials ?
If you have a Facebook account to log into spotify you might want to create a device password and log in with that details.
You can create a device account when you log into spotify in the webbrowser in your account details.
Reply
  •   
  • 1
  • 81
  • 82
  • 83(current)
  • 84
  • 85
  • 111
  •   
 
Thread Rating:
  • 17 Vote(s) - 4.65 Average



Logout Mark Read Team Forum Stats Members Help
Spotify for Kodi4.6517