v17 Hardware Acceleration - Issue
#1
I am currently using Kodi 17.1 on Windows 10 with a Nvidia 1060 with up to date drivers.
When I set 'Render Method' to auto detect and switch on DVXA, and try to playback pre-recorded SDTV the picture is jerky.
If I leave Render Method to auto- detect it will not default to software decoding for SDTV.
I need to manually select 'Render Method' to software to achieve a smooth picture and set the Deinterlace Method to off.
Is there any way I can resolve this?
Reply
#2
I had an issue with this EXACT same problem. The only fix for me was deleting kodi and doing a fresh install. Although at the time I believe I was using 16.1, but the problem never returned. Currently running 17.1.
Reply
#3
Thanks, I will give my media pc a full format and reinstall everything, so I have got a clean install. I will then report back here with the outcome.
Reply
#4
I am not sure exactly what is going on here.
I have formatted my pc and reinstalled windows 10
I have installed the latest Nvidia driver for my Nvidia 1060
I have installed Kodi 17.1 and left all the settings at default.
When I watch live or recorded SDTV, the picture is jittery with DVXA enabled.
Once I disable DVXA the picture is perfect.
@Fail$tyle420 are you now able to watch SDTV with DVXA enabled?
Can anyone please help me resolve this?
Reply
#5
he didnt mean to format your PC doh! thats extreme only 2 directories need deleting or 1 if you used a win installer for kodi jesus.

So you did all that and you havent even posted a debug log (wiki) do it please. i'll get my coat...
Reply
#6
I just wanted to make sure 100% that my system was 100% as it should be, I don't mind formatting my PC, I find it keeps it in tip top shape.
Anyway here is the log, hopefully, it points to my problem.
https://paste.ubuntu.com/24462863/
Reply
#7
ok i just didnt want you to think you HAD TO reformat ill have a look at the log but before i open it im thinking driver issue but we will see.
Reply
#8
Thanks for looking at my log Derek, that was one of the main reasons I decided to format my pc was to rule out driver issues, but I suppose time will tell.
Reply
#9
Hi @Derek did you manage to have a look at my log?
I had a look at it but nothing really stood out.
I am desperate to get to the bottom of this problem.
Reply
#10
try max performance for kodi in power settings (3D application in nvidia panel).
And what windows 10 version?
Reply
#11
Thanks, Fullsun, I am using Windows 10 Pro , I am not using the 'N' version with stripped out media player.
I will have a look for 3D application 'Power Settings' when I get back home, but I have to admit I have never seen that setting though.
My only concern is though this is SD video I am watching and I am having to disable De-interlacing to get a smooth picture.
Reply
#12
windows 10 1610 or 1703Huh
Reply
#13
Just checked it is 1703
Reply
#14
Look 'GPU load' in GPU-Z, if you are 100% it's bad.
Reply
#15
Exact smae issue here on an intel i3-3220 with intel hd2500 graphics.
When ill switch on dxva i have to disable deinterlacing (which also will be sets to dxva).
After that its smooth but not deinterlaced.

Also tried, which sadly not solved the issue:
 - sync playback with screen        off
 - change refresh rate                 off
 - Disable DXVA and use software rendering solved the issue, but the cpu load is very high on some HD channels -> fan is going wild. So no soltion.
 - advancedsettings.xml:
 
 <advancedsettings>
  <video>
    <forcedxvarenderer>false</forcedxvarenderer>
  </video>
</advancedsettings>

With the last change in advancedsettings.xml, the video of livetv is not jerky but also not deinterlaced, but the video setting is @dxva !?

Any hints about the issue?

Update!
I have solved the issue. It was the plugin "script.kodi.hue.ambilight" which causes the issues. 
After Deactivating the plugin all was fine.
Sorry for hijacking this thread!

pOpY
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Hardware Acceleration - Issue00