v18 Trouble accessing WHS 2011 NFS share from Xbox Kodi
Judging by other posts, everybody seems to have NFS shares working, but I can't seem to get there.

I have set up an NFS share on my old WHS 2011 box; I have tested from a Win10 client that I can mount/access the NFS share correctly.

When I try to set up an NFS share in Kodi, here's what happens...
_ Add video source > Browse > Network File System (NFS)
_ server IP address ( shows up
_ when "clicking" on IP address, share name ("/Movies") shows up
_ when "clicking" on share name, nothing happens

If I manually type in the NFS URL (nfs://, I get an error msg: "Unable to connect: The connection to the network location couldn't be established. This could be due to the network not being connected. Would you like to add it anyway?"
But the network is clearly connected, otherwise IP address and share name wouldn't show (by the way: tried both wired and wireless)

I have enabled Kodi debug logging, and the relevant errors seem to be...
   ERROR: Failed to open(//) opendir call failed with "NFS: READDIRPLUS of / failed with NFS3ERR_ACCESS(-13)"
   ERROR: XFILE::CDirectory::GetDirectory - Error getting nfs://
Sorry, I can't attach the full debug log, I need an NFS share to copy it onto :-(

I have enable event logging for all event types on the WHS NFS server (mount & unmount, lock & unlock, read & write, create & delete).
If I access the NFS share from my Win10 client, events show up in the Event Log as expected.
If I try to access the share from Xbox/Kodi, not a single event comes through!

Not sure if this is relevant, but the instructions I followed for setting up NFS on WHS 2011 were very specific about the correct NFS URL syntax.
It claims it should be nfs:// (take note of the additional “:”).
However, when trying to enter a URL with an extra ":", Kodi just seems to disregard/delete that.

Any suggestions?

Just to quickly summarize, you've tried the following steps?

1. Click Add Network Location

2. Change the option at the top to NFS.

3. Enter the server address.

4. Under "Remote Path", you type the path alias which is apparently Movies. Have you tried it without the "/"?

Server IP address should be correct, it comes from "Browse" (not typing it in).

Tried remote path both with and without leading "/", makes no difference to error.
Same configuration WHS 2001 with NFS server. I think we need to enter a user names and a password to be able to have access to the files insides the folder. This section is not available in Kodi.
You should grant access for guest to your NFS shares. This is actual for all platforms.
I make the changes. I can see the files in Kodi but I'm not able to start a video or a music files.
Please provide a Debug Log
I've given (built-in) Guest read/write access to the NFS share folder, and double-checked that Guest account is enabled.
Under the NFS sharing properties, I've tried both "Allow unmapped user Unix access (by UID/GID)" and "Allow anonymous access".
No changes: whatever I try, I can't see the contents of the share in Kodi and I keep getting NFS3ERR_ACCESS(-13) error in the debug log file.

@Flatfoot: I'd be keen to understand exactly what you did to at least see the folder contents. You mind giving me some more details?
To see the files, I changes the values of UID/GID (-2) to 0. 
0= Super User. Be careful with this change. Last night I lost all my sharing when I delete a shortcut on Kodi XBOX. I have to remove manually all NFS share on my WHS to be able to see them again on my other systems (Windows, Android).

I changed UID/GID to 0 as well, and was able to see the content of the NFS share.
But I'm not able to play the files inside the share.

I copied kodi.log onto my NFS share, but I end up with a file that nobody has access to (owned by ANONYMOUS LOGON) so can't share here.

The relevant part of the debug log file essentially contains another bunch of NFS3ERR_ACCESS(-13) errors w.r.t. accessing fanart.jpg, the avi file itself, etc.
(2018-01-26, 05:02)esun Wrote: I copied kodi.log onto my NFS share, but I end up with a file that nobody has access to (owned by ANONYMOUS LOGON) so can't share here.
You can always change an owner for a file to yourself.
> sudo chown $(id -u):$(id -g) path/xbmc.log
This is WHS 2011, remember?

I tried all the usual Windows tricks to change ownership of a file, to no avail.
The problem with the kodi.log file ownership led me to some sort of solution.

If I give user ANONYMOUS LOGON read/write access to the share, I can not only see the files but I can also play/execute them.
That's if I set the NFS share properties to "Allow anonymous access" with UID & GID set to 0.
(screenshot: http://prntscr.com/i5tq47)

The preferred option would be to use the default "Allow unmapped user Unix access"
I'm wondering if the built-in Guest account is different from what is being used?
(2018-01-26, 11:49)esun Wrote: This is WHS 2011, remember?

Ok, my fault. But you can get ownership of a file at Security tab in file properties or by takeown.exe. don't you?

Logout Mark Read Team Forum Stats Members Help
Trouble accessing WHS 2011 NFS share from Xbox Kodi0
This forum uses Lukasz Tkacz MyBB addons.