•   
  • 1
  • 383
  • 384
  • 385(current)
  • 386
  • 387
  • 515
  •   
Kodi DSPlayer – DirectShow Player for Windows
(2018-03-19, 22:57)Warner306 Wrote:
(2018-03-19, 17:26)bivab Wrote: Hi guys!

I've been using Kodi (DSPlayer) for a very long time and really appreciate the hard work being done by the developers. Having Kodi with MadVR + LAV is just plain awesome.

QUESTION #1

However, I have run into a bug that only started occurring after I swapped my Marantz SR 5009 receiver for a B&W Panorama 2 soundbar. It seems that when I bitstream Dolby Digital (Plus) the audio delay is not applied. If I choose to transcode Dolby into LPCM the audio delay works as expected. This also happens with DTS, although only if I switch audio tracks. If the DTS track was selected when starting the video it works.

The built-in VideoPlayer does not show these issues. 

I noticed the changelog for the latest build mentions fixing an issue related to just this what I described, but it's that version that I'm currently using. I also tried the 32-bit version and older versions up to 17.2, but they all have this issue.

QUESTION #2

My B&W Soundbar unfortunately does not support transcoding DTS-HD or Dolby TrueHD, but apparently also does not support multi-channel LPCM (only stereo). I have contacted B&W about this issue, but have gotten no reply yet. Can someone tell me what is theoretically better: bitstream Dolby Digital Plus (640kbps) or downmix Dolby TrueHD into LPCM 2.0 with Dolby Pro Logic II encoding?

Thanks!
 Hard to tell what is going on. You could try another audio renderer like ReClock. Remember, it is only 32-bit. This would most likely be something to do with Sanear. The default audio renderer might also work. Although, it is not WASAPI exclusive. But that isn't important when using a soundbar.

For the second question, bitstreaming would be preferred. But use whatever works. You would have one less conversion, which is the better scenario. 
 Thanks, I will try out ReClock. What I forgot to mention is that I noticed when the audio delay is not applied, the taskbar icon of LAV audio is also not visible. It seems like the LAV Audio renderer is somehow not started or bypassed? Is LAV Audio still required if the audio is bitstreamed and not transcoded?
Reply
(2018-03-20, 10:02)bivab Wrote:
(2018-03-19, 22:57)Warner306 Wrote:
(2018-03-19, 17:26)bivab Wrote: Hi guys!

I've been using Kodi (DSPlayer) for a very long time and really appreciate the hard work being done by the developers. Having Kodi with MadVR + LAV is just plain awesome.

QUESTION #1

However, I have run into a bug that only started occurring after I swapped my Marantz SR 5009 receiver for a B&W Panorama 2 soundbar. It seems that when I bitstream Dolby Digital (Plus) the audio delay is not applied. If I choose to transcode Dolby into LPCM the audio delay works as expected. This also happens with DTS, although only if I switch audio tracks. If the DTS track was selected when starting the video it works.

The built-in VideoPlayer does not show these issues. 

I noticed the changelog for the latest build mentions fixing an issue related to just this what I described, but it's that version that I'm currently using. I also tried the 32-bit version and older versions up to 17.2, but they all have this issue.

QUESTION #2

My B&W Soundbar unfortunately does not support transcoding DTS-HD or Dolby TrueHD, but apparently also does not support multi-channel LPCM (only stereo). I have contacted B&W about this issue, but have gotten no reply yet. Can someone tell me what is theoretically better: bitstream Dolby Digital Plus (640kbps) or downmix Dolby TrueHD into LPCM 2.0 with Dolby Pro Logic II encoding?

Thanks!
 Hard to tell what is going on. You could try another audio renderer like ReClock. Remember, it is only 32-bit. This would most likely be something to do with Sanear. The default audio renderer might also work. Although, it is not WASAPI exclusive. But that isn't important when using a soundbar.

For the second question, bitstreaming would be preferred. But use whatever works. You would have one less conversion, which is the better scenario.   
 Thanks, I will try out ReClock. What I forgot to mention is that I noticed when the audio delay is not applied, the taskbar icon of LAV audio is also not visible. It seems like the LAV Audio renderer is somehow not started or bypassed? Is LAV Audio still required if the audio is bitstreamed and not transcoded?  
 LAV Audio is part of the decoding, not rendering, process, so it is always used.
Reply
(2018-03-20, 16:38)Warner306 Wrote:
(2018-03-20, 10:02)bivab Wrote:
(2018-03-19, 22:57)Warner306 Wrote:  Hard to tell what is going on. You could try another audio renderer like ReClock. Remember, it is only 32-bit. This would most likely be something to do with Sanear. The default audio renderer might also work. Although, it is not WASAPI exclusive. But that isn't important when using a soundbar.

For the second question, bitstreaming would be preferred. But use whatever works. You would have one less conversion, which is the better scenario.   
 Thanks, I will try out ReClock. What I forgot to mention is that I noticed when the audio delay is not applied, the taskbar icon of LAV audio is also not visible. It seems like the LAV Audio renderer is somehow not started or bypassed? Is LAV Audio still required if the audio is bitstreamed and not transcoded?      
 LAV Audio is part of the decoding, not rendering, process, so it is always used.    
 I tried using it with ReClock but it gave me no audio at all. Then I noticed that my renderer was previously not set to [Sanear] but to [Directsound Panarama...]. Changing it to Sanear did not fix the issue however.

Pressing 'O' during bitstreaming of Dolby Digital did show me that LAV Audio was not used as a filter, but Microsoft DTV-DVD Audio decoder. When playing a file with DTS it was using LAV Audio. If I switched audio tracks during playback (of the file with DTS) then it switched to the Microsoft DTV-DVD decoder again and audio was not in sync anymore.

Is there some configuration or merits that I somehow messed up?

EDIT:

When I disabled bitstreaming Dolby Digital then the LAV Audio decoder is used again. Enabling this will use the Microsoft decoder.

EDIT #2:

In my first post I mentioned that the B&W Panorama 2 did not support multichannel LPCM. I assumed this because the Windows Sound control panel only shows stereo (2.0) channels for the device, while with my previous receiver I was able to select anything up to 7.1. Using Custom Resolution Utility I was able to "hack" the driver and enable more channels for LPCM, but if you do the test sound on Windows, only the left and right channel would play sounds.

Now I downloaded both a Dolby TrueHD and DTS-HD speaker mapping file and played these with DSPlayer. The files will play sounds discretely through each channel. To my surprise I am able to clearly distinguish all the channels being played. In this setup those HD tracks are transcoded into LPCM by LAV audio and I have disabled mixing. The only strange this is the the subwoofer channel (LFE) is inaudible, while if I bitstream the DTS Core track the LFE channel is clearly audible.

SANITY CHECK
Am I correct to assume that using the Sanear audio renderer, with exclusive mode enabled and the mixer disabled, LAV Audio will just transcode all channels into LPCM and send 8 channel LPCM over HDMI to the Panorama? The fact that I am able to hear all channels means the Panorama actually supports multichannel LPCM, and there's no downmixing to 2.0 happening somewhere in Windows?

Another thing I found is that when you disable bitstreaming DTS-HD (but enable DTS) it will always prefer bitstreaming the DTS Core track instead of transcoding the DTS-HD track into LPCM. If I disable bitstreaming DTS it will choose the DTS-HD track and transcode that one.
Reply
(2018-03-20, 20:18)bivab Wrote:
(2018-03-20, 16:38)Warner306 Wrote:
(2018-03-20, 10:02)bivab Wrote:  Thanks, I will try out ReClock. What I forgot to mention is that I noticed when the audio delay is not applied, the taskbar icon of LAV audio is also not visible. It seems like the LAV Audio renderer is somehow not started or bypassed? Is LAV Audio still required if the audio is bitstreamed and not transcoded?      
 LAV Audio is part of the decoding, not rendering, process, so it is always used.     
 I tried using it with ReClock but it gave me no audio at all. Then I noticed that my renderer was previously not set to [Sanear] but to [Directsound Panarama...]. Changing it to Sanear did not fix the issue however.

Pressing 'O' during bitstreaming of Dolby Digital did show me that LAV Audio was not used as a filter, but Microsoft DTV-DVD Audio decoder. When playing a file with DTS it was using LAV Audio. If I switched audio tracks during playback (of the file with DTS) then it switched to the Microsoft DTV-DVD decoder again and audio was not in sync anymore.

Is there some configuration or merits that I somehow messed up?

EDIT:

When I disabled bitstreaming Dolby Digital then the LAV Audio decoder is used again. Enabling this will use the Microsoft decoder.

EDIT #2:

In my first post I mentioned that the B&W Panorama 2 did not support multichannel LPCM. I assumed this because the Windows Sound control panel only shows stereo (2.0) channels for the device, while with my previous receiver I was able to select anything up to 7.1. Using Custom Resolution Utility I was able to "hack" the driver and enable more channels for LPCM, but if you do the test sound on Windows, only the left and right channel would play sounds.

Now I downloaded both a Dolby TrueHD and DTS-HD speaker mapping file and played these with DSPlayer. The files will play sounds discretely through each channel. To my surprise I am able to clearly distinguish all the channels being played. In this setup those HD tracks are transcoded into LPCM by LAV audio and I have disabled mixing. The only strange this is the the subwoofer channel (LFE) is inaudible, while if I bitstream the DTS Core track the LFE channel is clearly audible.

SANITY CHECK
Am I correct to assume that using the Sanear audio renderer, with exclusive mode enabled and the mixer disabled, LAV Audio will just transcode all channels into LPCM and send 8 channel LPCM over HDMI to the Panorama? The fact that I am able to hear all channels means the Panorama actually supports multichannel LPCM, and there's no downmixing to 2.0 happening somewhere in Windows?

Another thing I found is that when you disable bitstreaming DTS-HD (but enable DTS) it will always prefer bitstreaming the DTS Core track instead of transcoding the DTS-HD track into LPCM. If I disable bitstreaming DTS it will choose the DTS-HD track and transcode that one. 
 For ReClock, you need to configure it outside of Kodi. It has its own control panel. But this doesn't sound like your problem.

The Microsoft DTV-DVD Audio decoder is news to me. I don't know if this is normal behavior or not. I assume you are using internal filters? Each filter should appear under codec info (O) with a little (i) beside it.

If letting LAV Audio do the decoding for you is working, I would stick with it. Otherwise, there may be no other solution. There should be no quality loss if you don't need Dolby Atmos or DTS:X.
Reply
(2018-03-21, 16:12)Warner306 Wrote:
(2018-03-20, 20:18)bivab Wrote:
(2018-03-20, 16:38)Warner306 Wrote:  LAV Audio is part of the decoding, not rendering, process, so it is always used.     
 I tried using it with ReClock but it gave me no audio at all. Then I noticed that my renderer was previously not set to [Sanear] but to [Directsound Panarama...]. Changing it to Sanear did not fix the issue however.

Pressing 'O' during bitstreaming of Dolby Digital did show me that LAV Audio was not used as a filter, but Microsoft DTV-DVD Audio decoder. When playing a file with DTS it was using LAV Audio. If I switched audio tracks during playback (of the file with DTS) then it switched to the Microsoft DTV-DVD decoder again and audio was not in sync anymore.

Is there some configuration or merits that I somehow messed up?

EDIT:

When I disabled bitstreaming Dolby Digital then the LAV Audio decoder is used again. Enabling this will use the Microsoft decoder.

EDIT #2:

In my first post I mentioned that the B&W Panorama 2 did not support multichannel LPCM. I assumed this because the Windows Sound control panel only shows stereo (2.0) channels for the device, while with my previous receiver I was able to select anything up to 7.1. Using Custom Resolution Utility I was able to "hack" the driver and enable more channels for LPCM, but if you do the test sound on Windows, only the left and right channel would play sounds.

Now I downloaded both a Dolby TrueHD and DTS-HD speaker mapping file and played these with DSPlayer. The files will play sounds discretely through each channel. To my surprise I am able to clearly distinguish all the channels being played. In this setup those HD tracks are transcoded into LPCM by LAV audio and I have disabled mixing. The only strange this is the the subwoofer channel (LFE) is inaudible, while if I bitstream the DTS Core track the LFE channel is clearly audible.

SANITY CHECK
Am I correct to assume that using the Sanear audio renderer, with exclusive mode enabled and the mixer disabled, LAV Audio will just transcode all channels into LPCM and send 8 channel LPCM over HDMI to the Panorama? The fact that I am able to hear all channels means the Panorama actually supports multichannel LPCM, and there's no downmixing to 2.0 happening somewhere in Windows?

Another thing I found is that when you disable bitstreaming DTS-HD (but enable DTS) it will always prefer bitstreaming the DTS Core track instead of transcoding the DTS-HD track into LPCM. If I disable bitstreaming DTS it will choose the DTS-HD track and transcode that one.  
 For ReClock, you need to configure it outside of Kodi. It has its own control panel. But this doesn't sound like your problem.

The Microsoft DTV-DVD Audio decoder is news to me. I don't know if this is normal behavior or not. I assume you are using internal filters? Each filter should appear under codec info (O) with a little (i) beside it.

If letting LAV Audio do the decoding for you is working, I would stick with it. Otherwise, there may be no other solution. There should be no quality loss if you don't need Dolby Atmos or DTS:X. 
 Yes, I'm using the Internal Filters and not an external configuration file. If transcoding the tracks into LPCM comes without quality loss (compared to decoding by the receiver) then I'm fine with using it, although I wonder if the receiver does some extra special "surround" magic when it detects DD/DTS. Hopefully a future version of Kodi/Dsplayer will automagically fix this issue for me.

Thanks for your time, @Warner306.
Reply
There is no transcoding to PCM. The untouched audio is simply unpacked into separate channels. This would still be considered lossless unless you are doing some type of mixing with this data. LAV Audio and audio renderers can alter PCM tracks. But this can be bypassed with correct configuration (simply ignore the mixing tab in LAV Audio and don't use ReClock's media speed correction and choose WASAPI Exclusive). Then it is lossless.
Reply
(2018-03-21, 19:52)Warner306 Wrote: There is no transcoding to PCM. The untouched audio is simply unpacked into separate channels. This would still be considered lossless unless you are doing some type of mixing with this data. LAV Audio and audio renderers can alter PCM tracks. But this can be bypassed with correct configuration (simply ignore the mixing tab in LAV Audio and don't use ReClock's media speed correction and choose WASAPI Exclusive). Then it is lossless.
 Alright, good to know. So it's more decoding/unzipping rather than transcoding?

I tried disabling the Microsoft DTV-DVD decoder using this tutorial, hoping DSPlayer would fallback to LAV Audio, but this resulted in NO audio being played. The MS decoder is no longer present as a filter, but LAV audio neither. I guess I'll have to wait for a DSPlayer update, hoping it's not my machine that's in the wrong here.
Reply
Superior player! He help me with this problem
https://forum.kodi.tv/showthread.php?tid=258524&page=7

But, boblight is not supported?
Reply
mclingo   with madVR there is Full HDR Support. And Kodi 18 has good improvements in live TV part. And Netflix Addon is only working with Kodi 18..
Reply
(2018-03-21, 23:28)Gee11 Wrote: mclingo   with madVR there is Full HDR Support. And Kodi 18 has good improvements in live TV part. And Netflix Addon is only working with Kodi 18..
 what do you mean by full, does it (A) pass metadata to your TV automatically and enable HDR mode on your HDR TV if you have one, and (B) automatically convert HDR material to SDR if you havent got a HDR display?

I tried the latest nightly, I  found no HDR options or settings beyond some colour calibration controls in system, and when I played a HDR movie it tried to convert it to SDR, it looked terrible, seems far from ready to me.
Reply
i've pretty much got kodi-dsplayer working without troubles on my system.

apart from one thing, custom display modes in madvr. for the life of me i cant get it to work properly. either there is a bug in nvidia or madvr.

i'm trying to optimise the currant timings and not create new ones.

when i optimise the 23hz mode by playing a video to create the timings it seems that its confused with 24hz as well.
this is evident in that when the 23hz mode has been optimised it also creates timings for the 24hz at the same time. i know this as when i press optimise on 24hz it brings up an optimised list even though i have not optimised it with playing a video.
when i change to one of the optimised timing modes in 23hz and 'test' it changes the mode no problem, but it does not register with dsplayer when i press crtl+j and the timings are staying the same as before optimisation and displaying 4-5min.

this is pretty much my last hurdle that i have to jump.
Reply
(2018-03-21, 23:28)Gee11 Wrote: mclingo   with madVR there is Full HDR Support. And Kodi 18 has good improvements in live TV part. And Netflix Addon is only working with Kodi 18..
Considering the Netflix addon is a "legit" one, if I'm not mistaken (ie. it requires you have a payed for subscription), would you be so kind as to point me to the website that hosts it? Thank you.
For troubleshooting and bug reporting please make sure you read this first.
Reply
(2018-03-21, 21:50)Die$el Wrote: Superior player! He help me with this problem
https://forum.kodi.tv/showthread.php?tid=258524&page=7

But, boblight is not supported?
 Boblight is not supported and will probably never be supported. Sorry.
Reply
(2018-03-21, 21:39)bivab Wrote:
(2018-03-21, 19:52)Warner306 Wrote: There is no transcoding to PCM. The untouched audio is simply unpacked into separate channels. This would still be considered lossless unless you are doing some type of mixing with this data. LAV Audio and audio renderers can alter PCM tracks. But this can be bypassed with correct configuration (simply ignore the mixing tab in LAV Audio and don't use ReClock's media speed correction and choose WASAPI Exclusive). Then it is lossless.
 Alright, good to know. So it's more decoding/unzipping rather than transcoding?

I tried disabling the Microsoft DTV-DVD decoder using this tutorial, hoping DSPlayer would fallback to LAV Audio, but this resulted in NO audio being played. The MS decoder is no longer present as a filter, but LAV audio neither. I guess I'll have to wait for a DSPlayer update, hoping it's not my machine that's in the wrong here. 
 LAV Audio might use that decoder. I don't know. It seems like a strange thing for aracnoz to miss in testing.
Reply
(2018-03-22, 16:30)Warner306 Wrote:
(2018-03-21, 21:39)bivab Wrote:
(2018-03-21, 19:52)Warner306 Wrote: There is no transcoding to PCM. The untouched audio is simply unpacked into separate channels. This would still be considered lossless unless you are doing some type of mixing with this data. LAV Audio and audio renderers can alter PCM tracks. But this can be bypassed with correct configuration (simply ignore the mixing tab in LAV Audio and don't use ReClock's media speed correction and choose WASAPI Exclusive). Then it is lossless.
 Alright, good to know. So it's more decoding/unzipping rather than transcoding?

I tried disabling the Microsoft DTV-DVD decoder using this tutorial, hoping DSPlayer would fallback to LAV Audio, but this resulted in NO audio being played. The MS decoder is no longer present as a filter, but LAV audio neither. I guess I'll have to wait for a DSPlayer update, hoping it's not my machine that's in the wrong here.  
 LAV Audio might use that decoder. I don't know. It seems like a strange thing for aracnoz to miss in testing. 
 Okay, so I hooked up an entirely different machine (with an AMD APU instead of Intel + GTX 970) with a fresh Windows 10 64-bit installation. I only copied over my library and GUI settings and changed some basic settings for DSPlayer. When I start playing a video with Dolby Digital (with bitstreaming enabled) Kodi will now crash. If I play a file with DTS it will play correctly (and use LAV Audio). When I disabled bitstreaming Dolby Digital and let LAV decode the audio for me, Kodi does not crash and will play the file (using LAV Audio filter).

I don't know, but it feels like something's not entirely right here.

I'm happy to provide whatever info if someone feels up for a challenge Wink.
Reply
  •   
  • 1
  • 383
  • 384
  • 385(current)
  • 386
  • 387
  • 515
  •   



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows47
This forum uses Lukasz Tkacz MyBB addons.