•   
  • 1
  • 9
  • 10
  • 11(current)
  • 12
  • 13
  • 77
  •   
Release IPTV Recorder
Installed version 22 this morning.
Addon now to starts to finding streams and creating database, so it is improved; at the end i got an error again.
Checked the channels lists, i can see the groups but they are not opening...

Here is the log:
https://pastebin.com/E0zUJQ1U
Reply
Post an example EXTINF line from your m3u with a Belgium channel with non-ascii characters.
Reply
Here is an example, i removed dns address port etc...

https://pastebin.com/bj2JgAf3
Reply
You have explicitly set tvg-ID="" so all your tvg_id's are not null but the empty string.
If you either fill them in with the ids that match channel id in the xmltv or remove the tvg-ID="" completely it should work.
Reply
If you're lucky 0.0.23 will match your streams to the channels.
Give it a try.
Reply
Version 0.0.21 working perfect here mate. What an awesome addon.
Reply
Thx will check later...
XML list is provided by my provider so i do not know the id's...
Reply
(2018-04-15, 17:21)wigee Wrote: Thx will check later...
XML list is provided by my provider so i do not know the id's...
 The ids are the ones from your xmltv file:
Code:
<channel id="YOUR ID HERE"
which should match your m3u
Code:
tvg-id="YOUR ID HERE"
Reply
EPG won't load again, only thing I notice is that the progress % for scanning the xmltv file stops at 92% before I get an error message

https://pastebin.com/czudqu6M

xmltv.db seems to have no data in it also
Reply
(2018-04-16, 03:21)hotshot2k3 Wrote: EPG won't load again, only thing I notice is that the progress % for scanning the xmltv file stops at 92% before I get an error message

https://pastebin.com/czudqu6M

xmltv.db seems to have no data in it also
 It is either because a program has no title, which I find hard to believe but is possible, or your xmltv Title regex has replaced everything in the title with nothing.
The line that fails is just after the regex replacement.
https://github.com/primaeval/plugin.vide...n.py#L1924

What have you got in your xmltv Title Search and Replace settings?

The other possibility is that you have a title on multiple lines.
Have you got something like this in your xmltv file?
Code:
<title>my program
</title>
Reply
I've put some code in to handle multiline <title> fields in 0.0.27.
See if that was the problem.
Reply
Lots of my issues are solved since version 0.0.27.
I can now open the Belgium list and almost all channels have epg and are working
still have an error on one channel
See logs:
https://pastebin.com/CjW2M7aS

Thx for the effort
Ps: Later this week i will test with xtream m3u list as via this way i have more EPG.
This was also not working after update that changed it to XML.
Reply
0.0.28 might fix it. There was a double utf8 encoding of xmltv program titles.
If not post or pm me a link to your xmltv file.
It might need a file encoding detection call.
Reply
I've added the same file encoding detection in for xmltv as for the m3u files in 0.0.29.
Let's see if that detects the proper encoding.
What does the first line of your xmltv file say? The one starting with <?xml
Reply
Working for me now, it takes like 5 times longer to make the xmltv.db so I just have to be patient each time it is created
Reply
  •   
  • 1
  • 9
  • 10
  • 11(current)
  • 12
  • 13
  • 77
  •   
 
Thread Rating:
  • 4 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
IPTV Recorder54