When playing music from the FILE menu, I can not see the FANART in KODI 18
#1
When playing music from the FILE menu, I can not see the FANART. (When playing from the media library, the fanart is visible). In the KODI 17 this works. Transferred my question here, because this is very important to use KODI 18. It is not always convenient to search for music through the library, it is more convenient to search for music directly on HDD from the file menu.

DaveBlake wrote
Quote:@aleksobs my attention has been gained. Please don't bother with a Trac ticket, I am far more responsive to forum posts than Trac. I'll take a look first thing tomorrow.

I see the player screeshots. Have you added this music to the music library, or are you only using file view? Does fanart and artists thumbs show on the artists node (listing artists)?

If you could upload a copy of your music database - MyMusic70.db - somewhere and PM me a link that would be most helpful.

Ping me in your reply, it also may be clearer to split these posts and move them to the music support forum  rather than clutter this already huge thread.
1. I added this music to the music library.
2. Yes, fanart and artists thumbs show on the artists node (listing artists). Of course not all, but many.
3. Link to my MyMusic70.db

1. New LibreELEC.tv Leia build #0428
Image.

2. LibreELEC-RPi2.arm-8.2.5.

Image

Image
Image


Fanart is not visible not only during playback, but also when you move the cursor over a song list.

From file menu
Image

From music library
Image
Reply
#2
Thanks for posting, I am able to reproduce and will I'll look into fixing it. I do not need any logs or your music database.  I will post here when I have something for you to try.

On a different note, you say
Quote:It is not always convenient to search for music through the library, it is more convenient to search for music directly on HDD from the file menu.
Improving the library so that it is more convenient to use interests me greatly, it is why I started contributing to Kodi and ended up on the dev team. If you have particular things that cause you problems then open a thread about those. I may not be able to help, or you may inspire me with new ideas or encourage me to do something I have been considering. All I ask is that you are friendly and encouraging (as opposed to expectant and demanding), and remember that Kodi is developed and supported entirely by volunteers in our spare time.
Reply
#3
Thank you for your answer, KODI is the best, I really like it, thank you for your work, I will definitely make a voluntary contribution to the development of this project. But while I use KODI 17, because of the FANART. But I will monitor the development of the project, thank you again!
Reply
#4
I tried all the versions. The last version where it worked, was - LibreELEC-RPi2.arm-9.0-Milhouse-20180115215804-#0115x-gcd45cd6.tar. Help, please fix it!
Reply
#5
Stop nagging!!! I have raised a PR to fix this, and I will let you know once it has  been reviewed, approved, and  merged and is in the Millhouse builds for you to test, OK.
Reply
#6
A simple fix that gives artist fanart when playing albums/songs that are in the music library from file view  was included in Millhouse build #0505
Yet @aleksobs you reported
(2018-05-06, 19:16)aleksobs Wrote:  Hi! I tested build 0505 the error is still present. FANART is not visible.
 
Is this because you were testing with playing albums or songs that were not in your music library?
Reply
#7
No, all the playing albums and songs is in my music library. But I plaing music from file menu. 
Maybe in this is the problem. The album information is not displayed. Even the button is not active. Build @LibreELEC-RPi2.arm-9.0-Milhouse-20180508210314-#0508-g8463ee0
Image

In build 0115, the album information button is active. You can manually get information about the album. After that, all the pictures are displayed on the screen.
Image
Reply
#8
When I use #0505 to play library music from file view I see the artist fanart, so it is a puzzle why you don't.

I have to doubt that you are looking at files on a music source that have been scanned into the library. The fact that when looking at the song information dialog for a music file from file view you do not have the album information button enabled also indicates that that music is not scanned into the library. Be aware it needs to be the file that has been scanned, not a copy in some other location of a song that has the same title and artist.

Also how do you play from file view - do you view the files and hit play, or play a (album or artist) folder? Or do you add items to the queue and then go to current playlist? Keyboard shortcut or context menu?
Reply
#9
(2018-05-09, 16:01)DaveBlake Wrote: Also how do you play from file view - do you view the files and hit play, or play a (album or artist) folder? Or do you add items to the queue and then go to current playlist? Keyboard shortcut or context menu?
The misic files is a FLAC with CUE and separate files in folders.  All music put on music library.
For understanding the problem, I enclose a video.
1. Build 0115 all good!
0115

2. Build 0508 (It also periodically reboots itself. Unstable.)
1. 0508 part 1​​​
2. 0508 part 2 
3. 0508 part 3
Reply
#10
Thank you for the useful video clips.

Part 3 shows fanart for library songs on playback from file view of (album) folder above. This is what I was seeing and a result of the fix that was included in #0505 onwards. But I see now only a partial fix.

Part 1 shows playback from the music file itself not showing fanart. I can reproduce that, understand the cause and I will produce a fix.

Part 2 shows the Song Infomation dialog not allowing you to navigate right to the "Album Information" button, and yet the button appears to be enabled (not disabled as I initially thought, implying not in library). I think this is a problem with the Estuary skin, perhaps test with Confluence to confirm.

Other things to try with the Estuary skin: Do you have a mouse connected to your Pi, and if so can you try to click the "Album Information" button using the mouse? Otherwise try stepping through the buttons using move left instead of move right.  I also see different buttons to you - "Play", "Set my rating", "Choose Art", "Album Information" - not "Search YouTube".  I would guess that there is an addon adding the "Search YouTube" button. Perhaps the skin problem is related to whatever is adding the "Search YouTube" button, or maybe this is not Estuary? Either way I think this is a separate issue from seeing fanart.

Someone else is working on the cash while navigating files issue, and we hope to have a more stable build available soon.
Reply
#11
The skin could be one of the mods of Estuary.
Reply
#12
I can confirm that the button navigation behaviour on the song information dialog is skin related, a fix to Estuary has been raised (by another dev).

Meanwhile a fix restoring the fanart from file view is in the Millhouse build #0510. Not only does this restore the old functionality, it extends it to cover all types of artist art not just fanart, and multiple artists (if song has guest artists or is a collaboration album) not just the primary one. You will only see this in skins  that show this extra art (not Estuary). See PR13871

No doubt you will feedback @aleksobs once you have tested this.
Reply
#13
Thank you very much for your work and understanding. It's easier for me to post videos than to try to explain in English. FANART is now available, and it's very cool.
And sorry for my nagging)))
Reply
#14
(2018-05-10, 09:52)jjd-uk Wrote: The skin could be one of the mods of Estuary.
No, the skin Estuary is standart of LibreElec - 8.2.5. I did not install other modes of this skin. Now I tested Confluence, with the same result.
Reply
#15
(2018-05-11, 14:07)aleksobs Wrote: No, the skin Estuary is standart of LibreElec - 8.2.5. I did not install other modes of this skin.
Estuary does not have "Youtube Serach" button by default, something has added this.

But Estuary does have problem with button navigation. The "Album Information" button is enabled, but <move right> is not able to reach it. Try <move left> instead, or a mouse.


Quote: Now I tested Confluence, with the same result. 
What same result? No fanart? Odd button navigation? What buttons? Not that I am going to look into skin issues, it is not my area of knowledge.

But most importantly you are now seeing fanart for items in fileview.
Reply



Logout Mark Read Team Forum Stats Members Help
When playing music from the FILE menu, I can not see the FANART in KODI 180
This forum uses Lukasz Tkacz MyBB addons.