v18 Scrapers not working on Leia Alpha 2
#1
Good evening

Yesterday I installed the 64bit Version of Kodi 18 on Win10 and up to now it couldn't create a library because when the scrapers want to scan I get the error "Unable to connect to remote server..."

The Add-On Versions for IMDB is 2.0.5 and 5.1.1 (don't know why I have 2 of them... found 2 in your add-on section) and for TVDB it is 3.0.6. Had to update manually as the autoupdate didn't work. I installed the new Versions only in the 2nd installation.

I also made 2 second installation of Kodi cause I thaught maybe the first screwed up, but no effect. I allowed Kodi a path through the windows firewall, no effect.
The system information of Kodi says the internet connection is running, although I couldn't verify that cause I couldn't install the youtube add-on or a weather add-on (error while installing). So I don't have any more clues what to do.

The latest logfile is here.

Maybe an older 32bit version would work but as I run the 64bit version of Win10 i'd rather not.

Mogwai72
Reply
#2
(2018-07-05, 00:49)Mogwai72 Wrote: The Add-On Versions for IMDB is 2.0.5 and 5.1.1
You should have IMDB Scraper Library v2.9.2 and TheMovieDatabase v5.1.3 installed. Update these and it should work.

Go to Add-ons>My Add-ons. Pull out the left sideblade menu and select Check for updates
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
Thank you for your quick reply, i will try this this evening. Although when i went directly to the add-ons and checked for updates i got the reply that no new version is available.

Mogwai72
Reply
#4
(2018-07-05, 01:16)Karellen Wrote:
(2018-07-05, 00:49)Mogwai72 Wrote: The Add-On Versions for IMDB is 2.0.5 and 5.1.1
You should have IMDB Scraper Library v2.9.2 and TheMovieDatabase v5.1.3 installed. Update these and it should work.

Go to Add-ons>My Add-ons. Pull out the left sideblade menu and select Check for updates 
 I just tried this but nothing happens except that for half a second the message "Checking for Updates: 0%" appears in the upper right corner and disappears again. Seems like a car with no engine, looks nice but you can't drive :-). Maybe i'll give it a shot with the Nightly Version.

Mogwai72
Reply
#5
No, updating to the nightly version will still require you to download the latest versions.

Check that you have not disabled auto-updates in the Add-on settings and in the main settings page at Settings>System Settings>Add-ons

If you still cant find the problem, then Download and install from zip...

mirrors.kodi.tv/addons/leia/
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#6
When I try to install this metadata.themoviedb.org-5.1.3 I get an error message brabling something about "dependency on script"... Also if I try to install the latest youtube add-on.

I think it doesn't matter where Kodi is installed, right? I put it on a separate SD-Card which is drive D:\. Or maybe it has something to do with the big Win10 Update (fall creators)?

Auto Update is on. I would like to check if Kodi really has internet connection but how if I can't install youtube or tv add-ons?

Mogwai72
Reply
#7
In your log, it showed you using v18. Is that the version you tried installing the zip file into because that zip is for v18.

(2018-07-06, 01:00)Mogwai72 Wrote: I think it doesn't matter where Kodi is installed, right?
It depends... Did you use Portable Mode? https://kodi.wiki/view/HOW-TO:Install_Ko...table_Mode

Can you provide another log with libcURL selected in Component Logging. Remember to enable Debug mode again. Both are in Settings>System Settings>Logging

Then restart.
Locate a movie not in your library via Videos>Files, then press the Information button to start the scan of that movie.

Upload and tell us which movie.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#8
No I did not use portable mode, might try this later.

Yes, the Zips were for V18 which I installed (took them from your download link).

One good news is: out of curiosity I deinstalled V18 and installed V17 32Bit and here the scraping works fine, what I actually would not have expected. Also installing add-ins works fine (like weather stuff) which also did not work in V18. Quiet strange... I just had to update the content in my sources (did not delete profile while deinstalling).

V17 was also installed on the SD-Card as drive D:\.

I guess it's not such a good idea to have two versions installed at the same time, right? So I could keep the running V17 and keep on figuring out what't the matter with V18. Could it work with different installation folders?

Mogwai72
Reply
#9
It is no problem having two versions installed on Windows as long as you use Portable Mode. Personally I currently have 4 versions installed on my test/office machine. As long as you use Portable Mode, they never conflict with each other. Your v17.6 can be a standard install, but each subsequent install must be Portable Mode.

I am seeing some cURL errors but I am not sure if it is due to a general problem or because of the incorrect scraper versions, which is why I asked for another log. Also when creating that log, try installing an add-on in addition to scraping the movie.

Can you also update to the latest nightly.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#10
I installed the latest nightly version (from July 6th) as portable version.

The errors still occur. I tried to identify the movie "28 Days later" manually and after that I tried to install the youtube add-on from zipfile.

I also wanted to try to setup the weather add-on, but when I click on "Get more" it's all empty, there is no add-on to choose from where there should be about five.

Here is the latest logfile: LINK

Thanks a lot for your help.

Mogwai72
Reply



Logout Mark Read Team Forum Stats Members Help
Scrapers not working on Leia Alpha 20
This forum uses Lukasz Tkacz MyBB addons.