TVDB are updating their site. Their site currently has a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are working to rectify the problems.

Kodi 18 only playing one music track
Thanks John the cleaner log file will be easier to share with other devs, the issue looks player related to me so I'll need some team help. I'll be back with questions no doubt, and debug settings as needed.

Meanwhile do check what queued video does, and can you give details of what device you are running Kodi on.
(2018-09-01, 01:57)dawsonjw Wrote: Hi
   sorry dumb question coming.  In the specific logging window, which one does the NFS logging.  It is not mentioned there.


 I'd try the CURL logging.  Think curl handles NFS (as well as a bunch of other protocols).
Learning Linux the hard way !!
Hi Dave,

       ok did some testing with video queuing.  First thing I noticed was that the queue list actually had 100's of items in it.  Not sure why as I never actually use queuing specifically.  Anyway I cleared the queue and tagged a few different videos.  It works, they play one after the other off the same NAS the music files are stored.  Looked at the queue list and the items I just tagged are still there.  Is that right, as I would have thought these would get cleared once complete...

Went to the music and checked the queue list.  Lots of items in this queue too.  So I cleared it and tagged a few items.  The first one plays and that's it.  Tagged items are left in the queue.

My hardware is Minix Neo U1. 


Hi Dave,
             did the music test again this time with the CURL logging turned on.

ilosovelej (paste)


Thanks John, I'll see if anyone else on the team can identify what is happening here but it may take a while.

I'm running Win 10, latest Nightlies

all was ok the just one day no longer playing next tracks, I dont think that I changed anything in the setup

Normally I chose from the menu bar left side, MUSIC, click on it , then  SONGs and choose any title to play, then with Yatse shuffle on so that it just plays 

For a whole day this would not work and then it started working, the only change was I hovered over MUSIC and choose songs from the top menu bar, this started just fine with tracks play as they should be, since then all is fine again which ever way I choose the first track

If you wants logs just ask

I am unable to find anyone on the team that can repeat this issue or guess at a cause, also I suspect that the OP with a temporary issue on Windows OS experienced something different from what is happening on Android.

@dawsonjw you said "Worked OK a few weeks back", any chance that you could install various nightly builds and identify exactly which build this problem starts with. It is a little tedious, but without narrowing it down to a particular day I really can't find what change has triggered this regression.

BTW the currently playlist behaviour you saw is perfectly normal, itens stay there until a new album is played
Hi Dave
             Ok, I'll try to see when this started.   I have been tied up with family issues for the past few days but will get stuck into it now.  Oh any ideas on what can be done with the issue with Black Glass Nova and the skin helper issue you noted from the first log I sent you. 


Hi Dave,
            ok managed to fix the problem. 

The story goes...

Installed as far back as the install program would let me, which is about two weeks.  After that it won't allow a previous version.   Anyway problem was still there.  I went back to my "Backup" of which I have 10 versions a week apart.  Selected one about a month ago and it started working again.  Started moving forward a week at a time but to speed things up I didn't restore the "advancedsettings.xml" file.  This takes an extra step in the process.   Got all the way back to current date and all still working fine. Scratching my head I decided to leave at that and I put the "advancedsettings.xml" back.  It stopped working again.  Looking at the file it seems fine, so I simply retyped the whole thing and saved it.  It now works again.  Must have been something in there it didn't like, but only for music not video.  File just contained the standard cache settings one and a video library one to import watched flags.Huh??

Oh, any thoughts on the Skin Helper addon and Black Glass Nova issue that showed in my first log file.  Who do I report that too?

Cheers and thanks a bundle

Well done John, always nice when people solve their own bugs. But what I can't figure is what in advancedsettings.xml could cause this bevaviour. I can see what it read from the log
Contents of special://profile/advancedsettings.xml are...
<!-- Created using Easy Advanced Settings addon -->
No idea why that caused skipping, and you have the same now with it working?
(2018-09-07, 04:13)dawsonjw Wrote: Oh, any thoughts on the Skin Helper addon and Black Glass Nova issue that showed in my first log file.  Who do I report that too?
SHS has it's own support thread 235676 (thread), I would raise it there. It could just be it is not updated fully for Beta yet, addon updates are up to the author. Many skins use SHS, so it is not just a Black Nova issue. But I am guessing what is the cause of the many errors in your first log, it is not a fact. Something is trying to find extrafanart folder for each video, and there is failed JSON calls to GetAlbums.  The relevent part of the log for JSON call is
PHP Code:
08:56:03.380 T:18446744072341906688 DEBUGJSONRPCValue does not match any of the enum values in type
08:56:03.381 T:18446744072341906688 DEBUGJSONRPC: Array element at index 6 does not match in type properties
08:56:03.383 T:18446744072341906688 DEBUGMetadata and Artwork module --> {"error":{"code":-32602,"data":{"method":"AudioLibrary.GetAlbums","stack":{"message":"array element at index 6 does not match","name":"Item.Fields.Base","property":{"message":"Received value does not match any of the defined enum values","type":"string"},"type":"array"}},"message":"Invalid params."},"id":1,"jsonrpc":"2.0"}
56:03.383 T:18446744072341906688 DEBUGMetadata and Artwork module --> {'params': {'filter': {'and': [{'operator''is''field''album''value'u'The Axiom Archive 1969-1971'}, {'operator''is''field''artist''value'u'Axiom'}]}, 'properties': ['title''fanart''thumbnail''genre''displayartist''artist''genreid''musicbrainzalbumartistid''year''rating''artistid''musicbrainzalbumid''theme''description''type''style''playcount''albumlabel''mood''dateadded']}, 'jsonrpc''2.0''method''AudioLibrary.GetAlbums''id'1}
56:03.391 T:18446744072341906688 DEBUGCAddonSettings[script.module.metadatautils]: loading setting definitions
08:56:03.392 T:18446744072341906688 DEBUGCAddonSettings[script.module.metadatautils]: trying to load setting definitions from old format...
56:03.399 T:18446744072286243040 DEBUGKeyboardscancode0x14sym0x0112unicode0x0000modifier0x0
08:56:03.401 T:18446744072341906688 DEBUGCAddonSettings[script.module.metadatautils]: loading setting values 
After my android TV upgraded to v18 I had a similar issue with playing video files off my media server. I had had this issue way back in the past but managed to accidentally fix it but it returned with the update.
Would play one file and then stop. I had the play next etc set in the settings.
After reading the above I tried going into settings in advanced mode and resetting to default and then saving. This seems to have fixed the issue and I now get continual playback.
This isn't a deep technical investigation by any means but it may suggest something corrupt in the settings file that rolls out with the update.
If people have similar issues give it a try and see if you get a similar result.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Kodi 18 only playing one music track00