•   
  • 1
  • 71
  • 72
  • 73(current)
  • 74
  • 75
  • 81
  •   
Release Experimental Google Music Addon
@foreverguest
Thanks for answering. Yes, I checked: the credentials are the same on iohone and in mac...
Reply
If you could post the iPhone Kodi log, it would be helpful. Not sure where to find it ...
Reply
ok, thanks, I'll do it tomorrow!
Reply
(2019-02-26, 19:06)foreverguest Wrote: Hi,

This happens when you use a free account in Play Music.

Check if you are using the same login credentials in your iPhone and in your Mac.
 Hey mate, any luck with the preset Radios error?
Reply
@foreverguest
As often the case, whenever a machine fails you can find the cause in a dumb human behind it... In this case the dumb human was me: after a clean install of Kodi on my iPhone the addon works flawlessly. My apologies!
Reply
(2019-02-27, 01:37)Abbaskip Wrote:
(2019-02-26, 19:06)foreverguest Wrote: Hi,

This happens when you use a free account in Play Music.

Check if you are using the same login credentials in your iPhone and in your Mac.
 Hey mate, any luck with the preset Radios error?  
 Yes, I think I have nailed it now.

Try this: https://app.box.com/s/ohtx4b7k74iga8r7c7y1u0ymryn2xptw
Reply
(2019-02-28, 22:50)foreverguest Wrote:
(2019-02-27, 01:37)Abbaskip Wrote:
(2019-02-26, 19:06)foreverguest Wrote: Hi,

This happens when you use a free account in Play Music.

Check if you are using the same login credentials in your iPhone and in your Mac.
 Hey mate, any luck with the preset Radios error?  
 Yes, I think I have nailed it now.

Try this: https://app.box.com/s/ohtx4b7k74iga8r7c7y1u0ymryn2xptw

You, my friend, are a genius!

Do you mind me asking what the issue was? I'm trying to learn and was playing around with all sorts but struggled to even see what was causing that crash, as it seemed to successfully get a list of songs - just not play them. And playing songs from other areas in the add-on still worked.

What are your thoughts on that new Google Play API that has been suggested in the github? Is that something that could help the add-on moving forward?

I'll have to remember to buy you a beer next payday.
Reply
(2019-03-02, 16:06)Abbaskip Wrote: You, my friend, are a genius!

Do you mind me asking what the issue was? I'm trying to learn and was playing around with all sorts but struggled to even see what was causing that crash, as it seemed to successfully get a list of songs - just not play them. And playing songs from other areas in the add-on still worked.
Well, for starters it is probably a bug in Kodi 18. In past versions it didn't crash when I retrieved the song list and started playing without showing it. Now I have to return the list to be showed than I start playing.
Quote:What are your thoughts on that new Google Play API that has been suggested in the github? Is that something that could help the add-on moving forward?
As it is Python 3 only, I'll certain try it for Kodi 19, seems to have more features.
Reply
(2019-03-06, 06:22)foreverguest Wrote: As it is Python 3 only, I'll certain try it for Kodi 19, seems to have more features.

Oh that's right. Forgot about the mess that is python versions for Kodi versions. Thanks for the response and again for the great add-on
Reply
Ok, version 1.12 is out, contains the crash fix and latest fixes from github:
plugin.audio.googlemusic.exp-1.12

I'm working in refactoring the code to prepare to Python3 (Kodi 19) and use latest Kodi features.

Planning to add (accepting suggestions for new features):
- Home and Recents menu
- Oauth authentication

Planning to remove (if anyone use this features let me know):
- auto playlists
- kodi library integration
- library export
Reply
@foreverguest

Fortunately I didn't have the problems that other users were experiencing recently but I still just wanted to add an extra thank you for your continued support and development of this addon.

THANKS! Nod
If I have helped you or increased your knowledge please click the 'Thumb Up - Like' button to show me your appreciation :)
For YouTube questions see the official thread here.
Reply
I'm getting an error since the update. The addon had been working flawlessly on libreelec 17.6 prior. Tried to uninstall and reinstall. Still getting the error. It's most probably the credentials issue that seems to happen with every update. Is there anything I need to do in my google account?
Reply
Some people had success using this google unlock link: https://accounts.google.com/b/0/DisplayUnlockCaptcha

If it doesn't work, please upload your Kodi log so I can take a look.
Reply
Same here, cannot login anymore. Checked the logging:

20:19:41.231 T:1874850720  NOTICE: [GoogleMusicEXP-1.12]  ARGV: ['plugin://plugin.audio.googlemusic.exp/', '1', '?path=playlist&playlist_id=feellucky']
20:19:41.389 T:1962199168   DEBUG: ------ Window Init (DialogBusy.xml) ------
20:19:42.605 T:1874850720   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.ImportError'>
                                            Error Contents: No module named lib2to3.pgen2.parse
Reply
Please upload your full log to pastebin and share the link.
Reply
  •   
  • 1
  • 71
  • 72
  • 73(current)
  • 74
  • 75
  • 81
  •   



Logout Mark Read Team Forum Stats Members Help
Experimental Google Music Addon17
This forum uses Lukasz Tkacz MyBB addons.