•   
  • 1
  • 56
  • 57
  • 58(current)
  • 59
  • 60
  • 75
  •   
Release IPTV Recorder
(2019-03-17, 12:11)encol Wrote: Hi, i get this syntax error:
23:32:09 T:1611537112   ERROR: [plugin.video.iptv.recorder] service started...
23:32:10 T:1674597664   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.SyntaxError'>
                                            Error Contents: ('invalid syntax', ('/storage/emulated/0/Android/data/com.semperpax.spmc16/files/.spmc/addons/plugin.video.iptv.recorder/main.py', 1804, 25, '    streams = {x[3]:x for x in streams}\n'))
                                            SyntaxError: ('invalid syntax', ('/storage/emulated/0/Android/data/com.semperpax.spmc16/files/.spmc/addons/plugin.video.iptv.recorder/main.py', 1804, 25, '    streams = {x[3]:x for x in streams}\n'))
                                            -->End of Python script error report<--
 That looks like it won't work on Kodi 16 Jarvis which is what SPMC is based on.
Try using official Kodi 18.
I don't really want to try and back-port this to Jarvis. Kodi 19 is going to cause enough problems when it switches to python 3.
Reply
(2019-03-17, 12:18)primaeval Wrote:  That looks like it won't work on Kodi 16 Jarvis which is what SPMC is based on.
Try using official Kodi 18.
I don't really want to try and back-port this to Jarvis. Kodi 19 is going to cause enough problems when it switches to python 3. 

Unfortunately, my device run on android 4.4.
I don't think Kodi 19 can run on it  Sad
Reply
(2019-03-17, 12:24)encol Wrote:
(2019-03-17, 12:18)primaeval Wrote:  That looks like it won't work on Kodi 16 Jarvis which is what SPMC is based on.
Try using official Kodi 18.
I don't really want to try and back-port this to Jarvis. Kodi 19 is going to cause enough problems when it switches to python 3. 

Unfortunately, my device run on android 4.4.
I don't think Kodi 19 can run on it  Sad 
 You can fix the problem in the log with this change:
https://github.com/primaeval/plugin.vide...edf1cae9c7

However, I fixed that and a problem in xbmcswift for Kodi 16 Jarvis on Windows but recording locked up,
so I'm not going to try and fix it myself.

I very much doubt an old device running android 4.4 would be able to cope with recording either.
Reply
Thanks a lot,
i'll try and report!
Reply
now i have this:
ifucogumuj.kodi (paste)
Reply
(2019-03-17, 13:24)encol Wrote: now i have this:
ifucogumuj.kodi (paste)

It's the same type of problem. There are probably loads more.
I really haven't got the energy to fix it.
Nobody is working on SPMC any more.
http://spmc.semperpax.com/

See if you can put LibreELEC on your Android box.
I did that on a couple of my old devices.
Reply
(2019-03-17, 13:06)encol Wrote: Thanks a lot,
i'll try and report!


What box is it?
Reply
(2019-03-17, 15:10)ed_davidson01 Wrote:
(2019-03-17, 13:06)encol Wrote: Thanks a lot,
i'll try and report!


What box is it? 
 It's an Android Smart TV
Reply
Smart-tech LE4048SA
Reply
(2019-03-17, 15:29)encol Wrote: Smart-tech LE4048SA


I can’t find any specs on it. If it is an Amlogic chip then you might have luck.
If not time to buy a new one.
Reply
(2019-03-17, 13:24)encol Wrote: now i have this:
ifucogumuj.kodi (paste)
 I've fixed the other dict comprehensions but I haven't got anything to test it on.
https://github.com/primaeval/plugin.vide.../tree/spmc
If there are more problems open an issue on github and we'll discuss the details there.
Reply
(2019-03-17, 16:42)ed_davidson01 Wrote: I can’t find any specs on it. If it is an Amlogic chip then you might have luck.
If not time to buy a new one. 
It is sold under different names, you can find some specs here
Anyway, processor is an ARM Cortex-A7.
I succesfully rooted it and installed play store  Cool
(2019-03-17, 17:17)primaeval Wrote:  I've fixed the other dict comprehensions but I haven't got anything to test it on.
https://github.com/primaeval/plugin.vide.../tree/spmc
If there are more problems open an issue on github and we'll discuss the details there. 
Thanks a lot, now channel search works fine, but i have another error.

Unfortunately, now i have some problem in creating an account on github, so (for now) i cannot open an issue.
However, i pasted the error here: sedemotece.kodi (paste)
Reply
(2019-03-17, 18:56)encol Wrote:
(2019-03-17, 16:42)ed_davidson01 Wrote: I can’t find any specs on it. If it is an Amlogic chip then you might have luck.
If not time to buy a new one. 
It is sold under different names, you can find some specs here
Anyway, processor is an ARM Cortex-A7.
I succesfully rooted it and installed play store  Cool
(2019-03-17, 17:17)primaeval Wrote:  I've fixed the other dict comprehensions but I haven't got anything to test it on.
https://github.com/primaeval/plugin.vide.../tree/spmc
If there are more problems open an issue on github and we'll discuss the details there. 
Thanks a lot, now channel search works fine, but i have another error.

Unfortunately, now i have some problem in creating an account on github, so (for now) i cannot open an issue.
However, i pasted the error here: sedemotece.kodi (paste) 
That error is because I made a version of xbmcswift to show poster images properly.
Delete the one in
addons\script.module.xbmcswift2
and either re-install IPTV Recorder or another of my addons that uses it and it should now pull in the version from the Kodi repo.
Or you can grab the zip from here
https://mirrors.kodi.tv/addons/jarvis/sc...-2.4.0.zip

The difference is here if you want to modify the installed version. Just remove these lines.
https://github.com/primaeval/script.modu...d88fe44ebe
Reply
Great!
now plugin starts and i can see the channels, but when i try to record something i get this: evuboxeram.kodi (paste)
Reply
(2019-03-17, 21:44)encol Wrote: Great!
now plugin starts and i can see the channels, but when i try to record something i get this: evuboxeram.kodi (paste)
 Try this.
https://github.com/primaeval/plugin.vide...895d1c4945
Your SPMC version is using python 2.6 which is quite ancient now.
Reply
  •   
  • 1
  • 56
  • 57
  • 58(current)
  • 59
  • 60
  • 75
  •   
 
Thread Rating:
  • 4 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
IPTV Recorder54