Movies have stopped being scraped, despite being viewable in library
#1
I have used Kodi for a number of years now, but consider myself a very basic user.

I have a Windows server in my house, with two HDDs, one of which contains my movies, the other my television shows. I currently use SMB because when setting up I wasn't sure how to make UpNp follow along with the skin settings which I liked and could only access it by going into my settings and opening up library.

Lately all of a sudden, movies have stopped adding themselves from my library unless I go in to the video library and select "Scan to library" it will successfully add the movie, but otherwise when adding a movie to my library and then updating, it will only update my TV shows, fully ignoring movies. 

I have read a number of other threads and attempted the solutions in those threads, to no avail.

I have attached my logfile, which I hope is the right one and I appreciate any help anyone can offer.

https://paste.kodi.tv/olixilujef
Reply
#2
Hello @unlimitednights

The log is no good. Follow this guide and try again... https://forum.kodi.tv/showthread.php?tid...pid2665079

Also have a quick read of this... https://forum.kodi.tv/showthread.php?tid=336969

Moved to metadata scrapers
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
(2019-04-22, 02:35)unlimitednights Wrote: I have used Kodi for a number of years now, but consider myself a very basic user.

I have a Windows server in my house, with two HDDs, one of which contains my movies, the other my television shows. I currently use SMB because when setting up I wasn't sure how to make UpNp follow along with the skin settings which I liked and could only access it by going into my settings and opening up library.

Lately all of a sudden, movies have stopped adding themselves from my library unless I go in to the video library and select "Scan to library" it will successfully add the movie, but otherwise when adding a movie to my library and then updating, it will only update my TV shows, fully ignoring movies. 

I have read a number of other threads and attempted the solutions in those threads, to no avail.

I have attached my logfile, which I hope is the right one and I appreciate any help anyone can offer.

https://paste.kodi.tv/olixilujef

Thanks for your reply!

I think I got it this time: https://paste.kodi.tv/boteyicobe

After reading over the logfile I see it looks like it may be just skipping the scan of my movie folder because of something called fasthash?

I read a bit on it but couldn't find a conclusive answer, I tried a different scraper to no avail.

Thanks!
Reply
#4
Thanks, better.

Lets try to disable the fasthash check. Add the following to your advancedsettings.xml file, restart Kodi and try scraping.

<advancedsettings>
<videolibrary>
<usefasthash>false</usefasthash> <!-- defaults to true. Set to false in order to skip hashing based on the folders modification time. -->
</videolibrary>
</advancedsettings>
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#5
(2019-04-22, 07:12)Karellen Wrote: Thanks, better.

Lets try to disable the fasthash check. Add the following to your advancedsettings.xml file, restart Kodi and try scraping.

<advancedsettings>
<videolibrary>
<usefasthash>false</usefasthash> <!-- defaults to true. Set to false in order to skip hashing based on the folders modification time. -->
</videolibrary>
</advancedsettings>

Karellen, this worked great, my movies, after months, are scanning again with the addition of this advanced setting. 
The unintended consequence is that now Kodi is also checking every single show folder in my TV library, and just generally taking a long time.
Do you think there is a solution for this or am I trying to have it both ways here?

Maybe even more difficult to answer, can you think of any reason why this fasthash feature would have all of a sudden stopped working on my drive in my server? Is there anyway you could think of rectifying this?

I so sincerely appreciate your help, this is really amazing the amount of knowledge you have.
Reply
#6
@unlimitednights

Could you provide another Debug Log that captures an Update Library thanks. Let's see what Kodi is searching. But I think that is expected now that Kodi has to verify by other means any changes to folders.

There seems to be this entry that Kodi is searching for. It might be worth cleaning that out, whatever it is or name it correctly...
Searching for '888e4585daf848d29a7a793348eb51fc' using The TVDB scraper 

Once you create the above log, remove the fasthash setting and test whether your library is working again. Try adding another movie. If you don't have one, then just create a folder named with a movie, then an empty txt file and rename it to <movie>.mkv and try scraping that. Does it work?
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#7
(2019-04-23, 04:04)Karellen Wrote: @unlimitednights

Could you provide another Debug Log that captures an Update Library thanks. Let's see what Kodi is searching. But I think that is expected now that Kodi has to verify by other means any changes to folders.

There seems to be this entry that Kodi is searching for. It might be worth cleaning that out, whatever it is or name it correctly...
Searching for '888e4585daf848d29a7a793348eb51fc' using The TVDB scraper 

Once you create the above log, remove the fasthash setting and test whether your library is working again. Try adding another movie. If you don't have one, then just create a folder named with a movie, then an empty txt file and rename it to <movie>.mkv and try scraping that. Does it work?

I have two debug logs. Here is one now that the change has been made with fasthash being set to False, the movie dir was not skipped and everything is good. https://paste.kodi.tv/idoqatogul

Here is my second log after setting fasthash to true: https://paste.kodi.tv/evogavuqej, it goes right back to skipping the movie dir.

If you don't have any ideas on streamlining this thats no problem, I will live, I am sure.
Reply
#8
(2019-04-23, 06:15)unlimitednights Wrote: Here is my second log after setting fasthash to true: evogavuqej (paste), it goes right back to skipping the movie dir.
If everything is scraped into the library, then it should be skipping the movie directory as there is nothing to add. Isn't that a good thing?

I could not see where you added a movie in either of those two logs. But if you did, then you should not have scraped it in the first log with False hashscheck as Kodi has now seen the new movie and ruined the next scan because it already knows it is there, and will now skip it when you reset hashcheck back to True as it is already in the library.

There are other ways of updating the library without running through your entire collection. See... https://kodi.wiki/view/Updating_or_removing_videos
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply



Logout Mark Read Team Forum Stats Members Help
Movies have stopped being scraped, despite being viewable in library0
This forum uses Lukasz Tkacz MyBB addons.