•   
  • 1
  • 24
  • 25
  • 26(current)
  • 27
  • 28
  • 32
  •   
Beta Amber for Leia with Skinshortcuts
Maybe another "small" bug.

When I am watching something if I fast forward the pause buttons stays as a pause button instead of changing to a play button, but when you click it, it plays not pauses.

This seems to be the same using estuary, even though estuary doesn't have fast forward or rewind buttons (it has chapter skip buttons)
I have mapped certain remote buttons for FF and RW and bringing up the OSD in estuary while Rewinding or FF'ing the button is also a pause button but does not pause it plays.

Probably something to do with kodi
(2019-06-22, 01:00)edjalmo Wrote: Here is translation for Brazilian Portuguese: https://github.com/edjalmobf/Traducao_PT...uage.pt_br
If someone here is Brazilian too and want to take a look to suggest some translation, I appreciate.
I'm not an expert in English, so sorry for any mistake, but I did my best!

@bsoriano, I updated the brazilian portuguese translation.
Supercalifragilisticexpialidocious! (inscribed in large friendly letters)
My hardware is a Raspberry Pi 3b (with LibreELEC)
(2019-07-05, 22:09)edjalmo Wrote:
(2019-07-05, 19:05)bsoriano Wrote: That is not a cosmetic change, that is a re-design of the view.  I don't think I will do this right now.  However, if you have the time, please mock up how it would look for tv shows, movies, seasons, musicvideos, artists, albums and songs, and I will see what I can do.

Alternatively, you could just provide me a screenshot of the current view and point out in it the alignment issues you mentioned before.  That I could probably do fairly quickly.
My apologies! You're are completely right! I completely forgot all the other views (movies, musics...).
Look the new image.
Image

My suggestion is that you create an invisible space for plot (like the brown square on image) and center the plot and other things (title, season, duration...) inside it. This way even if plot is short it will be centered with the thumbnail, poster, artist... images.
The red rectangles is the space between plot an this other things. My point is that this space be always the same.
What you think? This is possible? 
@edjalmo, thanks! I am not sure how to go about something like that, I need to think about it some more.  Thanks again for showing me exactly what you meant.

Regards,

Bart
(2019-07-05, 22:52)edjalmo Wrote:
(2019-06-22, 01:00)edjalmo Wrote: Here is translation for Brazilian Portuguese: https://github.com/edjalmobf/Traducao_PT...uage.pt_br
If someone here is Brazilian too and want to take a look to suggest some translation, I appreciate.
I'm not an expert in English, so sorry for any mistake, but I did my best!

@bsoriano, I updated the brazilian portuguese translation. 
Thanks! I will download it and add it to the skin.
(2019-07-05, 22:36)treboR2Robert Wrote: Maybe another "small" bug.

When I am watching something if I fast forward the pause buttons stays as a pause button instead of changing to a play button, but when you click it, it plays not pauses.

This seems to be the same using estuary, even though estuary doesn't have fast forward or rewind buttons (it has chapter skip buttons)
I have mapped certain remote buttons for FF and RW and bringing up the OSD in estuary while Rewinding or FF'ing the button is also a pause button but does not pause it plays.

Probably something to do with kodi
@treboR2Robert , thanks! I had not noticed that.  I will take a look to see if it's something I can change in the skin.

Regards,

Bart
@bsoriano 

So there is defiantly something going on with the menu settings.

The "choose item for menu" is not working correctly for 2 of my PKC libraries (Movies and TV)

I select the item and it does nothing.

It works fine for literally every other thing including my other libraries, i even tried selecting some widgets and they worked.

I eventually figured out I could set the label and action manually. Which worked.

Something fishy going on though, it didn't behave like this before.
https://drive.google.com/file/d/1-7irpun...p=drivesdk

This little video probably explains it better
(2019-07-06, 02:16)treboR2Robert Wrote: https://drive.google.com/file/d/1-7irpun...p=drivesdk

This little video probably explains it better

@treboR2Robert, thanks for the video. I did not change the code for menu item selection, so I am not sure what is going on there. You said this is a new install, correct? Have you tried in another machine? What version of Kodi and PKC are you using? What version of script.skinshortcuts? That last one you can find in Amber Settings, Manage Dependencies.

My initial guess is that there is something going on between PKC and skinshortcuts. I will try to replicate this issue, under Windows (it’s the only OS I have to test). I will let you know what happens.

EDIT: I started from scratch, new install of Kodi Matrix nightly (from yesterday) and PKC 2.8.7.  I cannot replicate your issue.  I deleted the Movies and TV Shows menu items that were automatically created during the sync process, and added one of my movie libraries from PKC (I have multiple in my Plex server, none named just Movies), and added my TV Shows library from PKC.  Same way as you were doing on the video.  I have no issues, the menu items were added correctly.  The version of skinshortcuts I am using is 1.0.18.

Regards,

Bart
@treboR2Robert , I was successful with the recently added widget! In the end, I only had to modify one file from script.skin.helper.widgets.  

In order to use this, you need to make sure that you are using the Kodi repo version (and not MarcelVeldt's beta repo versions) of all of the skin.helper addons:

script.skin.helper.service, script.skin.helper.widgets and script.module.simplecache.

Make sure you disable "Auto-Update" for these addons in the addon info dialog for each addon.

Then, download my modded version of script.skin.helper.widgets from my GitHub: https://github.com/bartolomesoriano/scri...er.widgets.  Replace your current version with this one (you can find the current one in userdata\addons).

And finally, download the latest Amber from my GitHub.

Please test and let me know how it goes.  I just tested it with a similar configuration to yours (with PKC) and it works great Smile Thanks.

Thanks for your request, which pushed me to find a solution.

Regards,

Bart
(2019-07-06, 19:28)bsoriano Wrote: @treboR2Robert , I was successful with the recently added widget! In the end, I only had to modify one file from script.skin.helper.widgets.  

In order to use this, you need to make sure that you are using the Kodi repo version (and not MarcelVeldt's beta repo versions) of all of the skin.helper addons:

script.skin.helper.service, script.skin.helper.widgets and script.module.simplecache.

Make sure you disable "Auto-Update" for these addons in the addon info dialog for each addon.

Then, download my modded version of script.skin.helper.widgets from my GitHub: https://github.com/bartolomesoriano/scri...er.widgets.  Replace your current version with this one (you can find the current one in userdata\addons).

And finally, download the latest Amber from my GitHub.

Please test and let me know how it goes.  I just tested it with a similar configuration to yours (with PKC) and it works great Smile Thanks.

Thanks for your request, which pushed me to find a solution.

Regards,

Bart

It works a treat Bart Big Grin Big Grin Big Grin

Thank you for doing this, I appreciate all of your hard work !!! If only all developers were like you.


I could not find the add-on module.simplecache but i found the other 2 ( skin.helper.service and skin.helper.widgets ) in "my add-ons" and disabled the automatic updates.

I assumed the versions I had were from the standard kodi repo as they were just automatically installed when I installed your skin.

The location of the script.skin.helper.widgets folder was slightly different for me on CoreELEC it was in /storage/.kodi/addons/

I used WinSCP to delete the files in that folder and copy the new 1's over that I cloned from your git link.

I then rebooted, updated your skin and redone the widget.

Now everything is as it should be Smile It evens shows single episodes if there is only 1 available for that season.

Great work dude, I'm loving it !

Is the module.simplecache add-on not listed in kodi ? I see the folder for it in WinSCP but nothing in kodi itself.

Thanks again
Rob
(2019-07-06, 13:52)bsoriano Wrote:
(2019-07-06, 02:16)treboR2Robert Wrote: https://drive.google.com/file/d/1-7irpun...p=drivesdk

This little video probably explains it better

@treboR2Robert, thanks for the video. I did not change the code for menu item selection, so I am not sure what is going on there. You said this is a new install, correct? Have you tried in another machine? What version of Kodi and PKC are you using? What version of script.skinshortcuts? That last one you can find in Amber Settings, Manage Dependencies.

My initial guess is that there is something going on between PKC and skinshortcuts. I will try to replicate this issue, under Windows (it’s the only OS I have to test). I will let you know what happens.

EDIT: I started from scratch, new install of Kodi Matrix nightly (from yesterday) and PKC 2.8.7.  I cannot replicate your issue.  I deleted the Movies and TV Shows menu items that were automatically created during the sync process, and added one of my movie libraries from PKC (I have multiple in my Plex server, none named just Movies), and added my TV Shows library from PKC.  Same way as you were doing on the video.  I have no issues, the menu items were added correctly.  The version of skinshortcuts I am using is 1.0.18.

Regards,

Bart 

I will do a clean install on my PC and see what happens there.
Will let you know how it goes Smile

I don't see a skinshortcuts in my add-ons ? Where do I find it and the version number ?
(2019-07-06, 22:06)treboR2Robert Wrote:
(2019-07-06, 13:52)bsoriano Wrote:
(2019-07-06, 02:16)treboR2Robert Wrote: https://drive.google.com/file/d/1-7irpun...p=drivesdk

This little video probably explains it better

@treboR2Robert, thanks for the video. I did not change the code for menu item selection, so I am not sure what is going on there. You said this is a new install, correct? Have you tried in another machine? What version of Kodi and PKC are you using? What version of script.skinshortcuts? That last one you can find in Amber Settings, Manage Dependencies.

My initial guess is that there is something going on between PKC and skinshortcuts. I will try to replicate this issue, under Windows (it’s the only OS I have to test). I will let you know what happens.

EDIT: I started from scratch, new install of Kodi Matrix nightly (from yesterday) and PKC 2.8.7.  I cannot replicate your issue.  I deleted the Movies and TV Shows menu items that were automatically created during the sync process, and added one of my movie libraries from PKC (I have multiple in my Plex server, none named just Movies), and added my TV Shows library from PKC.  Same way as you were doing on the video.  I have no issues, the menu items were added correctly.  The version of skinshortcuts I am using is 1.0.18.

Regards,

Bart 

I will do a clean install on my PC and see what happens there.
Will let you know how it goes Smile

I don't see a skinshortcuts in my add-ons ? Where do I find it and the version number ?

You should see it if you go to Amber Settings, Manage Dependencies.

Regards,

Bart
(2019-07-06, 22:02)treboR2Robert Wrote:
(2019-07-06, 19:28)bsoriano Wrote: @treboR2Robert , I was successful with the recently added widget! In the end, I only had to modify one file from script.skin.helper.widgets.  

In order to use this, you need to make sure that you are using the Kodi repo version (and not MarcelVeldt's beta repo versions) of all of the skin.helper addons:

script.skin.helper.service, script.skin.helper.widgets and script.module.simplecache.

Make sure you disable "Auto-Update" for these addons in the addon info dialog for each addon.

Then, download my modded version of script.skin.helper.widgets from my GitHub: https://github.com/bartolomesoriano/scri...er.widgets.  Replace your current version with this one (you can find the current one in userdata\addons).

And finally, download the latest Amber from my GitHub.

Please test and let me know how it goes.  I just tested it with a similar configuration to yours (with PKC) and it works great Smile Thanks.

Thanks for your request, which pushed me to find a solution.

Regards,

Bart

It works a treat Bart Big Grin Big Grin Big Grin

Thank you for doing this, I appreciate all of your hard work !!! If only all developers were like you.


I could not find the add-on module.simplecache but i found the other 2 ( skin.helper.service and skin.helper.widgets ) in "my add-ons" and disabled the automatic updates.

I assumed the versions I had were from the standard kodi repo as they were just automatically installed when I installed your skin.

The location of the script.skin.helper.widgets folder was slightly different for me on CoreELEC it was in /storage/.kodi/addons/

I used WinSCP to delete the files in that folder and copy the new 1's over that I cloned from your git link.

I then rebooted, updated your skin and redone the widget.

Now everything is as it should be Smile It evens shows single episodes if there is only 1 available for that season.

Great work dude, I'm loving it !

Is the module.simplecache add-on not listed in kodi ? I see the folder for it in WinSCP but nothing in kodi itself.

Thanks again
Rob

Awesome! Thanks for your kind words!

Don’t worry about simplecache, I thought it would be necessary for this to work correctly, but it is not.

Regards,

Bart
(2019-07-06, 22:08)bsoriano Wrote:
(2019-07-06, 22:06)treboR2Robert Wrote:
(2019-07-06, 13:52)bsoriano Wrote: @treboR2Robert, thanks for the video. I did not change the code for menu item selection, so I am not sure what is going on there. You said this is a new install, correct? Have you tried in another machine? What version of Kodi and PKC are you using? What version of script.skinshortcuts? That last one you can find in Amber Settings, Manage Dependencies.

My initial guess is that there is something going on between PKC and skinshortcuts. I will try to replicate this issue, under Windows (it’s the only OS I have to test). I will let you know what happens.

EDIT: I started from scratch, new install of Kodi Matrix nightly (from yesterday) and PKC 2.8.7.  I cannot replicate your issue.  I deleted the Movies and TV Shows menu items that were automatically created during the sync process, and added one of my movie libraries from PKC (I have multiple in my Plex server, none named just Movies), and added my TV Shows library from PKC.  Same way as you were doing on the video.  I have no issues, the menu items were added correctly.  The version of skinshortcuts I am using is 1.0.18.

Regards,

Bart 

I will do a clean install on my PC and see what happens there.
Will let you know how it goes Smile

I don't see a skinshortcuts in my add-ons ? Where do I find it and the version number ? 

You should see it if you go to Amber Settings, Manage Dependencies.

Regards,

Bart 
Thanks it says version 1.0.17 and has no option to update
(2019-07-06, 22:10)treboR2Robert Wrote:
(2019-07-06, 22:08)bsoriano Wrote:
(2019-07-06, 22:06)treboR2Robert Wrote: I will do a clean install on my PC and see what happens there.
Will let you know how it goes Smile

I don't see a skinshortcuts in my add-ons ? Where do I find it and the version number ? 

You should see it if you go to Amber Settings, Manage Dependencies.

Regards,

Bart 
Thanks it says version 1.0.17 and has no option to update

Ok, I will try with that version, it should work as well.

Regards,

Bart
  •   
  • 1
  • 24
  • 25
  • 26(current)
  • 27
  • 28
  • 32
  •   



Logout Mark Read Team Forum Stats Members Help
Amber for Leia with Skinshortcuts1
This forum uses Lukasz Tkacz MyBB addons.