•   
  • 1
  • 106
  • 107
  • 108(current)
  • 109
  • 110
  • 111
  •   
Beta Spotify for Kodi
(2019-08-02, 07:33)jakermx Wrote: Did you both @armandokevin  and @Skank  have tried my mod from my github page?

No, you got link?
Reply
@jakermx cant find it
Reply
here you go!!!


https://github.com/jakermx/plugin.audio.spotify
Reply
(2019-08-02, 14:48)jakermx Wrote: here you go!!!


https://github.com/jakermx/plugin.audio.spotify
thx test asap
Reply
Please uninstall it and delete all datam then install my mod... it should work
Reply
@jakermx 

should this work on android devices/nvidia shield too?

When I try to start your mod, I am prompted to login and a browser opens but I can't input any credentials
Reply
(2019-08-02, 16:21)effe.rnr Wrote: @jakermx 

should this work on android devices/nvidia shield too?

When I try to start your mod, I am prompted to login and a browser opens but I can't input any credentials

I should work, because my mod did not modify nothing about it, I just changed the server selection process. bu if yo share your log file... I could find the issue and possibly a workaround  or solution. 

I will help others as well.
Reply
(2019-08-04, 15:15)jakermx Wrote:
(2019-08-02, 16:21)effe.rnr Wrote: @jakermx 

should this work on android devices/nvidia shield too?

When I try to start your mod, I am prompted to login and a browser opens but I can't input any credentials

I should work, because my mod did not modify nothing about it, I just changed the server selection process. bu if yo share your log file... I could find the issue and possibly a workaround  or solution. 

I will help others as well.  

okay, thx for your help! Here's the log file: ijipigunig.kodi (paste)


I think the problem is: 2019-08-05 21:52:04.272 T:15049 WARNING: plugin.audio.spotify --> Exception in utils.get_token ! --> 'NoneType' object has no attribute '__getitem__'
Reply
It is not an Error, it is just a Warning, so after that Waning  the AddOn will try to get the new token.

It will be very helpful if you disable the AddOn, enabled debuging and then enabled the addon back, So I can see what it is doing since it starts....
Reply
tracks not switching
Reply
(2019-08-02, 07:33)jakermx Wrote: Did you both @armandokevin  and @Skank  have tried my mod from my github page?

thanks for answering. I have installed from there, and nothing I still can not enter the addon. I have a premium account on spotify, and I am on Coreelec. I catch you
<blockquote class="imgur-embed-pub" lang="en" data-id="a/Y4jrIYk" data-context="false" ><a href="//imgur.com/a/Y4jrIYk"></a></blockquote><script async src="//s.imgur.com/min/embed.js" charset="utf-8"></script>
Reply
https://www.dropbox.com/sh/rr5rtxuj479xh...wy97a?dl=0
Reply
(2019-08-07, 02:03)jakermx Wrote: It is not an Error, it is just a Warning, so after that Waning  the AddOn will try to get the new token.

It will be very helpful if you disable the AddOn, enabled debuging and then enabled the addon back, So I can see what it is doing since it starts....

ah okay sorry, will do that tonight
Reply
@jakermx 

sorry for the delayed response, here is my debug log:

tihezalaka.kodi (paste)


here a second log:

caqifesefa.kodi (paste)

EDIT: The browser is trying to open a url something like that:

http://localhost:52308/callback?code=.....

EDIT 2:
I just deleted the browser cache.. now I can insert the credentials, but when I click on "log in" the same error occurs (This page isn't working - ERR_CONNECTION_REFUSED)
Reply
Hi!
First of all: Thank you for this plugin!

I'm trying to play music from Spotify on my Raspberry Pi running on Raspbian without having to install a complete media center distro. So far, I went with raspotify providing me with a Spotify Connect device I could control using my smartphone. Now I thought it would be nice to have a GUI on the screen of the RasPi as well. Since the web player doesn't work on Raspbian, I've been searching for other solutions for a while now and stumbled over this plugin here.
I installed it in Kodi and logged in with my Spotify Premium username and password. It works fine if I select music on the RasPi directly and play it. But in contrast to all other devices I use Spotify on, the plugin seems to not use Spotify Connect. On my smartphone or computer, I can't see that I am playing music on a different device, and so I can't add songs to the queue etc. either.
If I start music on my smartphone and connect to the RasPi via Spotify Connect (it appears in the device list), it starts to play correctly on the RasPi, but only one song and then it stops. So this doesn't seem to be a solution either.

Does anyone have experience on how to get this working so I can control it both via smartphone app and on the RasPi directly?
I also installed the mod by @jakermx, but it doesn't seem to make any difference. Log says that it tried to connect to 443, but doesn't tell if that was successful.
Reply
  •   
  • 1
  • 106
  • 107
  • 108(current)
  • 109
  • 110
  • 111
  •   
 
Thread Rating:
  • 17 Vote(s) - 4.65 Average



Logout Mark Read Team Forum Stats Members Help
Spotify for Kodi4.6517