Connection failed...No response from MythTV backend...Do you want to retry?
#1
Bug 
The error in the subject line is what i get when opening Kodi.  And no, trying it again doesn't help.
1) https://paste.ubuntu.com/p/vVXsXYcWy6/
2)
3) Starting Kodi from Debian (17.6 Debian package version: 2:17.6+dfsg1-1ubuntu1). Platform: Linux x86 64-bit  b)Using Release Kodi from Debian x64 build c) Kodi from Debian compiled from 2:17.6+dfsg1-1ubuntu1 by GCC 6.4.0 for Linux x86 64-bit version 4.15.15 (265999)
4) Running on Linux Mint 19.2, kernel: Linux x86 64-bit version 4.15.0-60-generic
5)-HP-Compaq-dc7900-Convertible-Minitower> CPU: Intel® Core™2 Duo CPU E8500 @ 3.16GHz, 2 cores available > Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] Digital Stereo (HDMI) Samsung 51D460ADXZA Plasma "monitor"  > several HDDs > several OTA tuner cards and dongle which (I don't have any idea if they will work yet)
6. Software Manager
7.Well that one I aint got the git...
8) I haven't changed anything, but have reinstalled Kodi a few times.
9) Start up Kodi....it happens everytime
10) It hasn't ever crashed...it just wont connect to mythtv backend.
11) That's a bit above my paygrade....not even sure by what is meant about it being build.
12) Been running 17.3 for a few years but used WMC.  ANY help will be greatly appreciated!!!
Sincerely,
mrgta67
Reply
#2
did you ever have mythtv running properly? sounds to me like there might be a setup error there.
Reply
#3
(2019-09-06, 05:40)disaacso Wrote: did you ever have mythtv running properly? sounds to me like there might be a setup error there.

No, it has never ran...what do you suggest I do to corect it?  Thanks for your inquiry!
M
Reply
#4
I'm no expert, but help me to understand something. Is the Myth backend running on the same machine that is running Kodi?

Also, can you get the Myth frontend working properly?
Quote ronie: "Estuary is a giant piece of crap."
Reply
#5
(2019-09-06, 13:14)mrgta67 Wrote:
(2019-09-06, 05:40)disaacso Wrote: did you ever have mythtv running properly? sounds to me like there might be a setup error there.

No, it has never ran...what do you suggest I do to corect it?  Thanks for your inquiry!
if your backend is on a separate machine you have to make sure its setup to allow outside connections, as well as change the ip address in the kodi addon to match your server. Check into the bind-address for mythtv, I'm not sure if this is still something you need to mess with in newer versions but it was always a source of trouble for me when setting up a backend. Also check that in mythtv-setup you have the pin set to 0000.  There should be lots of info on this type of problem in the mythtv sub-forum here.
Reply
#6
(2019-09-06, 14:18)Tobor Wrote: I'm no expert, but help me to understand something. Is the Myth backend running on the same machine that is running Kodi?

Also, can you get the Myth frontend working properly?
Hi Tobor,
Both Kodi and Mythtv are on the same computer. Kodi the front and MythTv is the back-end.  I haven't seen any way to run any frontend on MythTV.  I believe I just installed the back-end through the Software Manager (as I did with the Kodi frontend).  Thanks...any any help will be appreciated :-)
Reply
#7
(2019-09-06, 15:02)disaacso Wrote:
(2019-09-06, 13:14)mrgta67 Wrote:
(2019-09-06, 05:40)disaacso Wrote: did you ever have mythtv running properly? sounds to me like there might be a setup error there.

No, it has never ran...what do you suggest I do to corect it?  Thanks for your inquiry!
M  
if your backend is on a separate machine you have to make sure its setup to allow outside connections, as well as change the ip address in the kodi addon to match your server. Check into the bind-address for mythtv, I'm not sure if this is still something you need to mess with in newer versions but it was always a source of trouble for me when setting up a backend. Also check that in mythtv-setup you have the pin set to 0000.  There should be lots of info on this type of problem in the mythtv sub-forum here. 
Hi disaacso,
Its all on one machine...does any of the above apply?  Thanks!
M
Reply
#8
mrgta67,

You can try entering "http://127.0.0.1:6544" into your browser to see if the backend is running. If you get no connection, I recommend you research the Myth Wiki.

I've installed Myth a few times now but I have always had to refer to online sources, as it is easy to forget a simple but important step.

Tobor
Quote ronie: "Estuary is a giant piece of crap."
Reply
#9
(2019-09-07, 13:19)Tobor Wrote: mrgta67,

You can try entering "http://127.0.0.1:6544" into your browser to see if the backend is running. If you get no connection, I recommend you research the Myth Wiki.

I've installed Myth a few times now but I have always had to refer to online sources, as it is easy to forget a simple but important step.

Tobor

The tab says Problem loading page and the page says Can not connect...
M
Reply
#10
(2019-09-06, 00:40)mrgta67 Wrote: ...several OTA tuner cards and dongle which (I don't have any idea if they will work yet)
 
The backend is not running, and the sentence above leads me to think you have not completed mythtv-setup. During setup the tuners are added and the available channels are scanned. If a tuner doesn't work, you will know it then. I suggest following the guide I linked before. I know there is a better one somewhere, I can't find it at the moment. This one is pretty good, although it is specific to the HDHomerun tuner.
Quote ronie: "Estuary is a giant piece of crap."
Reply
#11
(2019-09-08, 14:41)Tobor Wrote:
(2019-09-06, 00:40)mrgta67 Wrote: ...several OTA tuner cards and dongle which (I don't have any idea if they will work yet)
 
The backend is not running, and the sentence above leads me to think you have not completed mythtv-setup. During setup the tuners are added and the available channels are scanned. If a tuner doesn't work, you will know it then. I suggest following the guide I linked before. I know there is a better one somewhere, I can't find it at the moment. This one is pretty good, although it is specific to the HDHomerun tuner. 
Tobor,
Yes, it is not running.  I have downloaded it and uninstalled  and reinstalled both Kodi and MythTV on several occasions.  I get the error connection failed, no response from mythtv backend.  every time I start up Kodi.  I have completely removed both kodi and mythtv a few minutes ago and will use the provided guide to try again...Thanks T,
M
Reply
#12
(2019-09-08, 14:41)Tobor Wrote:
(2019-09-06, 00:40)mrgta67 Wrote: ...several OTA tuner cards and dongle which (I don't have any idea if they will work yet)
 
The backend is not running, and the sentence above leads me to think you have not completed mythtv-setup. During setup the tuners are added and the available channels are scanned. If a tuner doesn't work, you will know it then. I suggest following the guide I linked before. I know there is a better one somewhere, I can't find it at the moment. This one is pretty good, although it is specific to the HDHomerun tuner. 
So part of the issue seems to be one has to set up a static IP address.  I have spent 1/2 the day trying to find some instructions of how to do such a thing and and AGAIN, at wits end....
Reply
#13
Any device that acts as a server should get a fixed IP address in computer land.

I'd say, make a list of your network server devices and their MAC addresses, and have your router send out fixated IPs for them.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#14
(2019-09-08, 22:06)Klojum Wrote: Any device that acts as a server should get a fixed IP address in computer land.

I'd say, make a list of your network server devices and their MAC addresses, and have your router send out fixated IPs for them.
Ki Klojum,
I am a noob...I would love to have my router do such a thing!  Do you have a link or "sticky" that would guide me in that direction?
Reply
#15
Not really. It depends a bit on your router, because that is where the action happens. Which router are you using?
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Connection failed...No response from MythTV backend...Do you want to retry?00