Kodi is changing pulse sink by using sync playback to display
#1
Good Morning,

HW: ASROCK J4205-ITX, REGA DAC, Yamaha AS-1000

SW: Yavdr ansible

I want to have SPDIF out to my REGA DAC always as default output.
Works fine @VDR and @kodi except of:

To show 4k content "sync playback to display" is set to "On start / stop".
This is causing the audio output is switching to HDMI and I have to switch my REGA DAC to the HDMI input source.

How can I force Kodi is always using the SPDIF out?

When listen to music the output stays on SPDIF.

Thank you and have a nice day.

M
Reply
#2
Disable Adjust Refreshrate to match video! It's not kodi changing anything but the infrastructure under the hood, that looses your HDMI device cause on refreshrate switch an unplug ist detected.

Post your Debug Log, using a DAC via pulseaudio is not a smart decision at all if you are concerned about audio quality.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
(2019-10-01, 10:55)fritsch Wrote: Disable Adjust Refreshrate to match video! It's not kodi changing anything but the infrastructure under the hood, that looses your HDMI device cause on refreshrate switch an unplug ist detected.

Post your Debug Log, using a DAC via pulseaudio is not a smart decision at all if you are concerned about audio quality.

Thx for guiding me, I've removed pulseaudo from the system and Kodi works fine now, not changing audio output anymore.

Just having no audio @vdr but I can live with this, will have a look @Alsa settings

Why you would not recommend to use pulseaudio with a DAC?
Reply
#4
Pulseaudio will (without a lot of tuning) exactly do what you don't want. It will resample most stuff in software, while you exactly bought the DAC for exactly this, e.g. outputting the data and letting the DAC convert it to analog. If you bought the DAC to use its spdif - you bought it for the wrong purpose.

Depending on your pulseaudio version, you can set it to 24 bits by default, set 44.1 khz as your default sample rate and 48 khz as your alternate samplerate and additionally enable the setting: avoid-resampling - that way pulseaudio will behave as good as it can for every sort of content - else it will just resample all content, reducing bit-depth and so on.

Hint: As you did not hear it, it's most likely not a problem for you.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#5
(2019-10-03, 18:20)fritsch Wrote: Pulseaudio will (without a lot of tuning) exactly do what you don't want. It will resample most stuff in software, while you exactly bought the DAC for exactly this, e.g. outputting the data and letting the DAC convert it to analog. If you bought the DAC to use its spdif - you bought it for the wrong purpose.

Depending on your pulseaudio version, you can set it to 24 bits by default, set 44.1 khz as your default sample rate and 48 khz as your alternate samplerate and additionally enable the setting: avoid-resampling - that way pulseaudio will behave as good as it can for every sort of content - else it will just resample all content, reducing bit-depth and so on.

Hint: As you did not hear it, it's most likely not a problem for you.
I want to have the audio output always on the SPDIF optical output of my motherboard. If possibel bit perfect for listening to music. I've only flac format music.

If Kodi is using HDMI audio output the quality is not as good because it goes through HDMI to the TV and from there to the DAC which I want to avoid.
I assume there is something not perfect configured on my system.

What would be the best approach?
Reply
#6
If you want bitperfect output as good as possible remove pulseaudio and use ALSA directly.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi is changing pulse sink by using sync playback to display00
This forum uses Lukasz Tkacz MyBB addons.