kodi on a 65" tv
#1
When I use the Pi4 (4gb) on a 32" tv, streaming is very smooth

however ...

When I use the same Pi4( 4gb) on a 65" tv, the streaming goes not so smooth.
the streaming is sometimes interupted for only a half second, but you can see it "stammering".

It's not the movie, or the Synology drive, because on a 32" it's perfect.

Is a 65" tv too big for a Pi4 (4gb)?
Or do I need to tweak some settings?

thnx
Reply
#2
Size of the TV should have nothing to do with streaming performance. Look elsewhere, like location of the pi.
Reply
#3
Unless the larger TV has a larger resolution.
Reply
#4
(2019-10-07, 23:22)Sjarel77 Wrote: When I use the same Pi4( 4gb) on a 65" tv, the streaming goes not so smooth.

debug log (wiki) please.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#5
Sounds like different refresh rates between the 2 TV's.
Reply
#6
Yes - the causes of judder in streaming are likely to be :

1. Different network connectivity - particularly if the Pi is using WiFi or Powerline Ethernet (Is the position of the Pi when feeding a 65" display different to when feeding a 32" display - different rooms, different position within a room, 2.4GHz interference from USB 3.0 etc.)

2. Different resolution. Is the Pi feeding the 65" display 4K, but the 32" display 1080p or 720p?

3. Different frame rates. Is the Pi playing the correct frame rate for the source material to the 32" display, but running at the wrong refresh rate when feeding the 65"?  (24p stuff at 50p looks horrible)
Reply
#7
(2019-10-08, 00:16)ActionA Wrote: Size of the TV should have nothing to do with streaming performance. Look elsewhere, like location of the pi.

Good afternoon.
What do you mean with the "location"?
The Pi is always next to the tv, and always connected by cat5e or cat6 cables.
No wifi is involved
Reply
#8
(2019-10-08, 08:55)mcelliott Wrote: Unless the larger TV has a larger resolution.

the 32" = 1920 x 1080
the 65" = 3840 x 2160
Reply
#9
(2019-10-08, 13:04)noggin Wrote: Yes - the causes of judder in streaming are likely to be :

1. Different network connectivity - particularly if the Pi is using WiFi or Powerline Ethernet (Is the position of the Pi when feeding a 65" display different to when feeding a 32" display - different rooms, different position within a room, 2.4GHz interference from USB 3.0 etc.)

2. Different resolution. Is the Pi feeding the 65" display 4K, but the 32" display 1080p or 720p?

3. Different frame rates. Is the Pi playing the correct frame rate for the source material to the 32" display, but running at the wrong refresh rate when feeding the 65"?  (24p stuff at 50p looks horrible)

1. The Pi is always connected by cables. no Wifi or powerlines are used. Every room has its own network connection (cat6 cables).  And every room has its own linksys switch.
So both rooms have the same setup.

2. 65" should be 4K (3840 x 2160), the 32" is 1080p

3. that I have to check how I can change it
Reply
#10
We need a debug log and/or the resolutions/refresh rates each TV supports.
Reply
#11
(2019-10-08, 09:32)Klojum Wrote:
(2019-10-07, 23:22)Sjarel77 Wrote: When I use the same Pi4( 4gb) on a 65" tv, the streaming goes not so smooth.
debug log (wiki) please. 
ok, I will have a look into that...
Reply
#12
Out of the box, Pi4 supports up to 1080p60 and 4kp30.
To enable 4kp60 you need to add hdmi_enable_4kp60=1 to config.txt.

I suspect your smooth TV is choosing 1080p60 and the not smooth one is choosing 4kp30
and you are seeing a problem with the lower framerate.

Either change the resolution in the GUI to 1080p (which will allow the higher framerate)
or add hdmi_enable_4kp60=1 to config.txt.

4kp60 isn't enabled by default as it requires higher clock frequencies and runs a little warmer.
Reply
#13
(2019-10-08, 17:04)popcornmix Wrote: Out of the box, Pi4 supports up to 1080p60 and 4kp30.
To enable 4kp60 you need to add hdmi_enable_4kp60=1 to config.txt.

Can I edit these files on a normal Windows-system?
Or do I need some linux/ubuntu?
Reply
#14
(2019-10-08, 19:02)Sjarel77 Wrote:
(2019-10-08, 17:04)popcornmix Wrote: Out of the box, Pi4 supports up to 1080p60 and 4kp30.
To enable 4kp60 you need to add hdmi_enable_4kp60=1 to config.txt.

Can I edit these files on a normal Windows-system?
Or do I need some linux/ubuntu? 
Just ssh into your pi4 and edit the file there.
Need help programming a Streamzap remote?
Reply
#15
(2019-10-08, 17:04)popcornmix Wrote: Out of the box, Pi4 supports up to 1080p60 and 4kp30.
To enable 4kp60 you need to add hdmi_enable_4kp60=1 to config.txt.

I suspect your smooth TV is choosing 1080p60 and the not smooth one is choosing 4kp30
and you are seeing a problem with the lower framerate.

Either change the resolution in the GUI to 1080p (which will allow the higher framerate)
or add hdmi_enable_4kp60=1 to config.txt.

4kp60 isn't enabled by default as it requires higher clock frequencies and runs a little warmer.
I have added it.
My config.txt looks like this now:

# SPDX-License-Identifier: GPL-2.0-or-later
# Copyright © 2009-2014 Stephan Raue ([email protected])
# Copyright © 2016-present Team LibreELEC (https://libreelec.tv)
################################################################################
# Bootloader configuration - config.txt
################################################################################

################################################################################
# Memory (System/GPU configuration )
################################################################################

# Default GPU memory split - at least 288M is needed for some 4k HEVC files
gpu_mem=320

################################################################################
# For overclocking and various other settings, see:
# https://www.raspberrypi.org/documentatio...fig-txt.md
################################################################################
# Set 'force_turbo=1' to disable dynamic overclocking and enable overclocking always.
force_turbo=0

# Force HDMI even if unplugged or powered off
# hdmi_force_hotplug=1

# Doesn't sent initial active source message.
# Avoids bringing CEC (enabled TV) out of standby and channel switch when
# rebooting.
hdmi_ignore_cec_init=1

hdmi_enable_4kp60=1

################################################################################
# End of default configuration
################################################################################

################################################################################
# Include distribution specific config file if it exists.
################################################################################
[all]
include distroconfig.txt
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
kodi on a 65" tv00