•   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 17
  •   
Beta Sling
#46
(2020-01-28, 14:32)mxlance Wrote: I am still getting an error
log: link removed as it contains sensitive info
Channels do still show and play in the channel list.
However i can not update channels or the guide data.
The guide is empty.
this is only happening on my linux/kubuntu 19.10 laptop.

Thank you
@mxlance  I did have one question about your empty guide, are you like me, transitioning from ps vue?  One thing I noted on my system was when I deleted ps vue, and tried to clear the m3u/xlmtv settings in iptv simple. but when I looked iptv simple settings file, I found it continued to have the settings for the deleted m3u/xlmtv from ps vue. I ended up uninstalling and reinstalling iptv simple and then moved forward. You'll have to forgive me if this has no connection to your problem but I thought I would ask.
Reply
#47
(2020-01-28, 17:01)clones Wrote: Thank you @d21spike. I felt it was odd that the same channels were excluded when I installed the addon on another computer. I believe I have tried a manual update on the first computer but will try tonite.

(Also, to give a good log, I know I 'enable to debug log' option in kodi settings, I also notice there is one in the addon, is it important to have them both 'enabled' 

 thank you and @eracknaphobia for all your work on this great addon. 

In the case of the channel, it could be a few factors. For example if the HTTP request failed and no information was returned for the channel it may end missing. Or if no guide information was returned the same may happen. Can't know till we see that log unfortunately.

Logging...Basically think of it like this, when you "Enable debug logging" in Kodi, you will printing more information to the log file. With it enabled, any add-on that "chooses" to print is allowed. In the case of Sling, this choice is on a toggle, "Enable Debugging." Since a good bit of information is printed by Sling it may drown out anything else you may be trying to troubleshoot, hence it's on a toggle.

To directly answer your question, yes both have to be "On" in order to retrieve debug information from the add-on.
Reply
#48
@d21spike
I reinstalled iptv simple  it didn't help.  So I removed both iptv simple and Sling data folders. Sling is now updating channels with no errors. I will report back when the guide is done.

@clones - no I was not a ps cue customer. Came to sling after HDHR streaming service went under.

thank you for the help

UPDATE: THAT fixed it. Deleting the userdata, rebooting and re-logging in did it.
Thank you for the idea about reinstalling IPTV Simple. that gave me the idea to delete the userdata.
Reply
#49
(2020-01-28, 16:33)d21spike Wrote:
(2020-01-24, 23:15)bds3151 Wrote: The log is reporting massive amounts of large audio sync errors.
We had a coded work around for what I think this is. Basically, lower-power devices would not support 6 channel audio and would stutter trying to play. I would make sure your device is playing 2 channel audio by playing something and opening Settings -> Audio Settings -> Audio Stream. If it grayed out, then it's managed by inputstream adaptive and can be enabled through that add-on settings. If this is the case, we may have to revisit this. A log of this may help as well.

Image
(2020-01-24, 23:38)bds3151 Wrote: I don't think this is a problem in selecting the correct stream. Outside of Kodi, the Win10 Sling app works flawlessly at the max rate. Inside Kodi, it is highly variable and within 1 day, will buffer at least 30 times a day. How can this be a connection issue on the same machine when Kodi and the Sling addon are the only variables? 

See above. Also note, the Sling add-on does not handle playback. Once inputstream adaptive is handed the url and key, the add-on is all hands off.
(2020-01-25, 18:09)mxlance Wrote: getting a sling error this morning
Log link removed
however things are still working as far as i can tell, Odd.

thank you

I do not see any Sling specific error in this log. If it happens again, can you make note of what the error is?
(2020-01-26, 02:45)clones Wrote: Installed the addon, as I open it and click on 'channels' I am getting an error as well as I am not getting the channels in the guide, I have 'cleared data' for the general and the guide but not sure what's happening.

I had uninstalled the ps vue addon, and realized that in simple iptv under m3u & xmltv still had the previous locations for the ps vue epg guide, so I changed both to remote path (internet address) and reinstalled the add on but am still getting not getting the channels in the guide. I am not sure if the sling addon is supposed to fill the m3u & xmltv locations because their still on remote path).  here's my log 
Log link removed


EDIT: No luck so far. I feel like I need to add the m3u & the xmltv to the simple IPTV but am not sure where they are located (when I was using ps vue, it was in ps vue addon file, but I do not see epg/xmltv files in the sling addon file). I also looked in the simple iptv settings file & even through I have changed the setting to remote path, the setting file still lists the ps vue epg & xmltv links). I uninstalled and reinstalled the simple iptv and have the m3u/xmltv set on remote path, cleared the guides, but sling is not showing up in my guide (besides my nextpvr). Help...  

Ok looking through your log, I did see Sling failed to retrieve a thumbnail for one of the channels. This is addressed in version 0.0.83, so you can try again and see what happens. Also, sometimes I found it helpful going to IPTV Simple settings and toggling update (even if it's the same version.) Not sure why this helps but for me it does. In terms of the add-on, Sling is supposed to generate a xml and m3u file in the add-on directory under userdata. Afterwards, it attempts to point IPTV simple to these files and trigger a restart.
(2020-01-26, 20:37)clones Wrote: OKay, now I am not getting the error when I go into channels in the sling addon but..

I ended up uninstalling and reinstalling the simple iptv and have the m3u/xmltv set on remote path, cleared the guides, but sling is not showing up in my guide (besides my nextpvr). 

EDIT: I should have been more patient and let the channel guide load, as one I clicked manual guide load, and let it finish, I guide loaded up. I believe I'm good. Thank you for a great addon.

I did notice an issue, if you access the guide before sling is done building the files and before IPTV pulls in the new files it may hang like this. Need to think of a fix for this. Version 0.0.83 should address the Sling error.
(2020-01-26, 22:58)clones Wrote: One odd thing I noticed, is ESPN is not coming up in my channels/guide. I tried to clear in general/guide in pvr but it has not brought it up. When I manually updated the channels I did see ESPN process through, so not exactly sure why. I went into the sling.epg.xml file and ESPN is not in the channel listings (ESPN2, ESPNU, ESPNews are listed). (It also looks like the MLB network & NBC Sports Network is not downloaded only the MLB Alt & NBC sports network alt, as well). 

I did go into the sling addon, and the channels are listed there, their just not coming up in the epg

EDIT: I have installed the addon on another (win10) computer and the same channels are missing from the epg.xml and the guide.  Huh

Usually a channel is excluded if no guide data was found for the channel. If the issue persists, I suggest triggering a manual guide update and getting a log.
(2020-01-27, 04:26)bds3151 Wrote: I set Inputstream to manual and even on the lowest quality stream I still get buffering quite often. Am I the only one seeing this? I can drop out of Kodi and run the Sling app in Win10 and it's fine. I can replicate this on several machines. 

See reply above.
(2020-01-27, 20:33)bds3151 Wrote: Is inputstream adaptive being abandoned on the Win10 platform? 
https://forum.kodi.tv/showthread.php?tid=349961&page=2 

 Might be Xbox, either way news to me.
(2020-01-28, 14:32)mxlance Wrote: I am still getting an error
Log link removed
Channels do still show and play in the channel list.
However i can not update channels or the guide data.
The guide is empty.
this is only happening on my linux/kubuntu 19.10 laptop.

Thank you

Try triggering an update on IPTV Simple (even if the version is the same), this sometimes fixes it for me. 

Re: stuttering and audio errors - The audio stream is greyed out. So this is an Inputstream Adaptive issue.
Reply
#50
(2020-01-28, 16:33)d21spike Wrote: ... If it grayed out, then it's managed by inputstream adaptive and can be enabled through that add-on settings. ...

(2020-01-28, 20:05)bds3151 Wrote: Re: stuttering and audio errors - The audio stream is greyed out. So this is an Inputstream Adaptive issue.     

See the bolded and underlined text that was quoted, sorry if I wasn't clear.

Inputstream Adaptive Settings
Image

Audio Settings during playback
Image
Reply
#51
(2020-01-20, 15:35)eracknaphobia Wrote:
(2020-01-20, 07:53)bds3151 Wrote: Great work on the new add on! I have noticed the channels from Sling and the HDHomerun DVR app in the guide but the program info is wrong for the Sling channels.  It's not a time zone issue, however, it seems like the HD Homerun OTA program info has overwritten the Sling info.

I've seen that happen with my guide (I use the hdhomerun pvr client as well). What I usually do is go into the pvr settings and run Clear data under General and then under Guide and it usually fixes it. If that doesn't work you could try disabling Use channel order from backend(s) and clear the data. 
Sometimes I have run into this and cleared the data but then had to reset all my channels, is there a way to set the channels so you don't have to keep moving ninety channels?
Reply
#52
(2020-01-29, 01:33)clones Wrote:
(2020-01-20, 15:35)eracknaphobia Wrote:
(2020-01-20, 07:53)bds3151 Wrote: Great work on the new add on! I have noticed the channels from Sling and the HDHomerun DVR app in the guide but the program info is wrong for the Sling channels.  It's not a time zone issue, however, it seems like the HD Homerun OTA program info has overwritten the Sling info.

I've seen that happen with my guide (I use the hdhomerun pvr client as well). What I usually do is go into the pvr settings and run Clear data under General and then under Guide and it usually fixes it. If that doesn't work you could try disabling Use channel order from backend(s) and clear the data. 
Sometimes I have run into this and cleared the data but then had to reset all my channels, is there a way to set the channels so you don't have to keep moving ninety channels?

The EPG is still a work in progress so no solution as of yet. Its tricky when there is two applications talking to IPTV at the same time overwriting each other. I have a thought to have sling channel numbering up higher and see if that fixes it, but I also only have sling interfacing with IPTV so testing isn't the simplest.
Reply
#53
(2020-01-28, 17:01)clones Wrote:
(2020-01-28, 16:33)d21spike Wrote:
(2020-01-24, 23:15)bds3151 Wrote: One odd thing I noticed, is ESPN is not coming up in my channels/guide. I tried to clear in general/guide in pvr but it has not brought it up. When I manually updated the channels I did see ESPN process through, so not exactly sure why. I went into the sling.epg.xml file and ESPN is not in the channel listings (ESPN2, ESPNU, ESPNews are listed). (It also looks like the MLB network & NBC Sports Network is not downloaded only the MLB Alt & NBC sports network alt, as well). 

I did go into the sling addon, and the channels are listed there, their just not coming up in the epg

EDIT: I have installed the addon on another (win10) computer and the same channels are missing from the epg.xml and the guide.  Huh

Usually a channel is excluded if no guide data was found for the channel. If the issue persists, I suggest triggering a manual guide update and getting a log.
(2020-01-27, 04:26)bds3151 Wrote:  

Thank you @d21spike. I felt it was odd that the same channels were excluded when I installed the addon on another computer. I believe I have tried a manual update on the first computer but will try tonite.

(Also, to give a good log, I know I 'enable to debug log' option in kodi settings, I also notice there is one in the addon, is it important to have them both 'enabled' 

 thank you and @eracknaphobia for all your work on this great addon.  
I did a one day manual update of the guide, and several of the channels (ESPN, NBC Sports Network, MLB, SYFY) are still missing from the guide (after the manual update, I also cleared the guide). 

I tried upload a log file twice but I got an error that the file was too large (max size is 1mb) ....
Reply
#54
(2020-01-29, 02:56)clones Wrote:
(2020-01-28, 17:01)clones Wrote:
(2020-01-28, 16:33)d21spike Wrote: Usually a channel is excluded if no guide data was found for the channel. If the issue persists, I suggest triggering a manual guide update and getting a log.

Thank you @d21spike. I felt it was odd that the same channels were excluded when I installed the addon on another computer. I believe I have tried a manual update on the first computer but will try tonite.

(Also, to give a good log, I know I 'enable to debug log' option in kodi settings, I also notice there is one in the addon, is it important to have them both 'enabled' 

 thank you and @eracknaphobia for all your work on this great addon.   
I did a one day manual update of the guide, and several of the channels (ESPN, NBC Sports Network, MLB, SYFY) are still missing from the guide (after the manual update, I also cleared the guide). 

I tried upload a log file twice but I got an error that the file was too large (max size is 1mb) .... 

Pastebin should be able to support larger file size. https://pastebin.com/
Reply
#55
(2020-01-29, 04:05)d21spike Wrote:
(2020-01-29, 02:56)clones Wrote:
(2020-01-28, 17:01)clones Wrote: Thank you @d21spike. I felt it was odd that the same channels were excluded when I installed the addon on another computer. I believe I have tried a manual update on the first computer but will try tonite.

(Also, to give a good log, I know I 'enable to debug log' option in kodi settings, I also notice there is one in the addon, is it important to have them both 'enabled' 

 thank you and @eracknaphobia for all your work on this great addon.   
I did a one day manual update of the guide, and several of the channels (ESPN, NBC Sports Network, MLB, SYFY) are still missing from the guide (after the manual update, I also cleared the guide). 

I tried upload a log file twice but I got an error that the file was too large (max size is 1mb) ....       

Pastebin should be able to support larger file size. https://pastebin.com/

got an error at pastebin as log was 3.6mb, I am going try to upload a log from my other system that not pulling those channels
Reply
#56
(2020-01-29, 15:03)clones Wrote:
(2020-01-29, 04:05)d21spike Wrote:
(2020-01-29, 02:56)clones Wrote: I did a one day manual update of the guide, and several of the channels (ESPN, NBC Sports Network, MLB, SYFY) are still missing from the guide (after the manual update, I also cleared the guide). 

I tried upload a log file twice but I got an error that the file was too large (max size is 1mb) ....     

Pastebin should be able to support larger file size. https://pastebin.com/ 

I got an error at pastebin too, saying that 512kb is the largest paste.(log is 3.6mb)....I ended up pasted into the open issue in github. 
Just tried this one, 50mb limit... http://www.tinyupload.com/
Reply
#57
(2020-01-29, 15:16)d21spike Wrote:
(2020-01-29, 15:03)clones Wrote:
(2020-01-29, 04:05)d21spike Wrote: Pastebin should be able to support larger file size. https://pastebin.com/

I got an error at pastebin too, saying that 512kb is the largest paste.(log is 3.6mb)....I ended up pasted into the open issue in github.   
Just tried this one, 50mb limit... http://www.tinyupload.com/ 
Okay, uploaded from the other system (win10)

link removed as it contains sensitive info

epg guide is not showing channels (espn, nbc sports network, mlb)
Reply
#58
(2020-01-28, 20:32)d21spike Wrote:
(2020-01-28, 16:33)d21spike Wrote: ... If it grayed out, then it's managed by inputstream adaptive and can be enabled through that add-on settings. ...
(2020-01-28, 20:05)bds3151 Wrote: Re: stuttering and audio errors - The audio stream is greyed out. So this is an Inputstream Adaptive issue.     

See the bolded and underlined text that was quoted, sorry if I wasn't clear.

Inputstream Adaptive SettingsImageAudio Settings during playbackImage 

I have checked that I am on manual, running 2 channel audio, and retested. Unfortunately, the buffering continues. Seems like it may be slightly less often, and it recovers within a 5~15 seconds where as before it would have went on for a minute or more.
Reply
#59
All previous log posts were removed due to the presence of sensitive information. This issue has now been removed from add-on logging and shouldn't occur anymore. Thank you to @DarrenHill for help with cleaning up the posts.
 
(2020-01-29, 15:59)clones Wrote: Okay, uploaded from the other system (win10)

link removed as it contains sensitive info

epg guide is not showing channels (espn, nbc sports network, mlb) 
I took a look at the add-on behavior with your subscription packages and found the issue. The "fix" for duplicate channels affecting users with both Sling Orange and Sling Blue was a bit overzealous and matched on channels that were similar, more specifically in this case "ESPN" was a sub-string of "ESPN Goal Line" and similarly "NBC Sports Network" was a sub-string of "NBC Sports Network-Alt." The add-on version 0.0.85 addresses this issue.
(2020-01-29, 18:18)bds3151 Wrote: I have checked that I am on manual, running 2 channel audio, and retested. Unfortunately, the buffering continues. Seems like it may be slightly less often, and it recovers within a 5~15 seconds where as before it would have went on for a minute or more. 
Improvement implies it's a step in the right direction but unfortunately also something out of my hands. Can you tell me which devices are affected, which version of Kodi, and your network speeds? Also, if you can grab a log of this event (make sure to be on at least version 0.0.85, see above.) Even if I can't come up with anything maybe someone else might be able to chime in.
Reply
#60
(2020-01-29, 20:11)d21spike Wrote: All previous log posts were removed due to the presence of sensitive information. This issue has now been removed from add-on logging and shouldn't occur anymore. Thank you to @DarrenHill for help with cleaning up the posts.
 
(2020-01-29, 15:59)clones Wrote: Okay, uploaded from the other system (win10)

link removed as it contains sensitive info

epg guide is not showing channels (espn, nbc sports network, mlb) 
I took a look at the add-on behavior with your subscription packages and found the issue. The "fix" for duplicate channels affecting users with both Sling Orange and Sling Blue was a bit overzealous and matched on channels that were similar, more specifically in this case "ESPN" was a sub-string of "ESPN Goal Line" and similarly "NBC Sports Network" was a sub-string of "NBC Sports Network-Alt." The add-on version 0.0.85 addresses this issue.
(2020-01-29, 18:18)bds3151 Wrote: I have checked that I am on manual, running 2 channel audio, and retested. Unfortunately, the buffering continues. Seems like it may be slightly less often, and it recovers within a 5~15 seconds where as before it would have went on for a minute or more. 
Improvement implies it's a step in the right direction but unfortunately also something out of my hands. Can you tell me which devices are affected, which version of Kodi, and your network speeds? Also, if you can grab a log of this event (make sure to be on at least version 0.0.85, see above.) Even if I can't come up with anything maybe someone else might be able to chime in. 
Thx. It is an improvement. I just noticed I'm on ver .83 so I'll update and wait to see if it happens again. My systems are all Win10, NUC83i, NUC75i, and a Deskmini A300 and have tried Kodi 18.5, 18.4 and 18.3. I have a 100mbps Frontier Fios connection. I'll follow up with a log once I upgrade to .85.
Reply
  •   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 17
  •   



Logout Mark Read Team Forum Stats Members Help
Sling0
This forum uses Lukasz Tkacz MyBB addons.