•   
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 25
  •   
[RELEASE] AutoWidget - Let your widgets work for you!
(2020-04-29, 16:56)drinfernoo Wrote: I can't remember right off if there is a "Networks" or "Studios" menu in there... but I added them to my library from TMDbHelper, if that helps Rofl

The most important that is possible to add this from TMDbhelper Smile I will try to figure it out...
Reply
In Edit Path/artwork would it be possible to have an option to remove artwork, i.e. if I don't want any Fanart I could remove this?
Reply
(2020-04-30, 21:44)FXB78 Wrote: In Edit Path/artwork would it be possible to have an option to remove artwork, i.e. if I don't want any Fanart I could remove this?

I can try and figure out a way to do that, but I don't know that Kodi provides a way to pick "None" in a browser dialog...
Reply
(2020-05-01, 16:39)drinfernoo Wrote:
(2020-04-30, 21:44)FXB78 Wrote: In Edit Path/artwork would it be possible to have an option to remove artwork, i.e. if I don't want any Fanart I could remove this?

I can try and figure out a way to do that, but I don't know that Kodi provides a way to pick "None" in a browser dialog... 
Okay thanks, in the meantime I edited the .group file from userdata to change the fanart to "" and it worked, so it's not a big problem Smile
Reply
(2020-04-26, 19:25)FXB78 Wrote: @drinfernoo Is there a way to create a Shortcut to open the Screensaver? I use the code XBMC.ActivateScreensaver() which works in the Power menu but I'm not sure which parameters to use to create this as a Shortcut in Auto Widget, or if it is even possible?

This should be working in 1.6.0.

I'm going to work on an easier way to make sure that all these parameters match up the way they should, but by using the right combination of advanced parameters in the path editor dialog, you can now execute any path verbatim. In particular, the following must be true:

  1. target must be "shortcut"
  2. path must not be a plugin, library, or Android app path (anything that contains ://)
  3. path must contain a set of ( ) (empty or with arguments)

With those conditions met, whatever value is in path will be executed verbatim, so you could use ReloadSkin(), ActivateWindow(Weather), LoadProfile(Kids), or probably any other shortcut you can come up with that is run as a Kodi "built in".

This will obviously only work for paths in shortcut groups, and requires the use of the "advanced" settings in the path dialog. As always, I heavily recommend using the path editor dialog to make these modifications, but if you feel like you have to edit the JSON manually, I recommend https://jsoneditoronline.org/.

Enjoy Big Grin
Reply
Hey @drinfernoo, I just tried 1.6.0 and created a shortcut to XBMC.ActivateScreensaver() and it works perfectly! Thanks for adding this feature Smile
Reply
[ARCTIC ZEPHYR 2]

I can't make TMDB Trendings to work as Widgets.

I have TMDB Add-on on Home screen and I would like to give it Trending widget (on Arctic Zephyr 2 Widgets go below Submenu items).

The problem is, it won't load! I press Down arrow and Widget doesn't load.

How to fix this? I tried adding even that item with ridiculously long ID but even that item won't load.

What's funny is that even when adding Widget with built-in Kodi Widget support TMDB won't load.

Is anyone else experiencing this? I was sure that AutoWidget will fix this but surprisingly it's still not working. Then I thought it takes ages to load so I left Kodi running for 30 minutes, still can't get widget to work. I also tried force reload within AutoWidget settings.

Thanks in advance! I hope that at least someone from this thread is using TMDB + added Widgets into submenus. One more Add-on has this problem too but I can't mention it here. While everything else works what I needed so far.
Reply
(2020-05-10, 01:04)ArcticBeast Wrote: [ARCTIC ZEPHYR 2]

I can't make TMDB Trendings to work as Widgets.

I have TMDB Add-on on Home screen and I would like to give it Trending widget (on Arctic Zephyr 2 Widgets go below Submenu items).

The problem is, it won't load! I press Down arrow and Widget doesn't load.

How to fix this? I tried adding even that item with ridiculously long ID but even that item won't load.

What's funny is that even when adding Widget with built-in Kodi Widget support TMDB won't load.

Is anyone else experiencing this? I was sure that AutoWidget will fix this but surprisingly it's still not working. Then I thought it takes ages to load so I left Kodi running for 30 minutes, still can't get widget to work. I also tried force reload within AutoWidget settings.

Thanks in advance! I hope that at least someone from this thread is using TMDB + added Widgets into submenus. One more Add-on has this problem too but I can't mention it here. While everything else works what I needed so far.
Works for me, I have trending widgets and random widgets working great with AZ2. Log file would probably show the issue.
Reply
(2020-05-10, 01:10)FXB78 Wrote:
(2020-05-10, 01:04)ArcticBeast Wrote: [ARCTIC ZEPHYR 2]

I can't make TMDB Trendings to work as Widgets.

I have TMDB Add-on on Home screen and I would like to give it Trending widget (on Arctic Zephyr 2 Widgets go below Submenu items).

The problem is, it won't load! I press Down arrow and Widget doesn't load.

How to fix this? I tried adding even that item with ridiculously long ID but even that item won't load.

What's funny is that even when adding Widget with built-in Kodi Widget support TMDB won't load.

Is anyone else experiencing this? I was sure that AutoWidget will fix this but surprisingly it's still not working. Then I thought it takes ages to load so I left Kodi running for 30 minutes, still can't get widget to work. I also tried force reload within AutoWidget settings.

Thanks in advance! I hope that at least someone from this thread is using TMDB + added Widgets into submenus. One more Add-on has this problem too but I can't mention it here. While everything else works what I needed so far.
Works for me, I have trending widgets and random widgets working great with AZ2. Log file would probably show the issue. 
I am glad to hear that they are working at least.

So as soon as you open Kodi when you go Down under TMDB it loads you Trending/Random Movies and TV Shows widget?

I never actually had experience with finding and reading Kodi log files. Where is log file located, which one I should seek for and where I should look for errors?

I guess Kodi reset should fix problem. I just hope it's not connected to AZ2 skin Add-on, I spent a lot of time to make such great Arctic Zephyr 2 build.
Reply
(2020-05-10, 01:04)ArcticBeast Wrote: [ARCTIC ZEPHYR 2]

I can't make TMDB Trendings to work as Widgets.

I have TMDB Add-on on Home screen and I would like to give it Trending widget (on Arctic Zephyr 2 Widgets go below Submenu items).

The problem is, it won't load! I press Down arrow and Widget doesn't load.

How to fix this? I tried adding even that item with ridiculously long ID but even that item won't load.

What's funny is that even when adding Widget with built-in Kodi Widget support TMDB won't load.

Is anyone else experiencing this? I was sure that AutoWidget will fix this but surprisingly it's still not working. Then I thought it takes ages to load so I left Kodi running for 30 minutes, still can't get widget to work. I also tried force reload within AutoWidget settings.

Thanks in advance! I hope that at least someone from this thread is using TMDB + added Widgets into submenus. One more Add-on has this problem too but I can't mention it here. While everything else works what I needed so far.

AutoWidget definitely works with AZ2.

If you have sections that aren't loading from TMDbHelper, then they won't load form AutoWidget either... and it's also an indicator or greater issues at hand.
Reply
(2020-04-24, 22:35)drinfernoo Wrote:
(2020-04-24, 15:58)macardi Wrote: Hi, and thanks for the new version. I really appreciate to be able to add playable shortcuts from different sources. However, I got a crash when trying to play widget shortcuts that is a movie or episode. I have tried with different sources/plugins and with different skins. Oddly it works when using Artic Horizon but it fails when using Artic Zephyr. 

Log

/Marcus
Hi, and thanks for the new version. I really appreciate to be able to add playable shortcuts from different sources. However, I got a crash when trying to play widget shortcuts that is a movie or episode. I have tried with different sources/plugins and with different skins. Oddly it works when using Artic Horizon but it fails when using Artic Zephyr. 

Log

/Marcus


That appears like it would be an issue with the playing add-on.       
I would like to rise this issue again since it still persists on my setup with the latest version of Autowidget. I have tried with a number of video addons - Netflix, HBO, Viaplay, Cmore, Retrospect, Dplay, YouTube. Kodi crashes when starting a stream (movie or episode) from a shortcut group with any of these addons except YouTube. I have also tried with different skins and it happens with all I tested except Artic Horizon as I mentioned in my previous post.

Since I cant see any other reports of this issue I wonder what's the cause, any ideas?

Cheers
Marcus
Reply
(2020-05-15, 21:38)macardi Wrote:
(2020-04-24, 22:35)drinfernoo Wrote:
(2020-04-24, 15:58)macardi Wrote: Hi, and thanks for the new version. I really appreciate to be able to add playable shortcuts from different sources. However, I got a crash when trying to play widget shortcuts that is a movie or episode. I have tried with different sources/plugins and with different skins. Oddly it works when using Artic Horizon but it fails when using Artic Zephyr. 

Log

/Marcus
Hi, and thanks for the new version. I really appreciate to be able to add playable shortcuts from different sources. However, I got a crash when trying to play widget shortcuts that is a movie or episode. I have tried with different sources/plugins and with different skins. Oddly it works when using Artic Horizon but it fails when using Artic Zephyr. 

Log

/Marcus


That appears like it would be an issue with the playing add-on.       
I would like to rise this issue again since it still persists on my setup with the latest version of Autowidget. I have tried with a number of video addons - Netflix, HBO, Viaplay, Cmore, Retrospect, Dplay, YouTube. Kodi crashes when starting a stream (movie or episode) from a shortcut group with any of these addons except YouTube. I have also tried with different skins and it happens with all I tested except Artic Horizon as I mentioned in my previous post.

Since I cant see any other reports of this issue I wonder what's the cause, any ideas?

Cheers
Marcus

I'm really not sure... I can test a couple of those, namely YouTube and Netflix, but those are the only two you mentioned that I'm able to use. There shouldn't necessarily be any reason why that would be happening, but with a debug log I can probably find the issue and get it working for you.

my recommendation for people who are having issues is to zip the addon_data/plugin.program.autowidget and addon_data/script.skinshortcuts folders, along with the one for your skin, and a debug log.

This gives me all the pertinent information about your AutoWidget setup (the groups you've made, the widgets you've pointed, and any skin settings that are relevant), and will give me the best chance to fully replicate, if possible, and fix the issue.
Reply
(2020-05-16, 02:23)drinfernoo Wrote:
(2020-05-15, 21:38)macardi Wrote:
(2020-04-24, 22:35)drinfernoo Wrote: Hi, and thanks for the new version. I really appreciate to be able to add playable shortcuts from different sources. However, I got a crash when trying to play widget shortcuts that is a movie or episode. I have tried with different sources/plugins and with different skins. Oddly it works when using Artic Horizon but it fails when using Artic Zephyr. 

Log

/Marcus


That appears like it would be an issue with the playing add-on.       
I would like to rise this issue again since it still persists on my setup with the latest version of Autowidget. I have tried with a number of video addons - Netflix, HBO, Viaplay, Cmore, Retrospect, Dplay, YouTube. Kodi crashes when starting a stream (movie or episode) from a shortcut group with any of these addons except YouTube. I have also tried with different skins and it happens with all I tested except Artic Horizon as I mentioned in my previous post.

Since I cant see any other reports of this issue I wonder what's the cause, any ideas?

Cheers
Marcus  

I'm really not sure... I can test a couple of those, namely YouTube and Netflix, but those are the only two you mentioned that I'm able to use. There shouldn't necessarily be any reason why that would be happening, but with a debug log I can probably find the issue and get it working for you.

my recommendation for people who are having issues is to zip the addon_data/plugin.program.autowidget and addon_data/script.skinshortcuts folders, along with the one for your skin, and a debug log.

This gives me all the pertinent information about your AutoWidget setup (the groups you've made, the widgets you've pointed, and any skin settings that are relevant), and will give me the best chance to fully replicate, if possible, and fix the issue.  
Thanks for your answer!

I have ziped the files and folders that you asked for.

Loggs

Thanks!
Marcus
Reply
Hi, I opened a github request before about hiding watched films in auto widgets and you were also discussing with jurialmunkey. Did it end up something which isn't possible, or are you still looking into a 'fix' for it? Many thanks.
Reply
(2020-05-16, 13:35)swiss_lis Wrote: Hi, I opened a github request before about hiding watched films in auto widgets and you were also discussing with jurialmunkey. Did it end up something which isn't possible, or are you still looking into a 'fix' for it? Many thanks.

It isn't something that AutoWidget will handle. You can see in the issue that we narrowed it down to just using the proper paths. Add-ons handle that, but AutoWidget just "passes it on".
Reply
  •   
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 25
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] AutoWidget - Let your widgets work for you!1
This forum uses Lukasz Tkacz MyBB addons.