•   
  • 1
  • 369
  • 370
  • 371(current)
  • 372
  • 373
  •   
Media Companion 3 beta's - Now with Music Video support
(2020-06-26, 21:45)Edworld Wrote: vbat99.

I have movies with 2 parts and in options to use runtime of file. For one movie it returns -1. Any idea why this happens?

Chances are this was once a complete one piece file, that has been split. When that is done, some of the header info is invalid for the track and the second part usually doesn't return a correct length.
Options are to re-encode the part returning a -1 runtime, or get the movie in one piece.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
Q re Certification (MPAA).  I was checking my movie database, and saw some "U" certifications.

For example Strategic Air Command (1954).  I have MC set to get certification from IMDB country US and when I browse IMDB it shows certification United States: Approved  and United Kingdom: U (and several others).  So I was wondering, what is the logic for scraping certifications?

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Matrix
Leia see: 304472
Reply
(2020-07-01, 02:01)scott967 Wrote: Q re Certification (MPAA).  I was checking my movie database, and saw some "U" certifications.

For example Strategic Air Command (1954).  I have MC set to get certification from IMDB country US and when I browse IMDB it shows certification United States: Approved  and United Kingdom: U (and several others).  So I was wondering, what is the logic for scraping certifications?

scott s.
.

Scraping from IMDb is always a mine-field, and the slightest change at IMDb can cause scrape issues.

I'll have a look into this tomorrow evening.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
I have come across another (stranger issues where some of my movie collection posters and backdrops have not downloaded correctly, or at all.

Collections with missing artwork :
  • The Increedibles Collection
  • The Lord of the Rings Animated Collection
  • Clash of the Titans Collection
  • Hoodwinked Collection
First thing I did, was check TMDB to see if the artwork did exist - they do. Seconds thing I did was to ensure the Collection Folder matched the name on TMDB - again, they match

The next thing I did was select a movie from the collection, right-click, select, Rescrape specific, then MovieSet Artwork -  no errors display so one would assume the artwork downloaded, but when checking, the artwork didn't

The next thing I did was go into the Movie Set tab, right-click a Collection then scrape the missing poster and backdrop - this time an error does pop up :
Problem formulating correct save information for Fanart
Please check your settings


This doesn't happen for every collection - only a few (ass per above examples), so I know my settings are correct.

Has anyone else had this issues, or know how to fix it ?
Reply
(2020-06-17, 11:16)vbat99 Wrote:
(2020-06-16, 00:18)NBAJ2K Wrote: I'm sorry, just ONE more question, this one regarding Trailers.

Now that the NFO file seems to be populating correctly (thanks again for the help on that) if have the movie selected and go to the information screen I can now see the ratings for all the movies.

However when I select "Trailer" nothing seems to happen. If I go to "Refresh" for each movie and have it refresh the movie information from the internet instead of locally, it seems to work then when selecting "Trailer", and it opens fine but I think that defeats the purpose of Media Companion.

I wasn't sure if it matters but under Movie Preferences in Media Companion I have trailers enabled from HD-Trailers.net. Is there anything else I need to do in order to configure that to work? I don't want to download the trailers locally, and hope to have them stream if a movie is selected. I've already generated and input the YouTube API key in case that's needed

Thanks again, sorry for the additional question!
-J

It depends on if the trailer is coming from Youtube for Media Companion. Youtube is now a fickle child requiring more work to get the correct url.

I'll do some testing and see what Kodi is exporting for trailer url, make sure its matching what we supply in Media Companion.
Hey vbat99,

Was just wondering if you had any luck regarding the trailers, wondering if it's something else on my end that needs to be changed, or if it's something with how it's being linked in Media Companion.

Thanks again for your help, sorry to bother you again about it!
-J
Reply
(2020-07-04, 05:52)Ozpeg Wrote: I have come across another (stranger issues where some of my movie collection posters and backdrops have not downloaded correctly, or at all.

Collections with missing artwork :
  • The Increedibles Collection
  • The Lord of the Rings Animated Collection
  • Clash of the Titans Collection
  • Hoodwinked Collection
First thing I did, was check TMDB to see if the artwork did exist - they do. Seconds thing I did was to ensure the Collection Folder matched the name on TMDB - again, they match

The next thing I did was select a movie from the collection, right-click, select, Rescrape specific, then MovieSet Artwork -  no errors display so one would assume the artwork downloaded, but when checking, the artwork didn't

The next thing I did was go into the Movie Set tab, right-click a Collection then scrape the missing poster and backdrop - this time an error does pop up :
Problem formulating correct save information for Fanart
Please check your settings


This doesn't happen for every collection - only a few (ass per above examples), so I know my settings are correct.

Has anyone else had this issues, or know how to fix it ?

How/where is the collection artwork being saved? What are your exact settings in Media Companion, as this will assist in finding out what is going wrong.
Image from MC Wiki page for Movie Artwork settings.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
(2020-07-05, 02:19)NBAJ2K Wrote: Hey vbat99,

Was just wondering if you had any luck regarding the trailers, wondering if it's something else on my end that needs to be changed, or if it's something with how it's being linked in Media Companion.

Thanks again for your help, sorry to bother you again about it!
-J

I haven't had any time to look further into this, probably won't for another month till real life settles down again.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
(2020-07-05, 21:17)vbat99 Wrote:
(2020-07-05, 02:19)NBAJ2K Wrote: Hey vbat99,

Was just wondering if you had any luck regarding the trailers, wondering if it's something else on my end that needs to be changed, or if it's something with how it's being linked in Media Companion.

Thanks again for your help, sorry to bother you again about it!
-J

I haven't had any time to look further into this, probably won't for another month till real life settles down again.
Absolutely no rush at all, totally understand!

Thank you!
-J
Reply
(2020-07-05, 21:15)vbat99 Wrote:
(2020-07-04, 05:52)Ozpeg Wrote: I have come across another (stranger issues where some of my movie collection posters and backdrops have not downloaded correctly, or at all.

Collections with missing artwork :
  • The Increedibles Collection
  • The Lord of the Rings Animated Collection
  • Clash of the Titans Collection
  • Hoodwinked Collection
First thing I did, was check TMDB to see if the artwork did exist - they do. Seconds thing I did was to ensure the Collection Folder matched the name on TMDB - again, they match

The next thing I did was select a movie from the collection, right-click, select, Rescrape specific, then MovieSet Artwork -  no errors display so one would assume the artwork downloaded, but when checking, the artwork didn't

The next thing I did was go into the Movie Set tab, right-click a Collection then scrape the missing poster and backdrop - this time an error does pop up :
Problem formulating correct save information for Fanart
Please check your settings


This doesn't happen for every collection - only a few (ass per above examples), so I know my settings are correct.

Has anyone else had this issues, or know how to fix it ?

How/where is the collection artwork being saved? What are your exact settings in Media Companion, as this will assist in finding out what is going wrong.
Image from MC Wiki page for Movie Artwork settings.
Just checked my settings and they are exactly as per the screenshot Above, so not sure what's going on.
Reply
@Ozpeg

you should be setting "to Central Folder" as that is what v19 will use.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2020-07-07, 05:26)Ozpeg Wrote: Just checked my settings and they are exactly as per the screenshot Above, so not sure what's going on.

So for movie central folder, is the folder already created? Or is MC renaming and creating folders when you scrape the movie?
eg do you have already
\Movies\The Incredibles Collection\The Incredibles (2004)\The Incredibles (2004).mkv

Or when you scrape do you have Auto Rename Folders and Files selected?

If the collections folder does not exist, then the error message you posted
Quote:Problem formulating correct save information for Fanart
Please check your settings
As MC can't find the collection folder to place the artwork into.

As Karellen mentioned, a Central folder may be best option going forward.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
(2020-07-07, 05:50)Karellen Wrote: @Ozpeg

you should be setting "to Central Folder" as that is what v19 will use.

This there a ticket about this? Will Collection artwork be part of Kodi V19.
If so what are the settings/options for file naming?
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
@vbat99

Merged PR for v19 here... https://github.com/xbmc/xbmc/pull/16970

It's already working as I tested extensively just before merging.

File naming uses short artwork names as shown in the PR and also in section 1.2 here... https://kodi.wiki/view/Movie_sets_artwork
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
vbat99,

Is there an option to save extrafanart in movie folder and not extrafanart folder? Also related to extrafanart, I have been using an advancedsettings file for extrafanart. That file starts with fanart1 instead of fanart0 as it is with MC. Is there an option in MC to start with fanart1?
Reply
(2020-07-07, 12:46)vbat99 Wrote:
(2020-07-07, 05:50)Karellen Wrote: @Ozpeg

you should be setting "to Central Folder" as that is what v19 will use.

This there a ticket about this? Will Collection artwork be part of Kodi V19.
If so what are the settings/options for file naming?

I had configured MC to download the movie set artwork directly into the movie collection folder, but after seeing Karellen's post plus reading the Wiki I'll make the change now to use a Movie Central Folder and re-download the artwork. Does anyone know when Kodi V19 will be released ? I'm still on 18.7
Reply
  •   
  • 1
  • 369
  • 370
  • 371(current)
  • 372
  • 373
  •   



Logout Mark Read Team Forum Stats Members Help
Media Companion 3 beta's - Now with Music Video support10
This forum uses Lukasz Tkacz MyBB addons.