Nvidia Jetson Nano, superfast Kodi device?
#61
(2020-07-28, 22:15)jaj2020 Wrote: Hey,
The Nano is hooked up to a freaking cell phone charger and it works... :-)
As long as you don't have peripherals connected - it should be fine.

One last thing, do you have any clue regarding hdmi-cec? Couldn't get it to work from the Nano.
It's the last missing piece of a terrific media center.

You'll need to install dependency for CEC. 

Code:

# apt install libcec-dev

And re-run CMake followed by build after that. Make sure, you see it have been found in CMake output.

You can also give it a try to my new docker container. It contains everything pre-compiled from the last commit and includes libcec. Here is more details on Docker
Reply
#62
I did compile with libcec-dev ( saw it when I ran cmake - it recognized the library ). However didn't see the CEC option in SYSTEM-SETTINGS peripherals section.
Maybe it's a hardware thing? Not sure if Jetson's HDMI supports it.
I'll check your docker package.

Thanks.
Reply
#63
Hey,

I'm getting a permission denied error trying to access the docker:

Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post http://%2Fvar%2Frun%2Fdocker.sock/v1.39/...tag=latest: dial unix /var/run/docker.sock: connect: permission denied
Reply
#64
(2020-07-29, 11:13)jaj2020 Wrote: I did compile with libcec-dev ( saw it when I ran cmake - it recognized the library ). However didn't see the CEC option in SYSTEM-SETTINGS peripherals section.
Maybe it's a hardware thing? Not sure if Jetson's HDMI supports it.
I'll check your docker package.

Thanks.

I have to check with a code, and get back to you on this. 

Quote:Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post http://%2Fvar%2Frun%2Fdocker.sock/v1.39/...tag=latest: dial unix /var/run/docker.sock: connect: permission denied

After you did usermod you need to relogin to new group take effect.
Reply
#65
(2020-07-29, 15:37)hashtag Wrote: I have to check with a code, and get back to you on this. 

Also please enable libCEC logging in System Settings -> Logging -> Component Specific Logging so we can see what is going on. Unfortunately my TV is very old and doesn't support CEC to give it a shot.
Reply
#66
That's the kodi log:
https://paste.kodi.tv/enemudimug.kodi
Reply
#67
(2020-07-29, 16:12)jaj2020 Wrote: That's the kodi log:
https://paste.kodi.tv/enemudimug.kodi

Yeah, logs are not very much helpful. It seems like some issue with L4T Kernel and libCEC. Some more details regarding this on NVIDIA forum.
Looks like, hardware supports it, so technically with some patchwork it is possible to bring it back to life. Yet it might be a quick fix.
Reply
#68
I also found this:

https://forums.developer.nvidia.com/t/wi...tson/35265
Reply
#69
(2020-07-30, 11:04)jaj2020 Wrote: I also found this:

https://forums.developer.nvidia.com/t/wi...tson/35265

Oh, sorry. it's the same post...
Reply
#70
https://docs.nvidia.com/jetson/l4t/index...ID0E0JB0HA

This mentions repository that contains binaries / source for Accelerated Decode with ffmpeg
Reply
#71
(2020-08-03, 07:12)TimeZlicer Wrote: https://docs.nvidia.com/jetson/l4t/index...ID0E0JB0HA

This mentions repository that contains binaries / source for Accelerated Decode with ffmpeg

I tried it, never worked for me, so had to build adapter for V4L2 video (which FFMPEG-L4T actually using under the hood).  We had quite success with it. So far few issues reported with interlacing, and CEC-Supoprt. 
There is latest nvidia-docker container, if you willing to give it a shot. All instructions are on docker description page.
Reply
#72
Thanks @hashtag

Have pull and managed to build and run it

Hit some issues

with EAC3


2020-08-08 19:26:48.467 T:9813 DEBUG <general>: VideoPlayer::Sync - Audio - pts: 633760000.000000, cache: 320000.052452, totalcache: 750000.000000
2020-08-08 19:26:48.467 T:9813 DEBUG <general>: CVideoPlayer::SetCaching - caching state 0
2020-08-08 19:26:48.467 T:9821 DEBUG <general>: CVideoPlayerAudio - CDVDMsg::GENERAL_RESYNC(-100000.000000), level: 100, cache: 320000.052452
2020-08-08 19:26:48.467 T:9813 DEBUG <general>: CDVDClock::SetSpeedAdjust - adjusted:0.000000
2020-08-08 19:26:48.467 T:9821 DEBUG <general>: CDVDAudio::Resume - resume audio stream
2020-08-08 19:26:48.468 T:9820 DEBUG <general>: CVideoPlayerVideo - CDVDMsg::GENERAL_RESYNC(-100000.000000)
2020-08-08 19:26:48.468 T:9511 WARNING <general>: ActiveAE - large audio sync error: 633570.423386
2020-08-08 19:26:48.468 T:9511 DEBUG <general>: ActiveAE - start sync of audio stream
2020-08-08 19:26:48.469 T:9511 WARNING <general>: ActiveAE - large audio sync error: 633570.087292
2020-08-08 19:26:48.580 T:9511 DEBUG <general>: ActiveAE::SyncStream - average error of 5000.000000, start adjusting
2020-08-08 19:26:48.643 T:9511 WARNING <general>: ActiveAE - large audio sync error: 633309.746437
2020-08-08 19:26:48.896 T:9820 INFO <general>: CVideoPlayerVideo - Stillframe detected, switching to forced 23.976024 fps

with multi 8 channels AAC


2020-08-08 19:31:15.011 T:10302   DEBUG <general>: CPtsTracker: detected pattern of length 1: 41708.33, frameduration: 41708.333333
2020-08-08 19:31:18.376 T:10030   DEBUG <general>: Keyboard: scancode: 0x17, sym: 0x9, unicode: 0x0000, modifier: 0x0
2020-08-08 19:31:18.643 T:10030   DEBUG <general>: Keyboard: scancode: 0x6f, sym: 0x273, unicode: 0x0000, modifier: 0x0
2020-08-08 19:31:18.776 T:10030   DEBUG <general>: Keyboard: scancode: 0x6f, sym: 0x273, unicode: 0x0000, modifier: 0x0
2020-08-08 19:31:18.776 T:10030   DEBUG <general>: HandleKey: up (0xf080) pressed, action is ChapterOrBigStepForward
2020-08-08 19:31:18.783 T:10295   DEBUG <general>: CVideoPlayer::SetCaching - caching state 2
2020-08-08 19:31:18.783 T:10295   DEBUG <general>: CDVDClock::SetSpeedAdjust - adjusted:0.000000
2020-08-08 19:31:18.793 T:10303   DEBUG <general>: CDVDAudio:Tongueause - pausing audio stream
2020-08-08 19:31:18.829 T:10295   DEBUG <general>: SeekTime - seek ended up on time 326117
2020-08-08 19:31:18.829 T:10295   DEBUG <general>: CVideoPlayer::FlushBuffers - flushing buffers
2020-08-08 19:31:18.879 T:10302   DEBUG <general>: CNVV4LBufferPool::Init 12 v4l2 buffers allocated
2020-08-08 19:31:18.881 T:10302    INFO <general>: CNVV4LBufferPool::Init 12 v4l2 buffers initalized
2020-08-08 19:31:18.887 T:10302    INFO <general>: NVV4LCodec::Reset decoder reset
2020-08-08 19:31:18.889 T:10303   DEBUG <general>: CDVDAudio::Flush - flush audio stream
2020-08-08 19:31:18.889 T:10303   DEBUG <general>: CDVDAudio:Tongueause - pausing audio stream
2020-08-08 19:31:18.889 T:10295   DEBUG <general>: CVideoPlayer - CDVDMsg::GENERAL_SYNCHRONIZE
2020-08-08 19:31:18.889 T:10030   DEBUG <general>: ------ Window Init (DialogSeekBar.xml) ------
2020-08-08 19:31:18.890 T:10303   DEBUG <general>: CVideoPlayerAudio - CDVDMsg::GENERAL_SYNCHRONIZE
2020-08-08 19:31:18.890 T:10302   DEBUG <general>: CVideoPlayerVideo - CDVDMsg::GENERAL_SYNCHRONIZE
2020-08-08 19:31:18.896 T:10295   DEBUG <general>: CheckPlayerInit - dropping packet type:2 dts:326117000.000000 to get to start point at 328119000.000000
2020-08-08 19:31:18.896 T:10302    INFO <general>: CVideoPlayerVideo - Stillframe left, switching to normal playback
2020-08-08 19:31:18.897 T:10295   DEBUG <general>: CheckPlayerInit - dropping packet type:2 dts:326034000.000000 to get to start point at 328119000.000000
2020-08-08 19:31:18.897 T:10295   DEBUG <general>: CVideoPlayer::CheckContinuity - wrapback :2, prev:326034000.000000, curr:325951000.000000, diff:-83000.000000
2020-08-08 19:31:18.897 T:10295   DEBUG <general>: CheckPlayerInit - dropping packet type:2 dts:325951000.000000 to get to start point at 328119000.000000
Reply
#73
(2020-08-08, 13:37)TimeZlicer Wrote: Thanks @hashtag

Have pull and managed to build and run it

Hit some issues

If you can, please upload video samples somewhere and full log to https://paste.kodi.tv.
Looks like, some issues with stream timestamp.
Reply
#74
Thanks! Sent you the logs and file privately
Reply
#75
Code:
mkvmerge -d 0 -A -S original.mkv -o video-only.mkv

Took another look at the logs and it seems not related to audio at all, so extracted only the video part and tried again

The problem only occurs when seeking or not playing from the beginning

Here are the logs
https://paste.kodi.tv/elekokegah.kodi
Reply



Logout Mark Read Team Forum Stats Members Help
Nvidia Jetson Nano, superfast Kodi device?0
This forum uses Lukasz Tkacz MyBB addons.