v18 Channel Groups Keep Disappearing
#1
Periodically my saved channel groups disappear and I'm left with just the standard channel groups.  Normally I just recreate the groups but I'm wondering, is there is a way to prevent this?  
Is this a Kodi problem or a Tvheadend problem? 
Can they be backed up?  
This most recently happened on my CoreELEC box but I've also had it happen on my Shield TV
2019 Shield TV Pro running Tvheadend Client (Kodi) and server
Samsung UN65JS8500 TV
Onkyo TX-NR646 Receiver
HD Homerun Quatro Tuner
Reply
#2
(2020-11-02, 02:26)RKCRLR Wrote: Periodically my saved channel groups disappear and I'm left with just the standard channel groups.  Normally I just recreate the groups but I'm wondering, is there is a way to prevent this?  
Is this a Kodi problem or a Tvheadend problem? 
Can they be backed up?  
This most recently happened on my CoreELEC box but I've also had it happen on my Shield TV


How do you create the groups? With the tvheadend web UI or with Kodis channel group manager?
Reply
#3
(2020-11-02, 09:21)ksooo Wrote:
(2020-11-02, 02:26)RKCRLR Wrote: Periodically my saved channel groups disappear and I'm left with just the standard channel groups.  Normally I just recreate the groups but I'm wondering, is there is a way to prevent this?  
Is this a Kodi problem or a Tvheadend problem? 
Can they be backed up?  
This most recently happened on my CoreELEC box but I've also had it happen on my Shield TV


How do you create the groups? With the tvheadend web UI or with Kodis channel group manager?

Kodi's channel group manager.
2019 Shield TV Pro running Tvheadend Client (Kodi) and server
Samsung UN65JS8500 TV
Onkyo TX-NR646 Receiver
HD Homerun Quatro Tuner
Reply
#4
Does this happen after you 'clear data' in settings-pvr livetv-general ?

Manually created groups in kodi will be gone after doing this. If the backend provides the groups they will be reloaded from it in kodi.

Just tried with a backend with, and one without providing channels groups. My manual groups are gone.
Reply
#5
(2020-11-03, 01:50)Atreyu Wrote: Does this happen after you 'clear data' in settings-pvr livetv-general ?

Manually created groups in kodi will be gone after doing this. If the backend provides the groups they will be reloaded from it in kodi.

Just tried with a backend with, and one without providing channels groups. My manual groups are gone.

I don't remember doing a "clear data" the last time it happened.  However, the CoreELEC box had locked up and I had to do a manual power cycle.
2019 Shield TV Pro running Tvheadend Client (Kodi) and server
Samsung UN65JS8500 TV
Onkyo TX-NR646 Receiver
HD Homerun Quatro Tuner
Reply
#6
(2020-11-03, 02:26)RKCRLR Wrote:
(2020-11-03, 01:50)Atreyu Wrote: Does this happen after you 'clear data' in settings-pvr livetv-general ?

Manually created groups in kodi will be gone after doing this. If the backend provides the groups they will be reloaded from it in kodi.

Just tried with a backend with, and one without providing channels groups. My manual groups are gone.

I don't remember doing a "clear data" the last time it happened.  However, the CoreELEC box had locked up and I had to do a manual power cycle.


Deactivate sync groups with backend in Kodi PVR settings. Look at the help text for explanation why this solves your problem.
Reply
#7
(2020-11-03, 09:23)ksooo Wrote:
(2020-11-03, 02:26)RKCRLR Wrote:
(2020-11-03, 01:50)Atreyu Wrote: Does this happen after you 'clear data' in settings-pvr livetv-general ?

Manually created groups in kodi will be gone after doing this. If the backend provides the groups they will be reloaded from it in kodi.

Just tried with a backend with, and one without providing channels groups. My manual groups are gone.

I don't remember doing a "clear data" the last time it happened.  However, the CoreELEC box had locked up and I had to do a manual power cycle.


Deactivate sync groups with backend in Kodi PVR settings. Look at the help text for explanation why this solves your problem.

Thanks, I'll give that a try.
2019 Shield TV Pro running Tvheadend Client (Kodi) and server
Samsung UN65JS8500 TV
Onkyo TX-NR646 Receiver
HD Homerun Quatro Tuner
Reply
#8
(2020-11-03, 23:12)RKCRLR Wrote:
(2020-11-03, 09:23)ksooo Wrote:
(2020-11-03, 02:26)RKCRLR Wrote: I don't remember doing a "clear data" the last time it happened.  However, the CoreELEC box had locked up and I had to do a manual power cycle.


Deactivate sync groups with backend in Kodi PVR settings. Look at the help text for explanation why this solves your problem.

Thanks, I'll give that a try.


Did it work?
Reply
#9
(2020-11-08, 09:38)ksooo Wrote:
(2020-11-03, 23:12)RKCRLR Wrote:
(2020-11-03, 09:23)ksooo Wrote: Deactivate sync groups with backend in Kodi PVR settings. Look at the help text for explanation why this solves your problem.

Thanks, I'll give that a try.


Did it work?

I could go months without having a problem so it's too early to tell for sure.  But since syncing channels to backend was enabled it seems this was likely the problem.  
Thanks
2019 Shield TV Pro running Tvheadend Client (Kodi) and server
Samsung UN65JS8500 TV
Onkyo TX-NR646 Receiver
HD Homerun Quatro Tuner
Reply



Logout Mark Read Team Forum Stats Members Help
Channel Groups Keep Disappearing0
This forum uses Lukasz Tkacz MyBB addons.