•   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 34
  •   
Release HBO Max
#16
@raina343

Just pushed 0.0.3 which adds initial subtitle supports.
Its using a python module (pycaption) to convert the TTML > SRT subs that kodi can understand.
It's a bit rough as you will see but should be ok for now.
I plan to write my own custom converter to get it better eventually.
This would also allow for a setting to not show the subs in brackets (birds tweet)
Reply
#17
@matthuisman subs now work, thank you very much for that
There is one problem however, which I hate to bring up since you went to the trouble for subs in the first place, and it appears to be in the pycaption subsystem, so I doubt you can do much about it

I took Southpark S23 E02 (band in china) as a sample.

the subs displayed onscreen for opening dialog are

[ Humming ]
Stan! Family meeting!
Nobody cares about that!
Come on!


now looking at the srt file converted by the addon

25
00:00:37,000 --> 00:00:42,000
[ Humming ]

26
00:00:42,000 --> 00:00:45,000
Stan! Family meeting!

27
00:00:42,000 --> 00:00:45,000
Get downstairs!

28
00:00:45,000 --> 00:00:45,000
I'm writing a song, Dad.

29
00:00:45,000 --> 00:00:46,000
Nobody cares about that!

30
00:00:46,000 --> 00:00:49,000
Come on!


so it appears lines 27 and 28 were skipped and looking at the timestamps it's easy to see why.  the timings are the same/overlapping

so I took a look at the source sub file on hbo (I mean they could just made life easier by using a more common sub format, sigh)

 <p region='pop1' style='basic' begin='00:00:37:01' end='00:00:42:06' tts:origin='35% 84.66%' tts:extent='27.5% 5.33%'>[ Humming ]</p>
   <p region='pop1' style='basic' begin='00:00:42:08' end='00:00:45:00' tts:origin='37.5% 79.33%' tts:extent='52.5% 5.33%'>Stan! Family meeting!</p>
   <p region='pop2' style='basic' begin='00:00:42:08' end='00:00:45:00' tts:origin='45% 84.66%' tts:extent='37.5% 5.33%'>Get downstairs!</p>
   <p region='pop1' style='basic' begin='00:00:45:02' end='00:00:45:17' tts:origin='10% 84.66%' tts:extent='60% 5.33%'>I'm writing a song, Dad.</p>
   <p region='pop1' style='basic' begin='00:00:45:19' end='00:00:46:19' tts:origin='30% 84.66%' tts:extent='60% 5.33%'>Nobody cares about that!</p>
   <p region='pop1' style='basic' begin='00:00:46:21' end='00:00:49:19' tts:origin='55% 79.33%' tts:extent='20% 5.33%'>Come on!</p>


and the timings are the same here.

so I went on a bit of a google trip, and came across

https://github.com/yanncoupin/stl2srt
this appears to be another python conversion utility. 
this utility appears to merge those rows with identical timestamps and also using the milliseconds timings that pycaption appears to drop out

so when I throw the XML subs file into that, I get

14
00:00:37,041 --> 00:00:42,250
[ Humming ]

15
00:00:42,333 --> 00:00:45,000
Stan! Family meeting!
Get downstairs!

16
00:00:45,083 --> 00:00:45,709
I'm writing a song, Dad.

17
00:00:45,792 --> 00:00:46,792
Nobody cares about that!

18
00:00:46,875 --> 00:00:49,792
Come on!
I've got big news!



which then appears works perfectly...

so I know you mentioned writing your own custom converter, but perhaps this will help avoid that need?
Reply
#18
@raina343 
thank you.
just pushed 0.0.4 that now uses stl2srt.
also a new setting to remove closed captions.
with that enabled, it will remove any text between ( ) and remove any ♪

I also had a play on Ubuntu x86_64 and confirmed the issue.
Seems its only x86_64 problem. Linux armv7 works fine.
I know of one other service (Foxtel Go) that has the same problem (LibreELEC x86_64)
I'll keep investigating.
Reply
#19
@matthuisman Thank you for yet another amazing add-on. 

I'm having an issue with skipping forward in a movie. It plays fine, but if I try to skip forward 1 minute, it stops the movie.

Here is my log: https://paste.kodi.tv/zuyepujige.kodi
Reply
#20
@Doctor Eggs 
im also on windows and saw that happen once but can't get it to do again.
does it do it all the time?
Reply
#21
Thank you for your hard work on this plug-in!

I'm having issues playing media on a Raspberry Pi 4 with Raspberry Pi OS. Navigating through the menus is slow, but works. When selecting a show, I see this log: https://paste.kodi.tv/alitofimob.kodi

Looks like a UDP connection timeout. I'm new to Kodi and I'm not sure if there's anything special I need to do to make sure connections to 127.0.0.1:49005 work as expected.

Thanks again!
Reply
#22
Please post full logs
Reply
#23
(2020-11-24, 02:02)matthuisman Wrote: @Doctor Eggs 
im also on windows and saw that happen once but can't get it to do again.
does it do it all the time?
I've tried it on all three of my windows 10 Kodi 18.9 instances and it happens on all of them. I've tried playing many different movies/tv shows and it happens every time.

I'm on IA 2.4.5 because I also use Sling and I thought that might be the issue but updating to 2.4.6 didn't fix it.
Reply
#24
@doctor Eggs
have pmd you a version to test
Reply
#25
I downloaded the repo today and the addon is not present.
Reply
#26
@Doctor Eggs 
The issue was Inputstream Adaptive Testing was installed and being used by HBO Max.
IAT has a commit changing to Bento4 which was causing the crash when fast forwarding.
IAT has been updated to remove this commit and therefore no longer crash.
Also, SlyGuy common has been updated to not automatically use IAT if it's installed.
It will only use it if forced (eg. PlutoTv)
 
(2020-11-26, 03:08)copterdr Wrote: I downloaded the repo today and the addon is not present.
its 100% there.
1) Do this: https://www.matthuisman.nz/2020/02/slygu...itory.html
2) Then Addons -> Install from Repo > SlyGuy Repo > Video add-ons > HBO Max
Reply
#27
(2020-11-26, 03:16)matthuisman Wrote: @Doctor Eggs 
The issue was Inputstream Adaptive Testing was installed and being used by HBO Max.
IAT has a commit changing to Bento4 which was causing the crash when fast forwarding.
IAT has been updated to remove this commit and therefore no longer crash.
Also, SlyGuy common has been updated to not automatically use IAT if it's installed.
It will only use it if forced (eg. PlutoTv)
 
(2020-11-26, 03:08)copterdr Wrote: I downloaded the repo today and the addon is not present.
its 100% there.
1) Do this: https://www.matthuisman.nz/2020/02/slygu...itory.html
2) Then Addons -> Install from Repo > SlyGuy Repo > Video add-ons > HBO Max

Thanks, I did the guide with sly guy repo. Must not have noticed.
Thanks you!
Copter Dr
Reply
#28
matthuisman

Have you figured out why the add-on is outputting DD audio when it's in a DD+ (EAC3) container? As I stated earlier, for some reason this seems to be the case with all apps except when Airplayed from my iPad, so apparently the source content is in DD+.
Reply
#29
@Wagg
Looking at their manifest, they have 4 adaption sets for audio

codecs="mp4a.40.2" = audio/program/en-US/2.0/r1/aac-128k.mp4
codecs="mp4a.40.5" = audio/program/en-US/2.0/r1/heaac-64k.mp4
codecs="ac-3" = audio/program/en-US/5.1/r1/ac3-384k.mp4
codecs="ec-3" = audio/program/en-US/5.1/r1/eac3-256k.mp4

Looking at the kodi debug log, it downloads: /audio/program/en-US/5.1/r1/ac3-384k.mp4
and then I see "Open() Successful opened audio decoder eac3"
So seems its downloading the ac-3 files and thinking it's eac3.

It appears Inputstream Adaptive sets the codec to eac3 for either ac-3 or eac-3 (not sure why)
https://github.com/peak3d/inputstream.ad....cpp#L2692
Maybe it leaves mpegts to figure it out?
https://github.com/peak3d/inputstream.ad...3.cpp#L153
Really not sure, would need to check with the developer of that addon.

In the audio select gui, it appears the list corresponds to:
1) ac3-384k
2) eac3-256k
3) aac-128k
4) heaac-64k
(this is because the proxy it uses orders the adaption sets by highest bitrate to lowest)

Have you tried going into the audio settings while playing and selecting the 2nd audio stream (DD+) down and see if that works correctly?
I'm testing with "The Witches" so please try the same.
Play that, open audio settings and select the 2nd item in the list.
Please advise if that plays correctly as DD+
Reply
#30
(2020-11-30, 22:42)matthuisman Wrote: @Wagg
Looking at their manifest, they have 4 adaption sets for audio

codecs="mp4a.40.2" = audio/program/en-US/2.0/r1/aac-128k.mp4
codecs="mp4a.40.5" = audio/program/en-US/2.0/r1/heaac-64k.mp4
codecs="ac-3" = audio/program/en-US/5.1/r1/ac3-384k.mp4
codecs="ec-3" = audio/program/en-US/5.1/r1/eac3-256k.mp4

Looking at the kodi debug log, it downloads: /audio/program/en-US/5.1/r1/ac3-384k.mp4
and then I see "Open() Successful opened audio decoder eac3"
So seems its downloading the ac-3 files and thinking it's eac3.

It appears Inputstream Adaptive sets the codec to eac3 for either ac-3 or eac-3 (not sure why)
https://github.com/peak3d/inputstream.ad....cpp#L2692
Maybe it leaves mpegts to figure it out?
https://github.com/peak3d/inputstream.ad...3.cpp#L153
Really not sure, would need to check with the developer of that addon.

In the audio select gui, it appears the list corresponds to:
1) ac3-384k
2) eac3-256k
3) aac-128k
4) heaac-64k
(this is because the proxy it uses orders the adaption sets by highest bitrate to lowest)

Have you tried going into the audio settings while playing and selecting the 2nd audio stream (DD+) down and see if that works correctly?
I'm testing with "The Witches" so please try the same.
Play that, open audio settings and select the 2nd item in the list.
Please advise if that plays correctly as DD+
Yup, you're right, the 2nd audio track plays properly as DD+. So almost all the HBO Max apps (Android TV, Fire TV, Roku, Chromecast stream, etc) are playing the wrong audio track. Only an Airplay2 stream from an Apple device plays the correct audio track. 

I knew the DD+ track was there because for the longest time my Nvidia Shield could play it just fine from the HBO Go app, then all of a sudden it was DD standard only.

Thanks!

Once again Kodi add-on is superior to the content provider's app. lol
Reply
  •   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 34
  •   



Logout Mark Read Team Forum Stats Members Help
HBO Max0
This forum uses Lukasz Tkacz MyBB addons.