WEB-DL 4K media flag
#1
Have just upgraded to 4K, and having some flag issues with WEB-DL content.

On my 1080p movies/series i just put WEB-DL in the file name and i get the WEB-DL flag in my library.

However, with 4K WEB-DL content, i get the "Ultra-HD Blu-ray" flag instead of the WEB-DL flag. The ones i have tried are HEVC codec files.

Does not matter if i rename it to DVD, Bluray or whatever, the flag does not change whatever i type in the filename


Anyone who can help me out?
Current Kodi/OS: Kodi 19.1 Matrix w/ Aeon Madnox 2.0 | Windows 10 Home.

HTPC: AMD Ryzen 7 5700G (8c/16t) // ASRock B550M Steel Legend // 16GB G.Skill Ripjaws V DDR4 3866Mhz // 2 x WD Black NV750 250GB NVMe + 128TB HGST NAS/WD Ultrastar // Silverstone Grandia GD07B
TV: LG OLED CX 77" Receiver: Yamaha RX-A3070 Front: Jamo S608 Center: Jamo C60 Center Surround: Jamo C60 Surround Atmos/DTS:X: Monitor Audio Bronze AMS Subwoofer: XTZ W12.18 ICE
Reply
#2
Which skin?
Reply
#3
(2021-05-27, 01:21)Hitcher Wrote: Which skin?

Aeon Madnox 2.0 (Matrix)
Current Kodi/OS: Kodi 19.1 Matrix w/ Aeon Madnox 2.0 | Windows 10 Home.

HTPC: AMD Ryzen 7 5700G (8c/16t) // ASRock B550M Steel Legend // 16GB G.Skill Ripjaws V DDR4 3866Mhz // 2 x WD Black NV750 250GB NVMe + 128TB HGST NAS/WD Ultrastar // Silverstone Grandia GD07B
TV: LG OLED CX 77" Receiver: Yamaha RX-A3070 Front: Jamo S608 Center: Jamo C60 Center Surround: Jamo C60 Surround Atmos/DTS:X: Monitor Audio Bronze AMS Subwoofer: XTZ W12.18 ICE
Reply
#4
(2021-05-27, 05:54)Simkin84 Wrote: Aeon Madnox 2.0 (Matrix)

Moved the appropriate section.
Reply
#5
Anyone?
Current Kodi/OS: Kodi 19.1 Matrix w/ Aeon Madnox 2.0 | Windows 10 Home.

HTPC: AMD Ryzen 7 5700G (8c/16t) // ASRock B550M Steel Legend // 16GB G.Skill Ripjaws V DDR4 3866Mhz // 2 x WD Black NV750 250GB NVMe + 128TB HGST NAS/WD Ultrastar // Silverstone Grandia GD07B
TV: LG OLED CX 77" Receiver: Yamaha RX-A3070 Front: Jamo S608 Center: Jamo C60 Center Surround: Jamo C60 Surround Atmos/DTS:X: Monitor Audio Bronze AMS Subwoofer: XTZ W12.18 ICE
Reply
#6
(2021-06-23, 22:48)Simkin84 Wrote: Anyone?

If the flag is in the video library, then it's a skin "problem".
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply
#7
(2021-05-26, 22:53)Simkin84 Wrote: On my 1080p movies/series i just put WEB-DL in the file name and i get the WEB-DL flag in my library.
You can see what the skin is coded to display here... https://github.com/mistervee/skin.madnox....xml#L1626

Doesn't look like 4K WEB-DL has been coded.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#8
(2021-06-23, 23:35)Karellen Wrote:
(2021-05-26, 22:53)Simkin84 Wrote: On my 1080p movies/series i just put WEB-DL in the file name and i get the WEB-DL flag in my library.
You can see what the skin is coded to display here... https://github.com/mistervee/skin.madnox....xml#L1626

Doesn't look like 4K WEB-DL has been coded.

Hm ok. So the only way to get this, is for the Author of the skin to code it?
Current Kodi/OS: Kodi 19.1 Matrix w/ Aeon Madnox 2.0 | Windows 10 Home.

HTPC: AMD Ryzen 7 5700G (8c/16t) // ASRock B550M Steel Legend // 16GB G.Skill Ripjaws V DDR4 3866Mhz // 2 x WD Black NV750 250GB NVMe + 128TB HGST NAS/WD Ultrastar // Silverstone Grandia GD07B
TV: LG OLED CX 77" Receiver: Yamaha RX-A3070 Front: Jamo S608 Center: Jamo C60 Center Surround: Jamo C60 Surround Atmos/DTS:X: Monitor Audio Bronze AMS Subwoofer: XTZ W12.18 ICE
Reply
#9
(2021-06-24, 21:59)Simkin84 Wrote: Hm ok. So the only way to get this, is for the Author of the skin to code it?
Yes, the Author or another member.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#10
(2021-06-24, 22:24)Karellen Wrote:
(2021-06-24, 21:59)Simkin84 Wrote: Hm ok. So the only way to get this, is for the Author of the skin to code it?
Yes, the Author or another member.

Ok thanks. I tried changing/adding some values/strings in the "includes_mediafile.xml" but it did not work.

Well, I hope Mr.V is alright and will be back here on the forum. Don't know if anyone else can do this.
Current Kodi/OS: Kodi 19.1 Matrix w/ Aeon Madnox 2.0 | Windows 10 Home.

HTPC: AMD Ryzen 7 5700G (8c/16t) // ASRock B550M Steel Legend // 16GB G.Skill Ripjaws V DDR4 3866Mhz // 2 x WD Black NV750 250GB NVMe + 128TB HGST NAS/WD Ultrastar // Silverstone Grandia GD07B
TV: LG OLED CX 77" Receiver: Yamaha RX-A3070 Front: Jamo S608 Center: Jamo C60 Center Surround: Jamo C60 Surround Atmos/DTS:X: Monitor Audio Bronze AMS Subwoofer: XTZ W12.18 ICE
Reply
#11
Speculating (I'm no skinner): conditions evaluation happens in order. If the video resolution gets matched first to 4k (as it is right now), you'll get the 4k flag. Your custom line will have to precede that, to show a different flag.
Reply
#12
(2021-06-25, 17:31)Daydream Wrote: Speculating (I'm no skinner): conditions evaluation happens in order. If the video resolution gets matched first to 4k (as it is right now), you'll get the 4k flag. Your custom line will have to precede that, to show a different flag.

<value condition="String.IsEqual(ListItem.VideoResolution,4k) | String.Contains(ListItem.filename,UHD)">$VAR[MediaFlagsPathVar]videocodec/4k.png</value>
<value condition="String.IsEqual(Container(7005).ListItem.VideoResolution,4k) | String.Contains(Container(7005).ListItem.filename,UHD)">$VAR[MediaFlagsPathVar]videocodec/4k.png</value>
 <value condition="String.IsEqual(VideoPlayer.VideoResolution,4k) | String.Contains(Player.filename,UHD)">$VAR[MediaFlagsPathVar]videocodec/4k.png</value>

If i change "filename, UHD" to "web-dl" and "4k.png" to "web-dl.png" in these strings i get the WEB-DL + 4K flag. But then i also get WEB-DL flag on my 4K BluRay's.
If i add another "Value Condition" to sit first, adding web-dl it wont work, still get Ultra-HD BluRay logo if i have web-dl.

If anyone knows how to do this, i would be extremely greatful. A member of this skin or whatever.
Current Kodi/OS: Kodi 19.1 Matrix w/ Aeon Madnox 2.0 | Windows 10 Home.

HTPC: AMD Ryzen 7 5700G (8c/16t) // ASRock B550M Steel Legend // 16GB G.Skill Ripjaws V DDR4 3866Mhz // 2 x WD Black NV750 250GB NVMe + 128TB HGST NAS/WD Ultrastar // Silverstone Grandia GD07B
TV: LG OLED CX 77" Receiver: Yamaha RX-A3070 Front: Jamo S608 Center: Jamo C60 Center Surround: Jamo C60 Surround Atmos/DTS:X: Monitor Audio Bronze AMS Subwoofer: XTZ W12.18 ICE
Reply
#13
Ok, the only solution i have found is to remove these 3 lines (in my previous post) in the "Includes_MediaFlags" file, and replace the "hevc" flag with the "Ultra-HD BluRay" (rename the BluRay flag to hevc, or else you get the HEVC flag instead) This way my 4K Bluray and 4K WEB-DL videos get the correct flag. 4K HDTV also get the correct flag.
1080p BluRay encoded in HEVC/H.265 is not affected, and show the correct "old" bluray flag.

As for now, im gonna keep it like this.
Current Kodi/OS: Kodi 19.1 Matrix w/ Aeon Madnox 2.0 | Windows 10 Home.

HTPC: AMD Ryzen 7 5700G (8c/16t) // ASRock B550M Steel Legend // 16GB G.Skill Ripjaws V DDR4 3866Mhz // 2 x WD Black NV750 250GB NVMe + 128TB HGST NAS/WD Ultrastar // Silverstone Grandia GD07B
TV: LG OLED CX 77" Receiver: Yamaha RX-A3070 Front: Jamo S608 Center: Jamo C60 Center Surround: Jamo C60 Surround Atmos/DTS:X: Monitor Audio Bronze AMS Subwoofer: XTZ W12.18 ICE
Reply



Logout Mark Read Team Forum Stats Members Help
WEB-DL 4K media flag0
This forum uses Lukasz Tkacz MyBB addons.