Can't install any addon kodi - win 10 64b
#1
Hello I can't install any addon, basically wanted to see how pvr iptv simple client works.
I keep showing the message 'add on couldn't be loaded an unknown error has occurred'.
It shows that it is installed, but if I want to turn it on, the same error Sad
https://paste.kodi.tv/ayevabavun.kodi
Reply
#2
(2021-05-29, 16:50)emxde Wrote: Hello I can't install any addon, basically wanted to see how pvr iptv simple client works.
I keep showing the message 'add on couldn't be loaded an unknown error has occurred'.
It shows that it is installed, but if I want to turn it on, the same error Sad
https://paste.kodi.tv/ayevabavun.kodi
Hello,
This one is a little strange, the log shows an 'Access Denied' (Odmowa dostępu) for the dll used in pvr.simple. (C:\Users\themo\AppData\Roaming\Kodi\addons\pvr.iptvsimple\pvr.iptvsimple.dll)
and yet it shows it loaded correctly prior to that.
Was this a new install or an upgrade or you just let the auto-update run after the install.
Also is there any reason why you are using C: and G: drives for the install?
I would do a complete uninstall, check you do not have any leftovers in the directory listed above.

Once you have done that, do a re-install of Kodi with the default settings, do not install the pvr yet and exit Kodi.
Restart Kodi and now install PVR, again exit Kodi.
Restart once again and see if you have any new outcome.
Got a Kodi problem? Provide us with a full Debug log (wiki)  | Useful pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | forum rules (wiki) | VPN policy (wiki)
Reply
#3
(2021-05-29, 18:51)OTinley Wrote:
(2021-05-29, 16:50)emxde Wrote: Hello I can't install any addon, basically wanted to see how pvr iptv simple client works.
I keep showing the message 'add on couldn't be loaded an unknown error has occurred'.
It shows that it is installed, but if I want to turn it on, the same error Sad
https://paste.kodi.tv/ayevabavun.kodi
Hello,
This one is a little strange, the log shows an 'Access Denied' (Odmowa dostępu) for the dll used in pvr.simple. (C:\Users\themo\AppData\Roaming\Kodi\addons\pvr.iptvsimple\pvr.iptvsimple.dll)
and yet it shows it loaded correctly prior to that.
Was this a new install or an upgrade or you just let the auto-update run after the install.
Also is there any reason why you are using C: and G: drives for the install?
I would do a complete uninstall, check you do not have any leftovers in the directory listed above.

Once you have done that, do a re-install of Kodi with the default settings, do not install the pvr yet and exit Kodi.
Restart Kodi and now install PVR, again exit Kodi.
Restart once again and see if you have any new outcome.
I tried on the old version, I tried on the new one. I uninstalled with revouninstaller, deleted all directories. I did as you wrote and then the same 'add-on couldn; t be loaded', clicking on TV 'no PVR add-on enabled - you need a tuner ...'.
I do not understand this Sad
Reply
#4
I don't understand either.
Are you using 19 or 19.1 and is the error in the log the same as in the previous log sent?
Got a Kodi problem? Provide us with a full Debug log (wiki)  | Useful pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | forum rules (wiki) | VPN policy (wiki)
Reply
#5
(2021-05-29, 19:41)OTinley Wrote: I don't understand either.
Are you using 19 or 19.1 and is the error in the log the same as in the previous log sent?
I used 18.9 and there was a problem, now I installed the new 19.1 and it's still the same, and here are the logs
https://paste.kodi.tv/osocoyezok.kodi
Reply
#6
(2021-05-29, 19:57)emxde Wrote:
(2021-05-29, 19:41)OTinley Wrote: I don't understand either.
Are you using 19 or 19.1 and is the error in the log the same as in the previous log sent?
I used 18.9 and there was a problem, now I installed the new 19.1 and it's still the same, and here are the logs
https://paste.kodi.tv/osocoyezok.kodi
I see this :

IAddonInstanceHandler::ADDON::IAddonInstanceHandler::CreateInstance: pvr.iptvsimple returned bad status "Permanent failure" during instance creation

I am sorry but someone more familiar with pvr.iptvsimple binary will have to step in and help you. 
I hope it's soon.
Got a Kodi problem? Provide us with a full Debug log (wiki)  | Useful pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | forum rules (wiki) | VPN policy (wiki)
Reply
#7
@phunkyfish might know what 2021-05-29 19:53:20.336 T:8900 ERROR <general>: PVR::CPVRClients::UpdateAddons: Failed to create add-on PVR IPTV Simple Client, status = 5 means. Or @howie-f.
Learning Linux the hard way !!
Reply
#8
How are you installing the addon? I believe that error occurs if you try to install a binary addon from source instead of the compiled zip.
Maintainer of Enigma2 PVR addon: repo, docschangelog
How to create a full debug: here
Reply
#9
(2021-05-29, 23:27)phunkyfish Wrote: How are you installing the addon? I believe that error occurs if you try to install a binary addon from source instead of the compiled zip.

Install from repository>PVR clients>PVR IPTV Simple Client   like that :|
Reply
#10
Try updating the repo first from the left hand menu.
Maintainer of Enigma2 PVR addon: repo, docschangelog
How to create a full debug: here
Reply
#11
(2021-05-30, 10:41)phunkyfish Wrote: Try updating the repo first from the left hand menu.

U mean 'Kodi Add-on repository'? Its 3.2.5 or idk what u mean, sorry.
Reply
#12
(2021-05-30, 13:00)emxde Wrote:
(2021-05-30, 10:41)phunkyfish Wrote: Try updating the repo first from the left hand menu.

U mean 'Kodi Add-on repository'? Its 3.2.5 or idk what u mean, sorry.
Go to the Repository and 'Check for Updates' via the Context Menu, then install.
Reply
#13
(2021-05-30, 13:10)FXB78 Wrote:
(2021-05-30, 13:00)emxde Wrote:
(2021-05-30, 10:41)phunkyfish Wrote: Try updating the repo first from the left hand menu.

U mean 'Kodi Add-on repository'? Its 3.2.5 or idk what u mean, sorry.
Go to the Repository and 'Check for Updates' via the Context Menu, then install.
Team Kodi - 3.2.5 (shield with v)  Angry
Reply
#14
You need to use the left context menu. So once you open the repo using “Install from repository” open the left pane pop out window.

Here there should be a check for updates button.
Maintainer of Enigma2 PVR addon: repo, docschangelog
How to create a full debug: here
Reply
#15
(2021-05-30, 17:26)phunkyfish Wrote: You need to use the left context menu. So once you open the repo using “Install from repository” open the left pane pop out window.

Here there should be a check for updates button.
I did, but it shows up-right 'Checking for add-on update: 0%' and disappears.
Reply



Logout Mark Read Team Forum Stats Members Help
Can't install any addon kodi - win 10 64b0
This forum uses Lukasz Tkacz MyBB addons.