Missing PVR channel icons
#1
Hi Bart!

Here comes a bug I'm having with Matrix, that I didn't have with Leia. Amber isn't able to show channel icons after a fresh Kodi start... I have to go to settings, and inside PVR options "reload" them so Amber can show them again. Any idea?

Some hints to help you:

- Nvidia Shield with last system version (9.0.1). (so Android)
- I'm testing last 19.4 Matrix, with last Amber for Matrix 3.4.32. I've also tested 3.4.11 (from official Kodi repo).
- With stock Estuary it's working OK. I've also test 3 alternativa skins, which also work OK (Eminence, Unity and another one I can't remember now).
- After Leia to Matrix and new mediaportal pvr plugin updates, I can see a message "loading channel icons" every time I start Kodi, which I didn't see with Leia. I assume something has changed in this regard, that Amber doesn't like at all.
- I was loading icons from an smb share, but I've also tested puting them in a local folder, just in case.

Hope you can take a look.

Thanks a lot.
Reply
#2
After some days of usage, I can say that... about 10% of times I launch Kodi, Amber shows pvr channel icons... 90% it doesn't. It must have to do with something that happens before or after Amber tries to load them... if they're available, then Amber shows them.
Reply
#3
@peque , I am not sure what is going in your case.  For me the channel icons show up without issue:

Image

Could you please provide a debug log of when this happens? (https://kodi.wiki/view/Log_file/Easy)  Thanks.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 11 Soundbar: Samsung HW-Q950A TV: LG CX Kodi: 19.3 Skin: Amber
Reply
#4
Oh sorry... bug report without log...

I'll do it ASAP. I'm not at home these days.
Reply
#5
Sorry for the delay!

Here you have the log of a fresh Kodi start that ends not showing PVR channel icons:

https://drive.google.com/file/d/1o00O0pI...sp=sharing

bye.
Reply
#6
@peque , please provide access to the file to "[email protected]".  Thanks.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 11 Soundbar: Samsung HW-Q950A TV: LG CX Kodi: 19.3 Skin: Amber
Reply
#7
Ohhh shhhit. Sorry. I've just changed file permissions.
Reply
#8
@peque , unfortunately, I could not find anything in the log that could give me a clue of what the issue is.

Amber just displays whatever Kodi loads as the item's icon.  It does not do any processing or anything else related to channel icons.  

Just to make sure that I understand, the channel icons do not show up in any window (channels, recordings, epg, shelves)?  Could you please post a screenshot that shows the issue? And when you do, could you, without exiting Kodi, switch to Estuary and send me a screenshot of the same window where the icons do not show in Amber? That way I can compare the code and see if Estuary is doing something differently than Amber, which could be the cause of the issue.

Thanks.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 11 Soundbar: Samsung HW-Q950A TV: LG CX Kodi: 19.3 Skin: Amber
Reply
#9
It's not that I don't want to collaborate. Smile It's that after repeating same tests I did before my easter holidays, results are different...

So I must "redo" my thoughs about this before going on.

I'll come back if I can tell you something more, but NOW... I would say it's not Amber related... ¿?

Crazy.
Reply
#10
Ok... so now I'm ready to report it again. Smile

Here you have a kodi log from a fresh start with Estuary: https://drive.google.com/file/d/1aVfQSKy...sp=sharing
Now, the exact same fresh start with Amber: https://drive.google.com/file/d/16V59Ex0...sp=sharing

Now... Can you say why in the hell PVR Manager is started, then stopped then started again with Amber, while just started (once) with Estuary? I can see the notification messages as it starts, then search for icons and load epg, then start again in Amber. With Estuary I don't see that restart. I asume this has something to do with the issue. I've tested other skins. None of them have this "start-stop-start". All of them show pvr channel icons with no problem.

More info: if I start with Estuary, then switch to Amber (no restart), I can see the pvr icons... If I start with Amber, then switch to Estuary, I can't see them.

Hope this helps a little bit more.
Reply
#11
(2022-04-24, 19:34)peque Wrote: Now... Can you say why in the hell PVR Manager is started, then stopped then started again with Amber, while just started (once) with Estuary? I can see the notification messages as it starts, then search for icons and load epg, then start again in Amber. With Estuary I don't see that restart. I asume this has something to do with the issue. I've tested other skins. None of them have this "start-stop-start". All of them show pvr channel icons with no problem.

@peque , I cannot say with certainty why this is.  Amber as a skin is not doing anything in particular with PVR or icons.  There are some differences that I can see between the startup with Estuary and the startup with Amber:

1. With Amber, skin.info.service is loaded, and not with Estuary.  I am not sure whether this has an impact, but you might try disabling it and seeing what happens.
2. With Amber, it seems that you have a PVR widget done through the Super Favorites addon.  I think this could have an impact.  You could try deleting this widget and seeing what happens.

Please test and let me know.  Thanks.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 11 Soundbar: Samsung HW-Q950A TV: LG CX Kodi: 19.3 Skin: Amber
Reply
#12
SuperFavourites was messing somehow. I've disabled it completely, and pvr icons have come back to my interface.

But it's strange to me because I don't have any PVR widget done with SuperFavourites. I've got two SuperFavourites folders used as widgets in Amber, but they have nothing to do with PVR: I use them to add shotcurts to some Android Streaming apps (Netflix, Youtube and so...) and game apps (Moonlight, Retroarch and so).

I've had to redo Streaming apps widget with standard Favourites Kodi feature, and I'll try to find some alternative, as standard Favourites doesn't let you choose favourite order, and you can't make different favourite groups, for example.

If you want to dig into this incompatibility let me know.

Thank you very much.
Reply



Logout Mark Read Team Forum Stats Members Help
Missing PVR channel icons0
This forum uses Lukasz Tkacz MyBB addons.