Video Streaming Kills my Internet

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
magma42 Offline
Junior Member
Posts: 3
Joined: Nov 2009
Reputation: 0
Post: #1
Hi. Really not sure where to start with this but its a problem that only seems to be manifesting either when I'm running XBMC or Boxee.

I open a video-streaming script (or app in Boxee) for say TED or Youtube, really it happens in all of them that I've tried, and start playing a video. Everything will be fine until at some point, the stream just stops completely, cant rewind or play from the beginning, nothing. Can't open any other stream actually, in this or any other script/app. Quitting out to Windows, well what do you know, I have no internet access whatsoever now. Firefox, IE, Opera all open to "Page not found" for any website, any torrent shuts down, can't VNC in, nothing.

This only ever happens in XBMC or Boxee when streaming video, and I can't work out what else the common thread connecting every instance of this might be, like duration or space used or whatever, since it will happen in short ones but not long ones, etc. I'm sure its some painfully obvious quick-fix that I'm just not seeing, but this is damned infuriating. Any help whatsoever is gratefully appreciated.
find quote
jhsrennie Offline
Team-XBMC Developer
Posts: 7,252
Joined: Nov 2008
Reputation: 119
Location: Chester, UK
Post: #2
I find that extended streaming causes my router (Draytek Vigor 2600) to run out of memory and crash. I have to restart it to get Internet access back. I haven't worked out exactly what is upsetting the router because I rarely need to stream anything big so it isn't an issue.

I note that mplayer causes the problem as well, though the BBC iPlayer does not.

find quote
SlavikZ Offline
Junior Member
Posts: 8
Joined: Jan 2010
Reputation: 0
Post: #3
You may try to disable QoS control in your router.
find quote
RetroWatcher Offline
Junior Member
Posts: 4
Joined: Jan 2015
Reputation: 0
Post: #4
This post is somewhat older but my answer might be useful because I ran into a similar problem.

I currently have a 20 MBit/s access. Initially, Kodi randomly aborted streaming videos from some sites and my PC became sluggish while streaming.

I was able to fix this by reducing the internet bandwidth of Kodi to 16 MBit/s (in System > Settings > Expert Mode). My explanation is that because the system now has sufficiant resources for other tasks, it is never tempted to preempt Kodi for too long a period.
find quote
iannace Offline
Junior Member
Posts: 1
Joined: Jan 2015
Reputation: 0
Post: #5
I have a related streaming issue in Kodi that did not occur in XBMC 13.2

I have multiple network security camera streams defined in a .m3u file. Each camera streams video and audio in H264 format via an RTP URL (UDP stream) over an Internet based VPN connection. Previously, under XBMC 13.2 and before, I could easily switch between camera streams, maybe viewing each stream for about ten to twenty seconds before moving on to the next camera stream to get a quick security rundown. There may have been a small buffer time between each but I could easily navigate from stream to stream without issues.

Under Kodi 14.0 if I view a single stream I have no issues, but if I switch to another stream, I am unable to view the second or subsequent stream sources unless I wait at least 45 seconds or so before attempting to connect to another stream. At the same time as I would try to access another stream I would lose connectivity with my remote site and the remote router would stop responding to pings. I thought the issue was poor Internet connectivity so I tried the same process over a period of a few days using different PC and Mac computers running Kodi but the same issue occurred on each test. I then installed WIreshark to analyze the IP connection with my streaming cameras and I found that Kodi does not release a viewed stream after stop or next is selected but it continues streaming the previous stream for quite some time. If I move from stream to stream, as I did in XBMC 13.2, I actually completely swamp my remote Internet connection as the effect is like watching multiple video streams at the same time, something my remote site does not have the bandwidth to handle. If I use XBMC 13.2 this "overload" issue does not occur. So it appears to me that there is a bug in Kodi 14.0 that does not allow a stream to be cleanly released when requested, but actually "times out" over a minute or so.
find quote