•   
  • 1
  • 24
  • 25
  • 26(current)
  • 27
  • 28
  • 29
  •   
Speed up playback watching video (include 1.1x to 1.5x ffwd rate with audio)?
@MB32 I installed and tested this feature on libreelec 8.2.5 and 8.90.007 and it worked on both.

How I tested it:
- Installed a fresh copy of Libreelec 8.2.5
- added my NFS to kodi so I had access to movies
- created a keymap with PlayerControl(tempodown) and PlayerControl(tempoup)
- Turned on sync playback to display
- Played movie and pressed the key I mapped and it worked
- Updated to 8.90.007 and tested again

If you are still having problems you should post a [[Debug Log]]
Reply
(2018-11-14, 17:45)FernetMenta Wrote:
(2018-11-11, 20:08)raven6679 Wrote: Hi, I've got a question. Does this speed up/down tempo feature (SUPER USEFUL!) work only in Windows version of Kodi?
I had Windows miniPC months ago, and I was super happy with this feature.
But now, I'm trying to use it on Odroid C2 with CoreElec 8.95.x and it seems, that tempo does not work at all.

Can anybody confirm that it works/doesn't work on LibreElec/CoreElec?
If not, what platforms it would works (beside, obviously, Windows version...).
 I developed and tested this on Linux X11/Wayland and OSX. I see no reason why it should not work other platforms too, but, as said, I did not test myself. 
Hi. A question: is there a way to set up upper limit to more than 1.5x? Let's say 2x?
Reply
(2018-11-26, 09:53)raven6679 Wrote:
(2018-11-14, 17:45)FernetMenta Wrote:
(2018-11-11, 20:08)raven6679 Wrote: Hi, I've got a question. Does this speed up/down tempo feature (SUPER USEFUL!) work only in Windows version of Kodi?
I had Windows miniPC months ago, and I was super happy with this feature.
But now, I'm trying to use it on Odroid C2 with CoreElec 8.95.x and it seems, that tempo does not work at all.

Can anybody confirm that it works/doesn't work on LibreElec/CoreElec?
If not, what platforms it would works (beside, obviously, Windows version...).
 I developed and tested this on Linux X11/Wayland and OSX. I see no reason why it should not work other platforms too, but, as said, I did not test myself.    
Hi. A question: is there a way to set up upper limit to more than 1.5x? Let's say 2x?   
maxtempo in video section of advanced settings. Be aware that your system might not be capable of going this speed.

EDIT: maxtempo must be in the range of 1.5 .. 2.1
Reply
Thank you. I will check on nVidia.

EDIT. Not a slightest problem on nVidia. 2.0 speed and not even a hickup. Works like a charm Smile
Reply
(2018-11-23, 17:33)Av3nged Wrote: @MB32 I installed and tested this feature on libreelec 8.2.5 and 8.90.007 and it worked on both.
Thanks for posting your keymap. It appears that we must use the <keyboard> tag to map this remote in LibreELEC.  (On desktop Kodi it works with the <remote> tag instead.)  I mapped the tempo control to <PageUp> and <PageDown> on the remote and it worked in LibreELEC.  However, the audio is muted if I use any playback speed other than 1.0.  On which hardware platform are you running LibreELEC ?
(2018-11-14, 17:45)FernetMenta Wrote: maxtempo in video section of advanced settings. Be aware that your system might not be capable of going this speed.
Should this be documented in the wiki?
https://kodi.wiki/view/Advancedsettings.xml
Reply
I tested on x86-64 and RPI2 I did not have a spare micro sd card so i did not test on my wetek hub. Also that is not the keymap that I used it is the basic format of what one should look like. I created mine with Add-on:Keymap_Editor (wiki) and then added in the tempoup/down into the keymap that it created for me.

FYI: all that text formatting makes it hard to read your message when not on the forum.
Reply
Is it possible to modify mintempo in advancedsettings?

and i can't get maxtempo to work either. these are my settings, the gui stops at 1.5:
Quote:<advancedsettings>
        <seeksteps>
                5, 10, 20, 30, 60, 180, 300, 600
        </seeksteps>
        <cache>
                <buffermode>1</buffermode>
                <memorysize>157286400</memorysize>
                <readfactor>5</readfactor>
        </cache>
        <video>
                <!-- is this possible -->
                <mintempo>0.5</mintempo>
                <maxtempo>2.1</maxtempo>
        </video>
</advancedsettings>
Reply
This is my advanced and it's working like a charm. Are you sure you put file in correct localization?
https://kodi.wiki/view/Advancedsettings.xml
Userdata (wiki)
Quote:<?xml version="1.0" encoding="UTF-8"?>
<!-- General Settings -->
<advancedsettings>

<playcountminimumpercent>95</playcountminimumpercent>
<nodvdrom>true</nodvdrom>

<!-- Streaming Optimization -->
<network>
    <buffermode>1</buffermode> <!-- Comment: Default is 1 -->
    <cachemembuffersize>52428800</cachemembuffersize> <!-- Comment: Default is 20971520 bytes or 20 MB -->
    <readbufferfactor>2.0</readbufferfactor> <!-- Comment: Default is 1.0 -->
</network>

<!-- Video Library Tweaks -->
<videolibrary>
    <cleanonupdate>true</cleanonupdate> <!-- Comment: Also clean library during library update -->
    <importwatchedstate>true</importwatchedstate>
    <importresumepoint>true</importresumepoint>
</videolibrary>

<video>
    <maxtempo>2.1</maxtempo>
</video>


</advancedsettings>
Reply
it's definely in the right location cause my seek steps show properly. maybe it's the skin i'm using? i'm on confluence and it doesnt go over 1.5x
Reply
Then try to set the skin back to default and try again with max tempo. I have default and it's showing 2.0 and it's really visibly (and audibly) faster than 1.5.
(2018-12-09, 21:24)BriceysCousin Wrote: it's definely in the right location cause my seek steps show properly. maybe it's the skin i'm using? i'm on confluence and it doesnt go over 1.5x
Reply
Hi all,

im trying to set this up again on a new nvidia shield box, seems not to be working properly.

I had it running fine on kodi 17, however on current setup keymaps and fast playback arent working as expected.

current setup is nvidia shield with kodi 18-rc4

the keymaps for some keys doesnt work, and for some it does. the tempo up and down just do a normal ffwd and rev and not tempo

ive managed to get audio playing at 2.0 during normal ffw, however audio is out of sync from video immediately.

Are there any known issues with the kodi version im using?

Thanks
Reply
This is one of the greatest features in recent times, excellent for binge watching or watching a movie a bit quicker when time is short. One request, though.

Usually, I would set my system to passthrough audio and deactivate "Sync playback to display". However, the latter is necessary. Consequently, I would like for this to work in reverse: Tempoup and tempodown should automatically turn "Sync playback to display" on and upon returning to normal speed "Sync playback to display" should be reset to its previous state, alternatively turned off.
Reply
I'm being told that "Sync playback to display" has adverse effects on AMLogic devices as the amcodec already handles something similar. Indeed I have noticed audio getting out of sync and being dropped, as well as buffer problems and freezing video on my s905x device. Maybe the AML wizards can cook something up?
Reply
Sync Playback to Display also disables audio passthrough.
I agree.  Switching between speed adjustments and normal play speed should be able to enable/disable 'Sync' automatically.
Reply
tempoUP/DOWN isn't the only use for "sync playback" so it would need a new setting to provide the "auto" feature you want.

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Krypton
Leia
Reply
  •   
  • 1
  • 24
  • 25
  • 26(current)
  • 27
  • 28
  • 29
  •   
 
Thread Rating:
  • 11 Vote(s) - 4.64 Average



Logout Mark Read Team Forum Stats Members Help
Speed up playback watching video (include 1.1x to 1.5x ffwd rate with audio)?4.6411