ir-keytable or: How I Learned to Stop Worrying about the LIRC Kernel

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
marcozd Offline
Senior Member
Posts: 147
Joined: Nov 2008
Reputation: 0
Post: #16
Hi all,

I am just wondering if I use this method of set-up for me remotes if I will be able to use irexec?

I would like to be able to control all of my devices from one remote and my receiver also has IR transmitters. I was thinking of using irexec to be able to change TV channels and power on etc.

Thanks in advance!Big Grin

CPU:Intel 2100 3.1 Ghz RAM:Corsair 4 GB DD3-133 Mobo: Gigabyte H67M-D2-B3 mATX OS HDD: Corsair Nova Series 32GB SSD Storage HDD: WD Green 2 TB Video Card: ASUS EN210 SILENT ODD:
find quote
colinjones Offline
Junior Member
Posts: 42
Joined: Dec 2010
Reputation: 0
Post: #17
Guys - desperate for some advice here!

Why would LIRC/irw not respond at all when ir-keytables -t works fine even with a custom mapping?? Its set up per the instructions using devinput, but as soon as I start LIRC, ir-keytables stops, and nothing further responds... stop LIRC and it comes back. Can't get XBMC to respond properly to the the remote as a result.

And I don't seem to be able to find any relevant logging to tell me what's going on...

Any pointers would be hugely appreciated!!
find quote
darkscout Offline
Posting Freak
Posts: 2,145
Joined: Jul 2008
Reputation: 12
Post: #18
What do your logs say?

[Image: aeKO.jpeg]
Code:
GRANT ALL PRIVILEGES ON `xbmc_%`.* TO 'xbmc'@'%';
IF you have a mysql problem, find one of the 4 dozen threads already open.
find quote
colinjones Offline
Junior Member
Posts: 42
Joined: Dec 2010
Reputation: 0
Post: #19
as I say, I couldn't find any specific LIRC logging, looked in dmesg and not much comes up. Can you let me know which log files I should grab and I'll pastebin them here!

Col.
find quote
illumilore Offline
Junior Member
Posts: 10
Joined: Nov 2011
Reputation: 0
Post: #20
I have an AVS Gear HA-IR01SV, and I think I have ir-keytable working correctly using rc6_mce, as all of the buttons such as KEY_RED and KEY_SLEEP come up correctly when running ir-keytable -t, however xbmc still does not recognize the keys correctly, and most of them do not work. I think the fault lies in the old keyboard.xml and remote.xml I have in the xbmc userdata folder. Where would I get the correct ones for my remote, and would it be keyboard.xml or remote.xml that would be the problem?
find quote
schumi2004 Offline
Posting Freak
Posts: 1,726
Joined: Aug 2011
Reputation: 21
Post: #21
Is it possible to have a IR Keyboard working this way?
find quote
m3t3or Offline
Junior Member
Posts: 4
Joined: Jun 2013
Reputation: 0
Post: #22
Thank's alot for this thread, it helped me to get my MCS-remote working!!

Was a long way for me .... I will tell the whole story .. maybe somebody else can profit from it:
- First I tried directly with lirc, tryd various different settings and drivers ... best I could get, when pressing a button was: "error reading /dev/lirc0" Undecided
- For some time I played a bit with "irrecord -d /dev/lirc0 -H devinput test.txt", which actually was able to give me keycodes to my keys
- I tried to figure out why always the message "can't get exclusive access to events coming from /dev/lirc0 interface" popped up when starting irw/lircd
- Because of that I found out, that there is "inputlirc" now ... basically I got the same problems with that Frown
- Than I sooner or later found this thread ... first time I was able to get some more input while using "Driver mceusb, table rc-rc6-mce, protocols: RC-5 RC-6" ... however still most keys from the remote did not react at all ... and the keys which did work, only worked when pressing them for 2sec ... often "ir-keytable -t" received only raw-signals, if any. Undecided
- I was lucky that I tried the remote on my other PC, which has exactly the same OS --> There it worked out of the box, with all keys.
- After some more testing/investigation, I figured out, that my media-pc front-USB connectors are running USB3.0 ... same for the half of my backside-usb-connectors Blush ... I re-plugged the device to one of the backside USB2.0 connectors --> Yay, finally all keys work out of the box as well for my media-pc !!

My Hardware: Hauppauge WinTV-HVR-1700, IR-Receiver: SMK Manufacturing, Inc. eHome Infrared Receiver
My Software: $uname -a: Linux media-pc 3.2.0-4-amd64 #1 SMP Debian 3.2.46-1 x86_64 GNU/Linux (Wheezy)
(This post was last modified: 2013-06-21 18:06 by m3t3or.)
find quote
mythxmbc Offline
Junior Member
Posts: 1
Joined: Nov 2013
Reputation: 0
Post: #23
Thank you for the tip on how to avoid LIRC, it's much easier than getting LIRC working every time I upgrade my hardware or software!

I found that the /dev/input/event# number was changing upon reboot, so sometimes my keytable was not getting set correctly. Sad

I solved this by finding the definitive event# for my device:

$ ls -l /dev/input/by-id
total 0
lrwxrwxrwx 1 root root 9 Nov 2 10:53 usb-05af_2.4G_USB_RF_KeyBoard-event-if02 -> ../event5
lrwxrwxrwx 1 root root 9 Nov 2 10:53 usb-05af_2.4G_USB_RF_KeyBoard-event-kbd -> ../event3
lrwxrwxrwx 1 root root 9 Nov 2 10:53 usb-05af_2.4G_USB_RF_KeyBoard-event-mouse -> ../event4
lrwxrwxrwx 1 root root 9 Nov 2 10:53 usb-05af_2.4G_USB_RF_KeyBoard-if01-event-mouse -> ../event4
lrwxrwxrwx 1 root root 9 Nov 2 10:53 usb-05af_2.4G_USB_RF_KeyBoard-if01-mouse -> ../mouse0
lrwxrwxrwx 1 root root 9 Nov 2 10:53 usb-05af_2.4G_USB_RF_KeyBoard-mouse -> ../mouse0
lrwxrwxrwx 1 root root 9 Nov 2 10:53 usb-15c2_ffdc-event-if00 -> ../event8
lrwxrwxrwx 1 root root 9 Nov 2 10:53 usb-15c2_ffdc-event-mouse -> ../event6
lrwxrwxrwx 1 root root 9 Nov 2 10:53 usb-15c2_ffdc-mouse -> ../mouse1
lrwxrwxrwx 1 root root 9 Nov 2 10:53 usb-Streamzap__Inc._Streamzap_Remote_Control-event-if00 -> ../event7

The last line is the one for my Streamzap remote receiver. When I use that in the --device field of the ir-keytable command:

ir-keytable --device=/dev/input/by-id/usb-Streamzap__Inc._Streamzap_Remote_Control-event-if00 --write=/etc/keycodes/newkeys

...it always gets the correct device (the Streamzap has shown up as event6, event7, and event8). Smile
find quote
seventhsite Offline
Junior Member
Posts: 7
Joined: Feb 2014
Reputation: 0
Location: Russia, Belgorod
Post: #24
What it may mean?
Code:
[email protected]_odroid:~# lsusb
...
Bus 001 Device 004: ID 0471:0815 Philips (or NXP) eHome Infrared Receiver
...
[email protected]_odroid:~# ir-keytable
Found /sys/class/rc/rc0/ (/dev/input/event3) with:
        Driver mceusb, table rc-rc6-mce
        Supported protocols:
        Enabled protocols:
        Repeat delay = 500 ms, repeat period = 125 ms
And cat /dev/input/event3 was return nothing. I also tried cat /dev/input/* and see the keyboard keys, but nothing from IR. Also I tried the remote control at the Windows and it works.

Ubuntu 13.10
Code:
[email protected]_odroid:~# uname -a
Linux 7th_odroid 3.8.13.18 #3 SMP PREEMPT Wed Apr 23 07:08:02 BRT 2014 armv7l armv7l armv7l GNU/Linux
find quote
jingo_man Offline
Senior Member
Posts: 139
Joined: Oct 2008
Reputation: 0
Post: #25
i used a lot of the principles here in my own setup, and all the buttons work for my setup now having made custom map files for the Harmony 650 remote I have. Inside XBMC, everything works and applying 10,000 repeat and delay settings makes it more workable.

However, I cannot get "resume from remote" to work. It suspends fine when I press the power toggle button. But nothing happens on resume.

I have a Zotac ZBox AQ01 (Kabini board) which has the built in IR receiver. Using Ubuntu, I have tried to only use the in-kernel lirc in an attempt to simplify.

I cannot find the vendor:product values (1283:0000) under the /sys/bus/usb/devices/*/idVendor files, to toggle the "enabled" flag at boot time.

I have the following devices:
Quote:sudo lsusb
Bus 002 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 8087:07dc Intel Corp.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Quote:dmesg | grep CIR
[ 3.430534] ite_cir: Auto-detected model: ITE8713 CIR transceiver
[ 3.430541] ite_cir: Using model: ITE8713 CIR transceiver
[ 3.472850] input: ITE8713 CIR transceiver as /devices/virtual/rc/rc0/input5
[ 3.473201] rc0: ITE8713 CIR transceiver as /devices/virtual/rc/rc0

Quote:sudo ir-keytable
Found /sys/class/rc/rc0/ (/dev/input/event3) with:
Driver ite-cir, table rc-rc6-mce
Supported protocols: NEC RC-5 RC-6 JVC SONY SANYO LIRC other
Enabled protocols: RC-6
Name: ITE8713 CIR transceiver
bus: 25, vendor/product: 1283:0000, version: 0x0000
Repeat delay = 10000 ms, repeat period = 10000 ms

Do I need the standalone lirc app on top to make this work? Is there something else in the config that needs applying?
find quote
Post Reply