Samba and symlinks
#1
I'm running XBMC 2:10.1 (from the PPA) on Xubuntu 10.10 and pointing it at Samba shares on my Debian 6 file server.

On the Debian box I have smb.conf with:

Code:
unix extensions = no

inside [global] as well as:

Code:
writable = no
follow symlinks = yes
wide symlinks = yes

inside the section for the file share.

The file share contains symlinks like so:

/dir/public/symlink -> /dir/private/actualfile

Where /private/ is outside of the Samba share.

Within XBMC all I get is a 0k file for "symlink". What am I missing?
Reply
#2
Do you have all of that in the global section in your smb.conf?
Have you tried:
Code:
unix extensions = no
follow symlinks = yes
wide symlinks = yes
in the [global] section?
Since you run xubuntu you could try to mount the share in xfce and see if the file manager in xfce behaves the same as xbmc.
Don't forget to restart smbd ;-)
Reply
#3
What I have in smb.conf, in [Global] is:

unix extensions = no
wide links = yes

And it is working perfectly. Running Ubuntu (Natty on one box, Lucid on other and on the smb server).
Reply
#4
From what I have read: Putting "wide links" (which is what I had wrong as "wide symlinks") in [global] is a security risk if any of your shares are writable because a symlink can be created remotely that goes to anything on your server. The safe way to use this option is only within shares that are read-only.

It works now, thanks.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Samba and symlinks00
This forum uses Lukasz Tkacz MyBB addons.