Clearart Mod and help
#1
Hi guys and gals,

I have been adapting an old clearart mod I saw on these forum to suit my needs abit more.

Basically when I pause playback on alaska revisited on my ATV2, it shows a white bar, clear art image - episode name and episode info.

The problem I am experiencing is that, some of the cleararts didnt load very well - so I replaced them with others, however no matter how many times I reboot my ATV2, it still loads the old clearart image on some files - even after they have long been deleted - does anyone know if/where the cache might be to reset it and force it to reload the file again?

Here is a screenshot of what the mod looks like when it is working as intended
Image

Any suggestions on deleting the cache?

Also, this was my first attempt at doing anything involving xml or skinning, so if anyone wants to take a look at the code and edit/fix it to make it better - feel free, it is by no means my own work, I have borrowed/stolen/adapted code from various places lol

DialogSeekbar.xml
Code:
<window id="115">
    <defaultcontrol>901</defaultcontrol>
    <visible>Window.IsActive(fullscreenvideo) + !Window.IsActive(videoosd) + !Window.IsActive(fullscreeninfo) + [Player.Seeking | Player.DisplayAfterSeek | Player.Paused | Player.Forwarding | Player.Rewinding]</visible>
    <controls>    
<control type="group">
        <animation effect="slide" end="0,0" condition="true">Conditional</animation>

            <include>Animation_SlideUpFadeOut</include>
<control type="image">
                    <posx>0</posx>
                    <posy>640</posy>
                    <width>1280</width>
                    <height>80</height>
                    <texture>dialogback.png</texture>
                    <animation effect="slide" end="0,-34" condition="IsEmpty(VideoPlayer.Year) + IsEmpty(VideoPlayer.Rating) + IsEmpty(VideoPlayer.Director) + IsEmpty(VideoPlayer.Writer)">Conditional</animation>
                </control>
<control type="largeimage">
                <posx>0</posx>
                <posy>580</posy>
                <width>250</width>
                <height>140</height>
                <texture>$INFO[Player.FolderPath]../clearart.png</texture>
                <visible>VideoPlayer.Content(episodes)</visible>
            </control>
<control type="largeimage">
                <posx>0</posx>
                <posy>580</posy>
                <width>250</width>
                <height>140</height>
                <texture>$INFO[Player.FolderPath]/clearart.png</texture>
                <visible>VideoPlayer.Content(episodes)</visible>
<aspectration>keep</aspectration>
</control>
<control type="label">
        <description>Plot Outline</description>
        <posx>250</posx>
        <posy>640</posy>
        <width>1280</width>
        <height>20</height>
        <visible>true</visible>
        <align>left</align>
        <scroll>true</scroll>
        <label>$INFO[VideoPlayer.Title]</label>
        <font>Font_EpisodeTitleNF</font>
      <textcolor>EpisodeTitle</textcolor>
        <wrapmultiline>true</wrapmultiline>
        <scrollspeed>50</scrollspeed>
        <scrollsuffix> - </scrollsuffix>
  </control>
<control type="label">
        <description>Plot Outline</description>
        <posx>250</posx>
        <posy>665</posy>
        <width>1000</width>
        <height>60</height>
        <visible>true</visible>
        <align>left</align>
        <scroll>true</scroll>
        <label>$INFO[VideoPlayer.Plot]</label>
            <font>Font_LandscapeInfo</font>
        <textcolor>LandscapeInfo</textcolor>
        <scrollspeed>50</scrollspeed>
        <scrollsuffix> - </scrollsuffix>
  </control>
<control type="label">
<posx>1120</posx>
<posy>690></posy>
<width>180</width>
<visible>true</visible>
<label>$INFO[VideoPlayer.Time] / $INFO[VideoPlayer.Duration]</label>
    <font>Font_OSDProgress</font>
                <textcolor>OSDProgress</textcolor>
</control>            
</control>
        <include condition="Skin.HasSetting(DebugGrid)">Object_DebugGrid</include>
        <include condition="Skin.HasSetting(DebugMode)">Debug</include>
    </controls>
</window>
Reply
#2
Delete your thumbs database.
Reply
#3
Hitcher Wrote:Delete your thumbs database.

Thank you Hitcher,

quick Wiki search on the thumbs db - renamed Textures6.db to oldTextures6.db,

also removed my thumbnails folder as ATV2 has limited space and I had ALOT of generated thumbs in there that I would never use again.

Works a charm now - and has rebuilt the db and thumbnails folders nicely Big Grin

Thanks again mate

Now to go back to tweak the clearart mod a little bit (havent done one for movies just yet).

Loving the skin btw - tried a fair few on my ATV, but Alaska is definately my favourite thus far - nice clean and intuitive interface - the plan is to get a 2nd ATV2 for my elderly mother, just accessing the network drive, the same way I have currently - and Alaska configured just right, in Kiosk mode, is perfect for the novice user - and at the same time has the features I want as a slightly more advanced user Big Grin
Reply
#4
would love to get this, if you mind sharing. IMO, the only thing missing from alaska/revisited is clearart
Board: Zotac ION-A-U Case: M350 Mini ITX Memory: 4GB Patriot PC6400 OS: XBMC on OpenELEC.tv build 6936 on a Corsair 32GB SSD Media Storage: W2K8 running on 14TB RAID 5 on an Asrock board w/ AMD Athlon X2 250 and PERC 6/I controller w/ 8 Samsung HD204UI Green drives Time to interface from power switch: 22.4 seconds.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Clearart Mod and help00