XBMC Music Video XML Creator - For Adding all Music Videos To Library
#46
First of all, thanks for this great app!

But I have a problem, when I check the "Get Thumbnail Using FFmpeg" box, the program sees if it is runing ok, and then I get the message that is done and that it is working properly.

But when I go back to the main windows, the "Get Thumbnail Using FFmpeg" box is... unchecked! if I try to check it again, the program test FFmpeg again, and everytime when I go back to the main windows the box is unchecked.

All other features are working fine, all nfo files are being created.

Any idea how can I solve this?
Reply
#47
Hey, I'll take a look at the code later today! which version of the app and which OS are you running?
Reply
#48
jacksonliam Wrote:Hey, I'll take a look at the code later today! which version of the app and which OS are you running?

XBMC Music Videos XML NFO Creator v13 FFMPEG
Windows 7 Ultimate

thanks!
Reply
#49
Thanks for your bug report!
I've fixed it the bug, when you check the box the application may appear to freeze but its just checking that ffmpeg works.
I tried to show a different window rather than the application just freezing - but that didn't appear to work!

Here's an updated one which should work!
v14
http://www.mediafire.com/?h5qzg9mdelq30xv
Reply
#50
Just installed V14, the get thumbnail check box is working fine!

But when I press "go" nothing happens, is this just me? The programs just stays open but does nothing.
Reply
#51
Palalisimo Wrote:Just installed V14, the get thumbnail check box is working fine!

But when I press "go" nothing happens, is this just me? The programs just stays open but does nothing.

Just did a test run myself (only 10 videos) with this newest version.
I get the nfo's but if I click on the video thumbnail box I get a popup that says...
'Done! FFMpeg is working.
FFMpeg takes 3-10 seconds per video'

But nothing happens.... no thumbnails....

BTW, Thank you, Jacksonliam.... I've been looking for something like this for awhile now with about 1000 videos!


EDIT>>>>>> Actually... I had v13 from a few days ago. Scanned the 10 videos with it and got the nfo's. Couldn't get the thumbs to work. Then saw the last couple posts above and upgraded to v14. Tried for the thumbs and got the result stated above.
Decided to delete the nfo's and start over. I get nothing at all with version 14. Now it does nothing for me... no nfos or thumbs..... :-(
Reply
#52
Are you installing or running the standalone exe? If youre installing then I think I predict the problem, ffmpeg exe is not being copied to install directory. Try the stand alone

If you're desperate you could try v12 the download link is in the first post, its the last one before I multi threaded and it works much better I think. It just appears to freeze while its working through the videos.
Reply
#53
Okay found the problem (I think)
v15
http://www.mediafire.com/?zut5fsgpiiejo0g

The problem with the other version was because of some code that visual basic decided to randomly delete.

To fix another problem I had to comment all my code and un-comment it again, This meant some code that was commented out purposely became un-commented-out. I think I got it all commented out again and I tested all the functions but If you do notice any odd things please let me know!
Reply
#54
Working now Dude! Got nfo's and thumbs (.tbn)

Thank you!
Reply
#55
Heya, I just ran my MV collection through the app and it worked great. But I can't seem to get XBMC to scrape it. The only scraper available now is the Yahoo one but it seems to crap out after about 30 vids. It doesn't seem to be able to just use the nfo files and not connect to music.yahoo which seems to be the problem.

Anyone got solution for this?
Reply
#56
Why do you need to scrape it if you have .nfos? I just put my videos in with matching .nfo and hit update library.
Reply
#57
I might be missing something but to set content of my music video folder to music video I have to select the yahoo scraper. I thought it wouldn't scrape if it had the matching nfo already but the yahoo scraper seems to do that.

I tried to break the yahoo scraper so it wouldn't interfere. Deleting the scraper removes the possiblity to set content to music video. Replacing the actual scraper with the tvdb scraper didn't help either.

So I think I'm missing something simple or I need to write a dummy scraper for it.
Reply
#58
Faldafeykir Wrote:I might be missing something but to set content of my music video folder to music video I have to select the yahoo scraper. I thought it wouldn't scrape if it had the matching nfo already but the yahoo scraper seems to do that.

I tried to break the yahoo scraper so it wouldn't interfere. Deleting the scraper removes the possiblity to set content to music video. Replacing the actual scraper with the tvdb scraper didn't help either.

So I think I'm missing something simple or I need to write a dummy scraper for it.

after you set content and scraper it should ask you if you want to ignore local data and refresh the files...IE rescrape them.
if you say no it should add the files to the library but use your current nfo/tbn/fanart.
Reply
#59
Vampirebat Wrote:after you set content and scraper it should ask you if you want to ignore local data and refresh the files...IE rescrape them.
if you say no it should add the files to the library but use your current nfo/tbn/fanart.


FWIW, it only asks me that if I reload. If I put a new music video and nfo file into my music video folder and hit update library, it adds it. I also put every video in it's own folder and put a fanart.jpg in there too. And in the nfo, I include the tag <thumb> and set the thumb myself.
Reply
#60
Cool app jacksonliam! But what if we have video clips that are different than true 'music video' (as in the video made to support a single release). Say something like

2006-11-16 - Nelly Furtado - Performance - All Good Things - World Music Awards.mpg

My choice was to bastardize XBMC fields (since it doesn't have something proper). The 'Performance' above is one of the 12 descriptions I assigned to genre. The date is used mainly for the year; if I recall right, XBMC doesn't store more than that even if the info is available; the 'event' to 'Albums', etc.

The breakdown I chose was by defining separators and pairs (separator '-'; than match whatever the filename has to XBMC fields that can be exported in a nfo file).

This worked for me and my collection of 3000 files because it was well structured to begin with (meh, I'm crazy like that...). I just though to mention this from a die hard collector's perspective, if it inspire you for new features, dealing with stuff beyond classic music videos.
Reply



Logout Mark Read Team Forum Stats Members Help
XBMC Music Video XML Creator - For Adding all Music Videos To Library0
This forum uses Lukasz Tkacz MyBB addons.