[RELEASE] WhatTheMovie addon - guess movies by snapshots
#31
(2012-03-10, 21:26)blenni Wrote: I wanted to use your plugin but I only get a white screen (see screenshot). Do you know what could be wrong (using Eden RC2)?

Hi,

yes the addon is broken because of website changes. I started a pull request to update/fix it on the xbmc.org addon repository - please wait about one day and you will be able to update to version 1.0.3.

regards,
sphere
My GitHub. My Add-ons:
Image
Reply
#32
update is now in the repo...
My GitHub. My Add-ons:
Image
Reply
#33
Version 1.0.4 is now in the repo.

Have fun.
My GitHub. My Add-ons:
Image
Reply
#34
Hi:

This seems like a dumb question, but how do I exit this addon using the IOS XBMC remote app?
I have tried to press everything, but the only way I found to exit the WhatTheMovie addon is by
pressing ESC on a regular keyboard.

If it helps, I am running raspbmc version RC3.

Thanks in advance.
Reply
#35
You should be able to exit the game with the stop-command.
My GitHub. My Add-ons:
Image
Reply
#36
Hi,
I'm running the latest version from official repo, and it sometimes locks up on me. It is loading next image, and it just keeps loading. Interface is functional (I can move around the buttons, and zoom into image), but can't quit (esc doesn't work) and if I try to close xbmc (s key -> exit) then it locks up fully and I need to kill and restart xbmc.

Thanks
Reply
#37
Hi. Thanks for reporting. I need a log file when this occours.

Regards,
sphere
My GitHub. My Add-ons:
Image
Reply
#38
http://www.xbmclogs.com/show.php?id=52782

I'm having the same problem as gizmo. It happens sometimes when I click the > button.
People have been asking me for a Donate button, so if you want to buy me a drink > here it is <
Reply
#39
From your log it looks like whatthemovie.com was unavailable for over a minute, not sure what I can do against this.
I will think about it...
My GitHub. My Add-ons:
Image
Reply
#40
It has nothing to do with timeouts, there are two HTTP exceptions that I'm seeing.

1) One problem is that my proxy is filtering urls that follow a particular pattern (i.e. if it looks like there's an ad, or malware etc.). It would seem that this happens for one of more of the whatthemovie urls, I can just reconfigure the proxy to fix that.

2) If the user turns off explicit content in their whatthemovie.com account settings then an explicit image will cause a HTTP exception in the plugin (404: Not Found).

These problems can be worked-around by the user, but really the plugin should be able to handle exceptions without hanging XBMC.

The log makes it look like a timeout is happening about once a second, but that's because your code lumps HTTP exceptions together with timeout exceptions and prints "There's a timeout", and then tries again, and fails again, and tries again and fails again etc. This process goes on forever, preventing user input in the process, effectively hanging XBMC. The reason that this only lasts a minute in the log is because that how long I waited before I killed the XBMC process.


Also please limit the number of times the code retries the same snapshot after a HTTP exception, if it fails more than once it may keep failing indefinitely.
People have been asking me for a Donate button, so if you want to buy me a drink > here it is <
Reply
#41
Hi Mossy,

1) I don't think that its related to your proxy, but if I'm wrong I guess you can fix that yourself Wink

2) You are right, they changed the way they substitute the explicit image if this is disabled in your profile. Before this change a black image with hardcoded text (blah blah explicit blah change profile) was referenced as shot image url. Now they show a transparent one with the text as real text. I didn't noticed this change. Now a black image together with a text note is shown.
I also made the timeout catching more robust by explicit checking for a timeout exception and changed the default timeout to 30 sec.

I noticed from your log that you prefer using the next button. I added an experimental method for pre-loading the next shot (together with the already preloaded random next shots), would be nice if you could test this.

You can download Version (1.0.8) here.

Changelog:
Quote:1.0.8 (unreleased)
- increate timeout to 30
- fixed potential exception while retrieving next shot
- fixed explicit and blocked shot error
- added experimental preloading of next/prev shots

See here for a full diff.

Thanks for reporting and sorry for mis-understanding your log Wink
-sphere
My GitHub. My Add-ons:
Image
Reply
#42
There is one snapshot with "/ad/" in the URL, which my proxy filtered out as an ad. Simple matter of configuration to fix that.

I originally thought, based on the log, that the timeout was set to one second, so I thought that should be higher, but as we now know there was no timeout happening. The default timeout is probably fine, but setting it to thirty seconds isn't going to do any harm either.

I'd be happy to test the new version, will let you know how I get on.
People have been asking me for a Donate button, so if you want to buy me a drink > here it is <
Reply
#43
At one point the plugin hung (on pressing the "previous" button), but I didn't have debug logging turn on. I turned on debug logging, but it didn't happen again.

Other than that it worked fine, with explicit content turn on and off.
People have been asking me for a Donate button, so if you want to buy me a drink > here it is <
Reply
#44
Reproduced using the "next" button - http://www.xbmclogs.com/show.php?id=55245

I reckon if you use the "next" button, over and over you'll eventually see this problem.
People have been asking me for a Donate button, so if you want to buy me a drink > here it is <
Reply
#45
Sadly I couldn't reproduce. Did you remember the preload-count while that happened?
My GitHub. My Add-ons:
Image
Reply



Logout Mark Read Team Forum Stats Members Help
[RELEASE] WhatTheMovie addon - guess movies by snapshots2
This forum uses Lukasz Tkacz MyBB addons.