XMBC freeze in exit
#1
Question 
Hi, I have XBMC installed on my 64bit archlinux system and everytime I want to exit it, it entirely freezes and I have to kill it from system monitor (it happens every time so now I run it in windowed mode so I wont have to restart comp every time I test something).

program isnt laggy or anything while Im at it, its just when I exit that it totally freezes, I have no idea how to proceed troubleshooting this.

A little more info:

-using nouveau drivers
-XBMC 10.1
-installed via arch package manager (pacman)

Complete log here:
http://pastebin.com/F9rMDKYf
Reply
#2
I have a similar problem. I thought it was compiz, but I'm not sure. Anyone else has an idea?

Running XBMC 11 pre. on Ubuntu 11.04
Reply
#3
Well I dont think its compiz because my arch installation is running on KDE4, so no compiz at all.
Reply
#4
Please turn on debug logging and post another log.
Reply
#5
is been doing that since todays builds after libboost i had freezes on reboot so I guess not same issue, Im on ubuntu 10.04
Reply
#6
Star 
here is the new log with debugging enabled

http://pastebin.com/SAaGkmat

thanks for the help!
Reply
#7
Hi,

having exactly the same problem.

Running xbmc 10.1 on Archlinux x86_64 from gnome3.

My Log looks quite like the one already posted. Last line says:
NOTICE: stop python

Any help would be greatly appreciated.

Kind Regards
Michael
Reply
#8
Sad 
Just installed Fedora 15, using same version xbmc. Same problem.

Didn't have this problem for F14, though, unless the version in the repositories is fairly new (just over a month?).

ken
Reply
#9
let try exit program using ALT+F4
Reply
#10
Hi there,

alt + f4 leads to the exact same effect (as does clicking on "X" in window-modes).

Kind Regards
Michael
Reply
#11
Is this a bug? Has anyone submitted it?

FWIW, this goes into a bad state: one needs to kill it (sigkill) rather than just terminate it (sigterm).


ken
Reply
#12
Hi, I am having the same issue here.

Using 64 bit, intel video, just have core Arch system with X, GDM and XBMC 10.1-3

Doesn't matter what option I select (Shutdown, Reboot, Exit, Suspend, Hibernate) XBMC just freezes. I very rarely get a crash log at all. On the 1 or 2 occassions it has actually generated, the last line is "stop python".

Besides this, XBMC is working just fine (only audio podcatcher plugin refuses to play any podcasts - lists podcast titles but will not go any further)

Seems odd, my previous install worked perfectly (both podcaster and shutdown). I don't remember which version of XBMC (assuming 10.1-2) as my old media box (8 year old pentium) finally gave up the ghost, so I built a new box just 1 week ago and started from scratch.

If I switch to a console and pkill X, I am suddenly returned to GDM and all is well again (I am able to restart/shutdown from a user console session and GDM, so it is not user permissions or a session issue).

This is rather painful, as this is set up as a media box connected to my NAS and TV, controlled by IR Remote. I really do not wish to have a keyboard attached to shutdown......grrrr.....

Anyone with any ideas, greatly appreciated.

Cheers.
Reply
#13
Very interesting that it only happens on arch.
Reply
#14
Big Grin 
bobo1on1 Wrote:Very interesting that it only happens on arch.

er not quite

X3lectric Wrote:is been doing that since todays builds after libboost i had freezes on reboot so I guess not same issue, Im on ubuntu 10.04
Reply
#15
I did a clean install of 10.1 today and it also freezes on Shutdown/Exit. I have to use Task Manager to kill the 100% CPU process of XBMC.
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
XMBC freeze in exit51