•   
  • 1
  • 109
  • 110
  • 111(current)
  • 112
  • 113
  • 162
  •   
XBMC Constellation For iPad/iPhone by FSS.cc (unofficial remote)
One small issue. Despite having my TV shows set to Poster, i'm seeing banners for some of the shows. Not sure how this happened as about a week ago it was showing posters just fine. The layout is fine, just the images are wrong.
Reply
@mdespault:
This is the first I've heard of this issue... It's odd that both devices are connecting to the same XBMC install with different results. Just curious, which model iPhone and iPad are they and which version of iOS are on each? Although it's great you found a work around for your issue, just remember that those four characters wont work properly from either device now if you need to actually use them for text input.

@Newsboy:
First, can you try to dump the image cache, force quit the app, then restart it and see if that corrects the problem on next sync? If not, please write back with more details (Host OS, XBMC Version, Constellation Version, iOS Device/Version, etc) so we can try to come up with more ideas to help.
HTPC 1: 64-bit Quad Core 3.4GHz Athlon X4 / 16GB DDR3 / (8) 2TB / 42" Vizio / Windows 8.1 (x64) / IIS 8.5
HTPC 2: 64-bit Quad Core 2.0GHz / 8GB DDR3 / 1TB / Windows 8.1 (x64) / IIS 8.5
My Personal Blog - NewsDemon | Text size doesn't seem to be working anymore for signatures?
Reply
Gave that a try only to get the same result.
Running Win 7, XBMC Version 11, Constellation v2.2.1, iPhone 4 running iOS5.1.1
Reply
I'm thinking of using this when my htpc is up and running, but can I browse my movie collection when my htpc is offline?
Reply
(2012-05-13, 11:10)Newsboy Wrote: Gave that a try only to get the same result.
Running Win 7, XBMC Version 11, Constellation v2.2.1, iPhone 4 running iOS5.1.1
Do you have other devices to test this with? Did you recently change any settings in XBMC itself? Lastly, if you try to view the shows in XBMC do the same ones show banners there as well? I can't think of any reasons it'd be doing this unless (doubtfully) it has something to do with iOS 5.1.1 (I'm still running iOS5 on all my devices)

(2012-05-13, 14:36)Tycho91 Wrote: I'm thinking of using this when my htpc is up and running, but can I browse my movie collection when my htpc is offline?
This app doesn't (currently) support an offline copy of the database, therefore your HTPC system has to be online and reachable from your iOS device at the time you want to look through your library.
HTPC 1: 64-bit Quad Core 3.4GHz Athlon X4 / 16GB DDR3 / (8) 2TB / 42" Vizio / Windows 8.1 (x64) / IIS 8.5
HTPC 2: 64-bit Quad Core 2.0GHz / 8GB DDR3 / 1TB / Windows 8.1 (x64) / IIS 8.5
My Personal Blog - NewsDemon | Text size doesn't seem to be working anymore for signatures?
Reply
Being really cheeky here, but waaaaaay back on pg 104 there's a post from FSS_Dawid re the Android version and hopefully after Q1 2012 (http://forum.xbmc.org/showthread.php?tid...#pid970581)

Was just after an update if at all possible? How you chaps getting on with it, and do you need testers? Smile
QNAP TS670 NAS - 4x4TB Raided with NFS Support & Central MySQL DB
Pi 3 [Xbian] - Samsung 46" ES7000 Smart TV & HT-E5550 3D BD Sound System
Pi 3 [Xbian]  + Hyperion Ambilight- Samsung 48" Curved UE48JS9000 4k
PowerEthernet T1502 Powerline adapters
Reply
@nsviper:
PM Dawid here on this forum with the subject line: "Android Beta" and in it, include the type of Android device you have and an email address to best reach you at. If/when added to the beta group, you'll need to create an account on the Constellation forums (link in my signature) and PM me your username there and after I verify your status I'll unlock access to the Beta area on those forums.

As far as actual status update, as I stated a few posts back, since I don't have Android devices I've sadly not really paid attention to the status, so as far as I know, it's still being worked on, but I have no idea how far it's gotten.
HTPC 1: 64-bit Quad Core 3.4GHz Athlon X4 / 16GB DDR3 / (8) 2TB / 42" Vizio / Windows 8.1 (x64) / IIS 8.5
HTPC 2: 64-bit Quad Core 2.0GHz / 8GB DDR3 / 1TB / Windows 8.1 (x64) / IIS 8.5
My Personal Blog - NewsDemon | Text size doesn't seem to be working anymore for signatures?
Reply
Sorry to ask again but I haven't seen a reply to this yet...

What's the status on getting Youtube video thumbnail/description when added to the video playlist? At the moment they just show up blank. A few pages back it was mentioned that this would be fixed in the latest update but it doesn't look like it has.

Thanks!
Reply
Hi

No major issue, only that I'm using the new ipad with constellation with ATV2 and the play button in the remote control does not change to the pause button when something is playing to indicate you can pause it.
When you touch it to pause, the playback on the TV does pause, but the pop up "playback started" comes up on the ipad.

Small bug, but needs repair methinks as it could lead to confusion.
Reply
I haven't given up on making the XBMC Commands feature in Constellation work. As a demonstration on what I want to achieve and how it fails, I want Constellation to send XBMC the command to show codec info while showing a video in Fullscreen. The XBMC action name for this is CodecInfo and it is mapped to the letter 'o' in keyboard.xml.

So, in Constellation's Command interface, I build a new command of the type 'XBMC Standard key' and select the letter 'O' (only capital letters and digits are listed). This command fails to do what I want.

From XBMC.log I can see that Constellation sends a different code than my Windows keyboard, although both are named 'o'.

For my keyboard, that works just find when hitting 'o', I have in the log:
Code:
00:46:34 T:2264   DEBUG: SDLKeyboard: scancode: 18, sym: 006f, unicode: 006f, modifier: 0
00:46:34 T:2264   DEBUG: CApplication::OnKey: o (f04f) pressed, action is CodecInfo

For Constellation, which fails, I have in the log:
Code:
00:46:44 T:2264   DEBUG: HttpApi Start command: SendKey  paras: SendKey; 0xf14f
00:46:44 T:2264   DEBUG: CApplication::OnKey: o (f14f) pressed, action is

Is this a bug in Constellation, or in Eden, or do I just have to make new entries in keyboard.xml?

Windows 7 x64, XBMC 11.0, Constellation 2.2.3 in iPad 2012

-Eriol
Reply
(2012-05-21, 01:40)Eriol Wrote: I haven't given up on making the XBMC Commands feature in Constellation work. As a demonstration on what I want to achieve and how it fails, I want Constellation to send XBMC the command to show codec info while showing a video in Fullscreen. The XBMC action name for this is CodecInfo and it is mapped to the letter 'o' in keyboard.xml.

So, in Constellation's Command interface, I build a new command of the type 'XBMC Standard key' and select the letter 'O' (only capital letters and digits are listed). This command fails to do what I want.

From XBMC.log I can see that Constellation sends a different code than my Windows keyboard, although both are named 'o'.

For my keyboard, that works just find when hitting 'o', I have in the log:
Code:
00:46:34 T:2264   DEBUG: SDLKeyboard: scancode: 18, sym: 006f, unicode: 006f, modifier: 0
00:46:34 T:2264   DEBUG: CApplication::OnKey: o (f04f) pressed, action is CodecInfo

For Constellation, which fails, I have in the log:
Code:
00:46:44 T:2264   DEBUG: HttpApi Start command: SendKey  paras: SendKey; 0xf14f
00:46:44 T:2264   DEBUG: CApplication::OnKey: o (f14f) pressed, action is

Is this a bug in Constellation, or in Eden, or do I just have to make new entries in keyboard.xml?

Windows 7 x64, XBMC 11.0, Constellation 2.2.3 in iPad 2012

-Eriol

First, sorry it's taken so long to respond... I've been a little busy with another project (more on that later)... On to the question, I'm not sure if it's a bug or limitation, but one thing to try first is to change the keyboard.xml to use something like "Ctrl+O" for example and than change it to that in Constellation to see if it works. I haven't used the keyboard commands in Constellation in awhile, but I remember the last time I tried it I had issues with sending a single character (I tried using 'h' to toggle Watched/ShowAll) but I was able to get it to work changing it to "Ctrl+character." If you already have other things that utilize using 'o' for this, you can just add a second command in keyboard.xml to do the same thing and just make that one the "Ctrl+" and see how it goes. Another quick suggestion (no idea if it works or even matters since I'm not near my network right now) is try changing the Case of the character, put 'O' instead of 'o' or vice versa. If that doesn't work, could you please PM me a copy of your xml so I can test it against my system.


Other news:
I'll be adding a new section to the Constellation forums shortly to go along with the new "HTPCPortal" site I'm writing (alongside fellow XBMC user hernandito). For more information on that site, please see the last page or so of the Maraschino thread where we discuss it.
HTPC 1: 64-bit Quad Core 3.4GHz Athlon X4 / 16GB DDR3 / (8) 2TB / 42" Vizio / Windows 8.1 (x64) / IIS 8.5
HTPC 2: 64-bit Quad Core 2.0GHz / 8GB DDR3 / 1TB / Windows 8.1 (x64) / IIS 8.5
My Personal Blog - NewsDemon | Text size doesn't seem to be working anymore for signatures?
Reply
Dear App Developer
I update on my iPhone iOS 5.1 your new Version 2.2.3, after update and new re-installation, the app crash everytime, doesn't matter what I do.
If I start an move something it crash, when I choose something it crash, if I go in settings it crash etc.
Please give me please option to install older version, send me please ipa file or give me my money back.
Sorry but this makes me not happy!
Thank you for your respond
Lejla
Reply
(2012-05-24, 01:34)Archigos Wrote: First, sorry it's taken so long to respond... I've been a little busy with another project (more on that later)... On to the question, I'm not sure if it's a bug or limitation, but one thing to try first is to change the keyboard.xml to use something like "Ctrl+O" for example and than change it to that in Constellation to see if it works. I haven't used the keyboard commands in Constellation in awhile, but I remember the last time I tried it I had issues with sending a single character (I tried using 'h' to toggle Watched/ShowAll) but I was able to get it to work changing it to "Ctrl+character." If you already have other things that utilize using 'o' for this, you can just add a second command in keyboard.xml to do the same thing and just make that one the "Ctrl+" and see how it goes. Another quick suggestion (no idea if it works or even matters since I'm not near my network right now) is try changing the Case of the character, put 'O' instead of 'o' or vice versa. If that doesn't work, could you please PM me a copy of your xml so I can test it against my system.

First, I am nothing but grateful that you strive to help so many users with such diverse problems. My thanks, good Sir! Smile

About your suggestions and comments:
  • Making a new ctrl +o command in XBMC and Constellation: no problems to do that for XBMC, but I cannot see that Constellation offers keymodifiers like ctrl and shift. The standard commands are just single letters and single digits. Am I missing something?

  • Changing the case for XBMC. I added an entry for upper case 'O' but to my knowledge XML is case insensitive, i.e. <o>CodecInfo</o> and <O>CodecInfo</O> are the same. Anyway, I tested it and it made no difference.

  • Sending my keyboard.xml: I don't think that would help. I deleted my user defined keyboard.xml and the problem persists. Hence it is generic to vanilla XBMC + Constellation.

I sure hope the developer of Constellation can make the app generate the same key as the keyboard does. Having to remap all commands is extremely onerous and heavy to maintain each time XBMC updates it's standard keybindings.

Here are a few things I consider bugs, by the way, in the newest Constellation:
- The button to create new Commands is invisible. It should be to the right of the command buttons the user so far has created.
- In the Commands management window where you make new commands there is a 'cancel' and '+' button. After you create a new command with the '+' button you have to close the windows with 'cancel' -- but you want to keep your newly created command. Luckily the creation is not cancelled, so the 'cancel' button is just mislabeled.
- Tapping the Volume knob mutes XBMC but tapping again does not unmute. You have to turn the knob all the way up to the desired volume.

Feature I miss:
- The Commands management window should offer to sort the created commands. It's no fun having the 'EXIT XBMC' button in the middle of the list and PAGEUP coming after PAGEDOWN.
Reply
You're welcome... I try helping the best I can... As I stated earlier I wasn't near my network at the time so I didn't have my iPad with me either to test any of the suggestions I gave.
  • It seems in this case I was wrong about practically everything I had said. I forgot Constellation doesn't have a way to use the key modifiers (Ctrl and/or Alt).
  • I was thinking 'backwards' about the keyboard.xml when I responded, I was thinking it was <Command>key</Command> instead of <key>Command</key> in which case the tag is case insensitive, but the value is Case Sensitive.
However, I did find a valid command to show the Codec Information. Create a new command with whatever Label you wanted and put the following in "Builtin command" XBMC.Action(CodecInfo) and you should be fine.

For the bugs listed: (I'll forward these to Dawid)
You're correct the "Create" is sadly invisible and should be fixed. (For users trying to create commands and can't find it, it's to the far right, slightly above the halfway mark of the Command Panel... I can mark it in a screenshot if required).
Agreed, the "Cancel" button should be named something like "Close" instead.
For the Volume Knob:
With the JSON API, the volume related commands are Mute, VolumeUp, VolumeDown, and Volume(%), so touching the volume knob the first time sends Mute, however to return to the previous volume there'd have to be a way to detect the exact % prior to mute.
HTPC 1: 64-bit Quad Core 3.4GHz Athlon X4 / 16GB DDR3 / (8) 2TB / 42" Vizio / Windows 8.1 (x64) / IIS 8.5
HTPC 2: 64-bit Quad Core 2.0GHz / 8GB DDR3 / 1TB / Windows 8.1 (x64) / IIS 8.5
My Personal Blog - NewsDemon | Text size doesn't seem to be working anymore for signatures?
Reply
A new Information I find out.
If in new Version 2.2.3 is playing a song, "XBMC Constellation" is crashing always, doesn't matter what you do, in few seconds it crash after starting.
If nothing is playing "XBMC Constellation" is not crashing.
I reinstall few times without success. Please can you send me the IPA File from old Version 2.1 or gave me please a other solution.
Thank you in advance for your effort.
Lejla
Reply
  •   
  • 1
  • 109
  • 110
  • 111(current)
  • 112
  • 113
  • 162
  •   



Logout Mark Read Team Forum Stats Members Help
XBMC Constellation For iPad/iPhone by FSS.cc (unofficial remote)5
This forum uses Lukasz Tkacz MyBB addons.