Odd issue
XBMC and my Apple TV 2 (running the latest on 4.3) are running fine (used Seas0npass), however I suddenly cannot SSH into it via terminal:

Quote:XXXX-Mac-Pro:~ Cory$ ssh [email protected]
ssh_exchange_identification: Connection closed by remote host

I also attempted to install todays new aTV Flash Black Beta 6 and it claims my Apple TV 2 is no longer JB'en (I know the rules on XBMC forums restrict JB'ing threads, but this seems it may not be JB related). I googled the issue and read many threads, fixes from permissions to others claiming a WORM due to not changing the root PW. I can AFP in Finder to my Apple TV 2, which is odd. I don't know why SSH via terminal and aTV Flash Black Beta claim it is no longer accessible/JB'en. I have the sense I need to change permissions on certain files and/or delete xml's/ssh/etc.

Any suggestions? Thanks guys! I appreciate all your hard work.
double check your ip address, if you can't ssh in. it's not jb'en.
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
davilla Wrote:double check your ip address, if you can't ssh in. it's not jb'en.

Double checked, it hasn't changed. I never restored it/unplugged it/turned it off, XBMC is working fine, I can access it via OS X Finder, drag and drop/create folders, etc. While using Cyberduck all of a sudden my connection dropped and Cyberduck could not get me access, neither terminal. Yet I can through Finder. Very odd.
You could try to increase the verbosity of the ssh command to see if it'll give you/us enough info to figure out the problem. For instance:

# ssh -v [email protected]


# ssh -v -v [email protected]

Pretty sure you can go up to three "-v" arguments. There's a good chance you're right re: permissions. Making sure of the following should eliminate permissions as an issue:
- your home dir, i.e. "~", should not have group write permissions, i.e. 755 should be safe
- the ~/.ssh dir should be 700 permissions
- in ~/.ssh the public key files (i.e. usually .pub extensions) should be 644
- everything else in ~/.ssh should be 600
You nailed it:

Quote:XXXXX-Mac-Pro:~ XXXX$ ssh -v -v [email protected]
OpenSSH_5.6p1, OpenSSL 0.9.8r 8 Feb 2011
debug1: Reading configuration data /etc/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file /Users/XXXX/.ssh/id_rsa type -1
debug1: identity file /Users/XXXX/.ssh/id_rsa-cert type -1
debug1: identity file /Users/XXXX/.ssh/id_dsa type -1
debug1: identity file /Users/XXXX/.ssh/id_dsa-cert type -1
ssh_exchange_identification: Connection closed by remote host

Looks like permissions somehow became schizo. Thankfully I can access it via Finder and hopefully make the necessary adjustments.

Thanks mate!
As I can't access the aTV 2 via SSH or such, and only through Finder, how do I change the permissions? Meaning, in "Sharing and Permissions" how to the codes translate to Name: Privilege"? Gonna google it now in the interim. I know there are a few programs but it seems I am limited.

Any help would be hugely appreciated. Thanks!
Someone probably knows what to set to get it to work again, but if it were me I would backup my XBMC settings (and any other settings you want to keep for your other installed programs) and restore/rejailbreak. Who knows what other permissions settings have bonked in various places that might become an issue later on. Unless someone has an idea as to why this happened in the first place.
One time the same thing happened to me, couldn't ssh in with terminal, but when I tried cyberduck it gave itself a new permission and worked and hence worked in terminal as well so if you have problems try cyberduck.
Using Seas0npass to restart the process, although I copied over the XBMC folder using Finder. I'll restore it and copy that folder. Hopefully it'll work.

Thanks guys!
Permissions on the ~/.ssh directory on your Mac could be at issue too. It'd be worth verifying them according to the permissions above.
The IKEE worm!
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Odd issue00