•   
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 48
  •   
Solved 10-bit h264 (Hi10) Support?
Hi,

just dropped by to say that I could successfully build xbmc with external ffmpeg under Archlinux.

ffmpeg-git in aur
gcc 4.6.2

All working fine after some tests.
Now I can remove the call to mplayer2 as external player Smile
Reply
Kurosama Wrote:Hi,

just dropped by to say that I could successfully build xbmc with external ffmpeg under Archlinux.

ffmpeg-git in aur
gcc 4.6.2

All working fine after some tests.
Now I can remove the call to mplayer2 as external player Smile


Ended up doing the exact same thing on Debian. Had to disable vdapu entirely because xbmc claimed ffmpeg didn't support it. Was an epic pain in the ass all around. >.>
Reply
@Kurosama, @hikaricore: Btw, I'm wordering if you encountered problems with seeking in Hi10P files on your builds with newer external ffmpeg? When I was working on my Windows build i got crash after every seek because it process different part of code (YUV420PLE -> YUV420P transformation) and crash on memory deallocation. And because neither of you mentioned any problem I wonder if it's Windows/My build only.
Reply
I've actually only tested with the Steins;Gate OP/ED Commie encoded awhile back thus far.
I plan to get into a new series this weekend, so I'll watch for anything weird at that point.
Reply
@bambi73: seeking works fine on my build.

@hikaricore: I haven't disabled vdpau in the configure step, I've only disabled it in the playback menu, and switched to Software in the render method.
Reply
Kurosama Wrote:@bambi73: seeking works fine on my build.
Strange, can you please tell me what is value do you see in m_pCodecContext->pix_fmt at line 453 at CDVDVideoCodecFFmpeg? And do you have something in m_pConvertFrame when it goes through CDVDVideoCodecFFmpeg::Reset()?

Kurosama Wrote:@hikaricore: I haven't disabled vdpau in the configure step, I've only disabled it in the playback menu, and switched to Software in the render method.
Looks like DXVA is better in this regard. I have DXVA setting on and it plays regular h264 files with it and only switch (i guess as fallback) to software ffmpeg for Hi10P Smile
Reply
Thumbs Up 
bambi73 Wrote:For these interested and crazy enough to test it Wink I compiled (for Windows) lastest XBMC head with FFmpeg n0.7.6 tag (iirc 1 month old -> contains Hi10P support).

http://www.megaupload.com/?d=9P0EDUAH

Just wanted to say thanks! I am downloading it to test. I run linux and win7 XBMC in my home so it is great to see a windows solution at least!

I noticed a few mentioned linux solutions with the external ffmpeg. Any chance of someone pointing me to a dummys guide or something for that? I normally use OpenELEC but if i need to change to something else i will consider it as i find linux better than windows for a plan media pc only type pc.
Reply
bambi73 your build is working great! Any chance of maintaining a page or something with the latest builds so we can update and see updates whenever you fix a bug if there are any? Maybe they could then add a link on the wiki or something for now until support gets added to XBMC in 2+ months?

For a matter of interest how hard was the modifications you made? There were others that seemed to easily make the change in linux and now you have made the change in windows but the devs are saying the changes are huge and will take 3+ months which i can understand but then you and others are posing working versions in such a short time.

Anyway great job and thanks for the hard work you have done on this
Reply
bambi73 only had one issue so far and that is the thumbnails for the 10-bit video have green lines through them. That said i really don't care about the thumbnails anyway but just thought i should mention it.

Anyone tested on an AMD Fusion yet? Planning to give it a go to see if it has enough grunt over the next few days for 10-bit video.
Reply
It seems that it has another issue : If deinterlacing is set to OFF, 10bits decoding is not working (post #180).
Reply
seer_tenedos Wrote:bambi73 your build is working great! Any chance of maintaining a page or something with the latest builds so we can update and see updates whenever you fix a bug if there are any? Maybe they could then add a link on the wiki or something for now until support gets added to XBMC in 2+ months?
I plan to make thread in XBMC Development subforum, so I'll have control over first post and can post builds there. I'm now working on Matroska Ordered chapters/editions support, so I wanted to make that thread when I have something to publish. But maybe I'll do it now for new ffmpeg builds.

seer_tenedos Wrote:For a matter of interest how hard was the modifications you made? There were others that seemed to easily make the change in linux and now you have made the change in windows but the devs are saying the changes are huge and will take 3+ months which i can understand but then you and others are posing working versions in such a short time.
I used ffmpeg tag n.0.7.6 which should have compatible API with one in XBMC, so there was no so much work on it. What caused most problems for me was versioning of this tag, which is complete mess so i removed most of conditional code on interface. Of course this is not option for XBMC developers, so they will spent much more time on it that me. Additional work is reapplying of 50+ patches to ffmpeg which I skipped because it's hard for me to decide if patch is still needed and in some cases to find original place where patch it Smile. I still plan to apply some selected patches to some next build, but for that I need time Smile

seer_tenedos Wrote:bambi73 only had one issue so far and that is the thumbnails for the 10-bit video have green lines through them. That said i really don't care about the thumbnails anyway but just thought i should mention it.
jpsdr Wrote:It seems that it has another issue : If deinterlacing is set to OFF, 10bits decoding is not working (post #180).
I already corrected this, will make new build when I have some time
Reply
bambi73 Wrote:I'm now working on Matroska Ordered chapters/editions support, so I wanted to make that thread when I have something to publish.
Do you plan to support what i've asked in ticket #12166 ?
Reply
jpsdr Wrote:Do you plan to support what i've asked in ticket #12166 ?
Yes, it's main reason why I'm doing it. Linking segments from different files is what most peoples understand under the term "Ordered chapters".
Reply
Ok, thanks. I didn't know in fact how this feature was named. Now, in the future i'll know what Ordered chapters mean. I'm very interested by the realease you're trying to make : update ffmpeg for 10bits and MT + Ordered chapters !! Whoh, my dream will come true !!
Reply
An updated XBMC Core player with better support, more features, and perhaps better quality would indeed be rather interesting Big Grin
If it worked it'd probably be enough to get me to come back from MediaPortal, which right now is the only way to get all my files working properly without having to deal with the bugs in DSPlayer, or faffing around with external players.
i3-2100 /w Scythe Big Shuriken Cooler, 4GB RAM, GT430 Passive, 40GB SSD boot drive, 2TB 5400RPM internal media drive, 2TB external drive, Nexus 430W PSU, Nexus case fans

Feeding Yamaha RX-V1800, Panasonic 42PZ80 Plasma, Mission 753/Quad speaker surround kit
Reply
  •   
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 48
  •   



Logout Mark Read Team Forum Stats Members Help
10-bit h264 (Hi10) Support?7
This forum uses Lukasz Tkacz MyBB addons.