Bricked my ATV2
Yesterday I decided to try out the weather app so I can see my local weather from frontrow. It installed fine. I configured it to show my local weather fine. XBMC started fine. Everything was fine until I tried to exit from XBMC. That's when the shit hit the fan. I pressed and held the menu button to exit XBMC. The screen flashed and then nothing. ATV2 blinks for ~20 seconds, the TV flashes, then the ATV2 reboots. No apple logo on the screen, nothing.

I removed the power cord. Plugged the power back in and still no joy. Blink, screen flash, reboot. Did this a couple of times, but still no joy.

My next step is I'll just restore it. Re-jail break it and I'll be on my merry way. Grabbed my micro USB cable, plugged it into my laptop and nothing. In the past, iTunes would automatically launch but not this time. I manually launched iTunes, thinking someone changed the auto launch setting in iTunes. Launched iTunes and nothing. iTunes does not see the ATV2. Tried another micro USB cable. Nothing. Tried another computer, nothing. Tried putting into DFU mode. Nothing. Downloaded tinyumbrella thinking I could get in that way. Nothing. All I get is white light blinking, a screen flash, then reboot.

This thing is truly bricked. Aside from what I've done above, anyone got any other suggestions?
Have you tried this?
Check out my stationery blog-
which XBMC were you running?

on the apple remote, try holding the menu and play button simultaneously for 30 seconds until the apple tv flashes
EDIT: Nevermind, you already did my suggestion
You can't brick an ATV2 via jailbreak or XBMC. It is simply not possible.
I agree, but I a 2 pound brick now.
I had a similar problem where my PC couldn't consistently see my ATV2 to perform a restore. I resolved the issue by connecting it to a 32-bit Windows box (rather than my 64-bit boxes) and doing the restore there. I've just never had good luck with iTunes and their drivers on Windows x64. Try the following:
  • Make sure the power cord is *not* in the ATV2 while it is connected to the PC
  • Wait a minute or so for the ATV2 light to come on and the PC to see it
  • If the PC shows any new additions in Device Manager while the ATV2 is connected but iTunes still doesn't see it, try uninstalling it in Device Manager the reconnecting the AVT2
  • Try using iTunes on a 32-bit Windows box
  • Try using iTunes from a Mac (maybe at the Mac Store)
That's for the suggestions. The ATV2 reset actually got the Apple logo to show once, but then it'd just reboot.

I'm going to try to get this replaced under warranty. I called Apple and told them, "I don't know what happened. Came home and the light was blinking." I have to send it in because where I live there's no Apple store. Hey, got nothing to lose.
Just got a confirmation email from Apple that my "new" ATV2 was shipped out to me yesterday.

Thanks Apple!

In all likely hood, it was a hardware failure not caused or related to XBMC. I wonder what version of FW is on it? If it's the 4.3, then I'm SOL until a fix comes out.
The saga has come to an happy ending... Received a new ATV2. Immediately JB'd with seasonpass. No problems installing NitoTV and XBMC.

I'm not going to install the weather app just in case Smile
I am glad to you got it working
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Bricked my ATV200