•   
  • 1
  • 111
  • 112
  • 113(current)
  • 114
  • 115
  •   
DSPlayer (DirectShow Player for XBMC) Eden build available
Well i have a new issue now, this time i started up XBMC, i had this Audio Mute symbol on the top right, which persists during Video playback also. Though the sound plays during Videos, the GUI sounds have completely stopped playing altogether. I tried changing the default audio devices in the System settings and DSPlayer settings, but i cannot make it go away. Have tried multiple restarts as well. Any idea on what could be wrong ?

Image

PS - Do the theme settings/customizations (custom menu options in Aeon NOX specifically) carry over if i upgrade to the Official Frodo based DSPlayer build once it is posted here later ? I lost these settings when i jumped from the default XBMC to DSPlayer.
Reply
For your information we need DSInputStreamPVRManager.h for compilation ;-)
Reply
(2013-01-31, 00:15)technick Wrote: For your information we need DSInputStreamPVRManager.h for compilation ;-)

Could you be more specific? I'm not a C++ programming guru, but just a guy who has a set up building environment on Windows and knows which scripts to run.Smile

Should be fixed now.

2 PhOeN!X

It seems that you accidentally pressed XBMC's "mute" button - F8 or a special key on a multimedia keyboard/remote.
Reply
(2013-01-31, 10:44)Roman_V_M Wrote:
(2013-01-31, 00:15)technick Wrote: For your information we need DSInputStreamPVRManager.h for compilation ;-)

Could you be more specific? I'm not a C++ programming guru, but just a guy who has a set up building environment on Windows and knows which scripts to run.Smile

2 PhOeN!X

It seems that you accidentally pressed XBMC's "mute" button - F8 or a special key on a multimedia keyboard/remote.

Well , i tried that, but the Mute button wasn't the issue. While playing the video, i went into the Audio & Subtitles settings settings, and saw that the Voume was set at -60dB. Wierely the sounds on the Videos were playing just fine. I turned that up to 0.0dB (Max setting), and it that symbol went away and the menu sounds worked fine again. I can swear i ddi not touch the volume settings before, so don't know how it changed that setting by itself.

Reply
Roman, Can you ask Edward K if he can make support for DVD ifo in avsplitter please?
Reply
So ETA on final frodo will be from panni tomorrow, if not the Edward K can pull something fasterSmile

@Roman: I saw a guide many pages ago in which order to install the build with regards to AV splitter etc. I presume that this is the same for all DS builds posted here also from panni?

EDIT: This is the guide I was referring to:
http://forum.xbmc.org/showthread.php?tid...9&page=145
Reply
Ok what i want to do is this:
Make DSPlayer my main player for all files (bluray, bdmv, mkv, ....)
And make use of the stock xbmcplayer (dvdplayer) for all internet streams (youtube addon and stuff) and for dvd ifo files (dvds)

I just make a playercorefactory.xml for this right?
Will it work if i use it like this? :



<playercorefactory>
<rules action="prepend">
<rule protocols="daap|rtv|rtsp|rtmp|http|https|rtmpe|rtsp|mms" player="DVDPlayer"/>
<!-- DVD -->
<rule player="DVDPlayer" filetypes="dvd|ifo"/>
</rules>
</playercorefactory>
(2013-01-31, 11:53)Bjur Wrote: So ETA on final frodo will be from panni tomorrow, if not the Edward K can pull something fasterSmile

@Roman: I saw a guide many pages ago in which order to install the build with regards to AV splitter etc. I presume that this is the same for all DS builds posted here also from panni?

yup

But i hope to see a clear "how to install" topic about DSplayer for frodo... with stable release

But for now..

1) download latest dsplayer build
2) download latest lav filters and avfilter
3) Install lav filters (for audio and video, make sure to set it up once installed)
4) installed avfilter
5) install dsplayer
6) go into video options, tick dsplayer and tick "use merits"

then everything is set up
Reply
Hi guys,
actually I'm using the latest DSPlayer/Eden build.
Due to personal preferrences I would like to stay with this version for the moment.
The only thing, not working like a charm is the cooperarion with the Yatse-App.

Now I have seen a bugfix for DSPlayer, solving exactly this issue.
Is there any way to get this bugfix into a DSPlayer/Eden-build?

I guess there are a lot of people out there, appreciating the chance of a stable use of this version.

Thank you for the great work and best regards!
Reply
(2013-01-31, 11:47)Skank Wrote: Roman, Can you ask Edward K if he can make support for DVD ifo in avsplitter please?

I can ask him. I don't know if he agrees, but asking won't hurt.Smile

(2013-01-31, 11:55)Skank Wrote: Ok what i want to do is this:
Make DSPlayer my main player for all files (bluray, bdmv, mkv, ....)
And make use of the stock xbmcplayer (dvdplayer) for all internet streams (youtube addon and stuff) and for dvd ifo files (dvds)

I just make a playercorefactory.xml for this right?
Will it work if i use it like this? :

Seems to be OK, though I've never seen files with .dvd extension.

(2013-01-31, 14:57)guenzelsen Wrote: Hi guys,
actually I'm using the latest DSPlayer/Eden build.
Due to personal preferrences I would like to stay with this version for the moment.
The only thing, not working like a charm is the cooperarion with the Yatse-App.

Now I have seen a bugfix for DSPlayer, solving exactly this issue.
Is there any way to get this bugfix into a DSPlayer/Eden-build?

I guess there are a lot of people out there, appreciating the chance of a stable use of this version.

Thank you for the great work and best regards!

You can download a diff patch from here, then apply to Eden code and pray for the build to compile without issues.Smile


2 All.
Currently I cannot compile a binary build due to unknown issues. Hopefully, with the help from Eduard K I will be able to solve them, and to create the installer.
Reply
(2013-01-31, 15:24)Roman_V_M Wrote: [quote='Skank' pid='1318071' dateline='1359625657']
Roman, Can you ask Edward K if he can make support for DVD ifo in avsplitter please?

I can ask him. I don't know if he agrees, but asking won't hurt.Smile

(2013-01-31, 11:55)Skank Wrote: Ok what i want to do is this:
Make DSPlayer my main player for all files (bluray, bdmv, mkv, ....)
And make use of the stock xbmcplayer (dvdplayer) for all internet streams (youtube addon and stuff) and for dvd ifo files (dvds)

I just make a playercorefactory.xml for this right?
Will it work if i use it like this? :

Seems to be OK, though I've never seen files with .dvd extension.

(2013-01-31, 14:57)guenzelsen Wrote: 2 All.
Currently I cannot compile a binary build due to unknown issues. Hopefully, with the help from Eduard K I will be able to solve them, and to create the installer.


Cool thx mate, let me know what he says...
maybe playercorefactory should look like this


<playercorefactory>
<rules action="prepend">
<rule protocols="daap|rtv|rtsp|rtmp|http|https|rtmpe|rtsp|mms" player="DVDPlayer"/>
<!-- DVD -->
<rule player="DVDPlayer" filetypes="ifo"/>
</rules>
</playercorefactory>
Reply
(2013-01-31, 15:24)Roman_V_M Wrote:
(2013-01-31, 14:57)guenzelsen Wrote: Hi guys,
actually I'm using the latest DSPlayer/Eden build.
Due to personal preferrences I would like to stay with this version for the moment.
The only thing, not working like a charm is the cooperarion with the Yatse-App.

Now I have seen a bugfix for DSPlayer, solving exactly this issue.
Is there any way to get this bugfix into a DSPlayer/Eden-build?

I guess there are a lot of people out there, appreciating the chance of a stable use of this version.

Thank you for the great work and best regards!

You can download a diff patch from here, then apply to Eden code and pray for the build to compile without issues.Smile

Hi Roman,
thanx for your prompt reply!

Honestly I have not the slightest clue how to do compiling/stuff like this.

May I kindly ask, if anybody is willing to go for this challenge?
I even don't know how much work has to be invested in this topic.

Best regards!
Reply
Hey guys, any idea why installing the latest DSP build for Frodo doesn't allow me to play any video?
Reply
(2013-02-01, 10:00)dsync89 Wrote: Hey guys, any idea why installing the latest DSP build for Frodo doesn't allow me to play any video?

Have you tried configuring DSplayer properly? The wiki article is still valid.
Currently DSplayer does not include any "out of the box" filters, so either enable "Use system filters..." or set up your own filter configuration as described in the wiki article.

PS. The issues with build compilation have been fixed, so hopefully the build based on Frodo final will be released soon.
The issues with switching over XBMC sound output from AE to DSplayer and back should have been fixed. Also now DSplayer can play http streams.
mediasconfig.xml now supports protocols= property for filter rules.
However, the bigger issue with network steams is that there no comprehensive source DirectShow filter that would handle all kinds of network streams, like AVsplitter or LAVsplitter does this for various kinds of file types. System default "File Source (URL)" can only handle http-streams.
Reply
(2013-02-01, 13:21)Roman_V_M Wrote:
(2013-02-01, 10:00)dsync89 Wrote: Hey guys, any idea why installing the latest DSP build for Frodo doesn't allow me to play any video?

Have you tried configuring DSplayer properly? The wiki article is still valid.
Currently DSplayer does not include any "out of the box" filters, so either enable "Use system filters..." or set up your own filter configuration as described in the wiki article.

PS. The issues with build compilation have been fixed, so hopefully the build based on Frodo final will be released soon.
The issues with switching over XBMC sound output from AE to DSplayer and back should have been fixed. Also now DSplayer can play http streams.
mediasconfig.xml now supports protocols= property for filter rules.
However, the bigger issue with network steams is that there no comprehensive source DirectShow filter that would handle all kinds of network streams, like AVsplitter or LAVsplitter does this for various kinds of file types. System default "File Source (URL)" can only handle http-streams.

Chinese for me Smile
So will it be able to play movies from the youtube addon? And trailers addon?

Thx
Did you have the time to ask about dvd ifo?
Reply
Well those are nice news, Roman
thx
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
  •   
  • 1
  • 111
  • 112
  • 113(current)
  • 114
  • 115
  •   



Logout Mark Read Team Forum Stats Members Help
DSPlayer (DirectShow Player for XBMC) Eden build available13
This forum uses Lukasz Tkacz MyBB addons.