XBMC Tvheadend Recording problem
#1
Hey guys,

Im using XBMC PVR Pre-11 (i think), and can pick up all the channels fine, change channels, see up coming recordings, everything works good, except trying to setup recording from the frontend as it comes up with errors "PVR Backend error. Check the log for details..."

Now on my backend, running 11.04 Ubuntu, with Tvheadend 2.12, i am able to record just fine, albeit i cant actually see the picture or sound (Which is another issue in itself?), and play it back and watch it fine.

Im not sure if it comes back to me not being able to see/hear anything on the backend, but i do get the following errors from time to time in Tvheadend;
Quote:MPEG2VIDEO @ #512: Continuity counter error
MPEG2AUDIO @ #650: Continuity counter error
Transport error indicator

I have posted about this error on the Tvheadend forums, but this error might have something to do with the frontend not recording also.

Here is my pastebin of the debug log in XBMC hopefully it can shed some light on the error of not being able to record, hopefully its something simple and im just an idiot :p

Thanks for the help, and if you need anymore logs or info, let me know. Thanks!!
Reply
#2
please report this problem on trac or github too, cause it'll get lost here
opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
Reply
#3
I had the same problem (Error adding timer: 'Event does not exist') but it gone after I've reseted my pvr database.
Reply
#4
Thanks EKASs for the tip, but unfortuantly that didnt help Sad

Also, dushmaniac, are you able to point me to where you would like me to post this on github or trac?
Reply
#5
MrBump Wrote:Hey guys,

Im using XBMC PVR Pre-11 (i think), and can pick up all the channels fine, change channels, see up coming recordings, everything works good, except trying to setup recording from the frontend as it comes up with errors "PVR Backend error. Check the log for details..."

Now on my backend, running 11.04 Ubuntu, with Tvheadend 2.12, i am able to record just fine, albeit i cant actually see the picture or sound (Which is another issue in itself?), and play it back and watch it fine.

Im not sure if it comes back to me not being able to see/hear anything on the backend, but i do get the following errors from time to time in Tvheadend;


I have posted about this error on the Tvheadend forums, but this error might have something to do with the frontend not recording also.

Here is my pastebin of the debug log in XBMC hopefully it can shed some light on the error of not being able to record, hopefully its something simple and im just an idiot :p

Thanks for the help, and if you need anymore logs or info, let me know. Thanks!!


It sounds familiar to me. When using TV Headend as just watch the TV Headend is not always picking the hardware acceleration to show the video. So actually ffmpeg is jumping in. If you record something and watch the recorded file the acceleration jump in and it is possible that the hardware decoding can not show the recording. So try to disable the acceleration and see if it works.

BTW:
About recording i can also not set the recording from gui but directly through web interface i can set recordings.
This is my log: http://pastebin.com/fJsM0nKU
Reply
#6
I had same that you for recording from windows. But i update Tvheadend https://github.com/andoma/tvheadend (HTS Tvheadend git-940b107). The problem come from the server and now i can record from xbmc interface.

I hope that help u
Reply
#7
I have tried to compile the tvheadend.

I have downloaded latest source (andoma-tvheadend-940b107) from https://github.com/andoma/tvheadend
untar it and tried to compile it.
Quote:sudo apt-get install libssl-dev

./configure --disable-avahi
make

and it will not compile because it says
Quote:support/version.sh: 13: git: not found
cat: build.Linux/ver: No such file or directory
Version changed
support/version.sh: 13: git: not found
CC build.Linux/src/main.o
support/version.sh: 13: git: not found
CC build.Linux/src/utils.o
support/version.sh: 13: git: not found
and so on

Are there on net anywhere already compiled versions of TVHeadend?
Reply
#8
If you don't want to install git, you can overwrite the version manually in Makefile :
Code:
VERSION=$(shell support/version.sh) -> VERSION=UNKNOWN
It should work.
Reply
#9
EkASs Wrote:If you don't want to install git, you can overwrite the version manually in Makefile :
Code:
VERSION=$(shell support/version.sh) -> VERSION=UNKNOWN
It should work.

It does not:

Quote:[email protected]:/tmp/andoma-tvheadend-940b107# make
support/version.sh: 13: git: not found
cat: build.Linux/ver: No such file or directory
Version changed
support/version.sh: 13: git: not found
CC build.Linux/src/main.o
cc: cannot specify -o with -c or -S with multiple files
make: *** [build.Linux/src/main.o] Error 1
[email protected]:/tmp/andoma-tvheadend-940b107#
Reply
#10
It's weird, make still launch support/version.sh, are you sure you have changed the line in Makefile ?
Reply
#11
EkASs Wrote:It's weird, make still launch support/version.sh, are you sure you have changed the line in Makefile ?


Hi yes i did.
But then i have find already premade packages from lars-opdenkamp
https://launchpad.net/~lars-opdenkamp/+a...hive-extra

And took file (latest is from 31.7)
Quote:tvheadend_2.12.99~git20110731.9d775d~odk1~karmic_i386.deb
and it works on Ubuntu 8.04 LTS and appletv.

Now the recordings are working ok Smile even from XBMC.

TNX for help.
Reply
#12
cool Wink
Reply



Logout Mark Read Team Forum Stats Members Help
XBMC Tvheadend Recording problem0
This forum uses Lukasz Tkacz MyBB addons.