Thread Rating:
  • 0 Vote(s) - 0 Average
GUI freeze when backend returns poor signal
#1
Hi guys,

does anyone else get this in the latest version.


08:51:59 T:10020672 DEBUG: Alloc resources: 0.31ms (0.01 ms skin load)
08:51:59 T:10020672 DEBUG: CGUIInfoManager::SetCurrentMovie(pvr://channels/tv/All TV channels/154.pvr)
08:51:59 T:10020672 DEBUG: CAnnouncementManager - Announcement: OnPlay from xbmc
08:51:59 T:10020672 DEBUG: GOT ANNOUNCEMENT, type: 1, from xbmc, message OnPlay
08:52:00 T:3066030960 ERROR: PVRClient - SignalQuality - addon 'HTS Tvheadend:192.168.0.200:9982' returns bad error (-3) from SignalQuality()

then the GUI is frozen until I restart it.

Cheers,
Neil
--
Frontend : OpenELEC PVR runnig on Acer Revo 3700
Backend : Ubuntu 11.10 running with TVHeadend 1 x DVB-T, 1 x Dual DVB-S2
Reply
#2
i have same problem but im using VDR , when i recieve msg signal lost and then signal restored and sometimes GUI is freezing.... its 50/50% to happen this and i dont know why it is happening .

for more info i will tell you my system :
e-350 APU from AMD last driver 11.12 with vaapi 0.8 xbmc-pvr latest linux is Kubuntu i will put here last log of xbmc and last log of vdr.

XBMC:
http://pastebin.com/bp3ha9Sd

VDR:
http://pastebin.com/yfsDjSKY

i can submit furder log if any of you developers interested , im not using debug now i will wait any response here ... cya Smile
Reply
#3
Do you see the cpu load go to a maximum if that happens? I might have seen this issue. It's nasty because the debugger does not allow to break in this situation.
Reply
#4
The same in my case.
Reply
#5
giaur Wrote:The same in my case.

yep, the same problem ... [XBMC PVR latest build + TVHeadEnd ...]
Ubuntu 14.04 LTS 64Bit Server, Xfce, KODI Isengard, Skin Arctic Zephyr, tvheadend tv backend
ASUS P8H61-M LE/USB3, Celeron G530, Geforce 210, 4 GB DDR3 RAM , 1 TB Samsung 2,5" HDD
iHOS104 BluRay Drive, WinTV-HVR-1200 & TT DVBS2-1600
Silverstone GD05B Case, Sony PS3 BD Remote control, Logitech Cordless Mediaboard Pro for PS3
Reply
#6
i will check my CPU is it going to 100% when it crash again , im sorry for the delay i was not able to go online 2 days Smile

and 1 more thing is there anything i can do to restart XBMC or whole PC with the remote ?
Im lazy to go to other room where is my PC and reboot it with Putty ssh connection becouse i dont have keyboard and mouse Smile
Reply
#7
cpu is not on 100% when GUI freezes , im now testing new VDR 1.7.23
this gui freeze is happening when LIVE TV cant decode a channel and it says signal lost , then signal restored ... and if this happens 2-3 times GUI freeze and i must restart.
Reply
#8
Sometimes this is enough to stop tv playback and start it again and there is no more freezes. But, sometimes xbmc freezes totally and pkill X on other terminal is only way get control again.
Reply
#9
yeah but the worst part is if i restart KDM and when xbmc load again and i switch on some channel or when i play a movie there is no picture anymore ( i think video driver fu*ks up and i must restart the whole pc...

is there a way to restart X with CTRL ALT and BACKSPACE ? on Kubuntu ? why they removed the shortcut...
Reply
#10
Quote:is there a way to restart X with CTRL ALT and BACKSPACE ? on Kubuntu ?
Go to keyboard layout options and enable this.
Reply
#11
i enable the shortcut but its not working if xbmc is standalone mode Smile
i start it from KDM directly not inside the KDE ...
Reply
#12
with Beta 2 freezing increased rapidly when switching channels, even if signal is stable, or if using (video related) functions like fast forward. In most cases I have to open a seperate terminal login and kill XBMC manually ... or my wife has to reset the maschine Wink
Ubuntu 14.04 LTS 64Bit Server, Xfce, KODI Isengard, Skin Arctic Zephyr, tvheadend tv backend
ASUS P8H61-M LE/USB3, Celeron G530, Geforce 210, 4 GB DDR3 RAM , 1 TB Samsung 2,5" HDD
iHOS104 BluRay Drive, WinTV-HVR-1200 & TT DVBS2-1600
Silverstone GD05B Case, Sony PS3 BD Remote control, Logitech Cordless Mediaboard Pro for PS3
Reply
#13
We are changing the lib for tcp connection which might be the source of this problem. The task is not fully completed yet.
Reply
#14
FernetMenta Wrote:We are changing the lib for tcp connection which might be the source of this problem. The task is not fully completed yet.

after upgrading from BETA 2 to BETA 3 freezing clearly decreased .. seems you have got the knack ! Good work !

Thanks

LastCoder
Ubuntu 14.04 LTS 64Bit Server, Xfce, KODI Isengard, Skin Arctic Zephyr, tvheadend tv backend
ASUS P8H61-M LE/USB3, Celeron G530, Geforce 210, 4 GB DDR3 RAM , 1 TB Samsung 2,5" HDD
iHOS104 BluRay Drive, WinTV-HVR-1200 & TT DVBS2-1600
Silverstone GD05B Case, Sony PS3 BD Remote control, Logitech Cordless Mediaboard Pro for PS3
Reply
#15
Hi,
I still have this crashes when using pulse-eight ppa when I lose the DVB signal.
Do you know if this release integrate the changes that you're speaking about ?
If not, is there a way to upgrade my configurationtion ?
Cheers
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
GUI freeze when backend returns poor signal00