Thread Closed
  •  Previous
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 17
  • Next 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
[Release] Artwork Organizer Script
Not sure if i understand this script..
I installed and set destination directory to c:\fanart

Now its doing nothing lol
I thought it would copy all art to that directory

It copies all art right?
But what does it do with the original one? delete it?
Or?
Else whats the point in just copying?
Will New downloaded art (say with artwork downloader) autodownload then to that directory?
I found a way to start the script Smile
Thx to an earlier post here in this topic
It started copying over all the art
I can see all art organized in c:\fanart

But i dont get the point why i should do this?
Since when i download it with artwork downloader, all art is within the movie folder...
why do i still need this one then?
I wanna see the point here....
Thx !
(2012-09-21, 11:33)Skank Wrote: Not sure if i understand this script..
I installed and set destination directory to c:\fanart

Now its doing nothing lol
I thought it would copy all art to that directory

It copies all art right?
But what does it do with the original one? delete it?
Or?
Else whats the point in just copying?
Will New downloaded art (say with artwork downloader) autodownload then to that directory?

(2012-09-21, 15:47)Skank Wrote: I found a way to start the script Smile
Thx to an earlier post here in this topic
It started copying over all the art
I can see all art organized in c:\fanart

But i dont get the point why i should do this?
Since when i download it with artwork downloader, all art is within the movie folder...
why do i still need this one then?
I wanna see the point here....
Thx !

running random addons without having the slightest clue what is does is bad practice imo.

that being said, see the first post... it's only useful if you're running a skin that uses the directories created by this addon to create a slideshow.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
(2012-09-21, 18:51)ronie Wrote:
(2012-09-21, 11:33)Skank Wrote: Not sure if i understand this script..
I installed and set destination directory to c:\fanart

Now its doing nothing lol
I thought it would copy all art to that directory

It copies all art right?
But what does it do with the original one? delete it?
Or?
Else whats the point in just copying?
Will New downloaded art (say with artwork downloader) autodownload then to that directory?

(2012-09-21, 15:47)Skank Wrote: I found a way to start the script Smile
Thx to an earlier post here in this topic
It started copying over all the art
I can see all art organized in c:\fanart

But i dont get the point why i should do this?
Since when i download it with artwork downloader, all art is within the movie folder...
why do i still need this one then?
I wanna see the point here....
Thx !

running random addons without having the slightest clue what is does is bad practice imo.

that being said, see the first post... it's only useful if you're running a skin that uses the directories created by this addon to create a slideshow.

Im using aeon mq4, no idea if its useful then...
Aha so its only to see slideshows of art for movie, series and music?
(2012-09-21, 18:54)Skank Wrote: Aha so its only to see slideshows of art for movie, series and music?

yup :-)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
A ok now i get it...
And theres no link with artwork downloader? Cause all that artwork is in another place within for ex the movie folders..?
Or can it be set up to copy that artwork too?
(2012-09-21, 19:23)Skank Wrote: A ok now i get it...
And theres no link with artwork downloader? Cause all that artwork is in another place within for ex the movie folders..?
Or can it be set up to copy that artwork too?

no
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Ok thx!
Started to noticing a few issues following database cleanups, I'm getting black backgrounds show up in the slideshow more often.

Running stable Eden and using Transparency, Artwork Organizer script itself runs fine.

Used to see the occasional black background, but thought nothing of it. Recently removed some older content, then ran database cleanup and finally the Artwork Organizer script again, but I'm definitely seeing black backgrounds more often in amongst the regular fanart backgrounds.

I'm guessing the slideshow is cycling through fanart that have been removed by the cleanup, but hoped rerunning the Artwork Organizer would sort that?
Unless I'm missing something obvious?

Any pointers appreciated!
(2012-09-26, 21:58)Fra-HTPC Wrote: Started to noticing a few issues following database cleanups, I'm getting black backgrounds show up in the slideshow more often.

Running stable Eden and using Transparency, Artwork Organizer script itself runs fine.

Used to see the occasional black background, but thought nothing of it. Recently removed some older content, then ran database cleanup and finally the Artwork Organizer script again, but I'm definitely seeing black backgrounds more often in amongst the regular fanart backgrounds.

I'm guessing the slideshow is cycling through fanart that have been removed by the cleanup, but hoped rerunning the Artwork Organizer would sort that?
Unless I'm missing something obvious?

Any pointers appreciated!

As far as I know the script only copies (and renames) fanart from the artwork folder, it doesn't delete the fanart that resides there.

LibreElec on an Intel NUC (DC3217IYE). Onkyo NR-717. Canton Movie CD-1000. LG 55B6V.

If it ain't broke: break it, fix it, repeat
Ah right, thought I'd read in here somewhere that every run of the script empties the target folders and copies everything to to them again.

I'll try deleting the copied folders and run the script so it populates them again
(2012-09-27, 08:38)Fra-HTPC Wrote: Ah right, thought I'd read in here somewhere that every run of the script empties the target folders and copies everything to to them again.

I'll try deleting the copied folders and run the script so it populates them again

Yes, it does do that. But the original artwork isn't affected. You set your skin to display fanart from the folder the artwork organizer script creates, this folder isn't updated untill you re-run it again. So fanart from new movies won't show unless you run the script again.
This cannot be the cause of your black screens. Basically, it only creates a set of folders full of jpg (or dds) files. Simple and effective.
LibreElec on an Intel NUC (DC3217IYE). Onkyo NR-717. Canton Movie CD-1000. LG 55B6V.

If it ain't broke: break it, fix it, repeat
Understood. I'll go over my settings again this evening to see if I'm missing anything obvious
Think I figured part of it out, the script doesn't seem to empty the target folder when it is run.
It certainly over writes existing files and adds anything new, but doesn't (always?) remove .tbn files for movies not in the library anymore.

Looking at the library and target folder side by side, I still had .tbn files for movies removed from the library, even after running clean database and the script again.

Manually deleted all .tbn files in the target folder, re ran the Artwork Organiser script, noted that the total count of files dropped by about 30, so it must have been leaving some behind?


Doubtin myself now, just spotted fanart for a movie that isn't in the library anymore and there is no .tbn in the target folder for it, confused now
(2012-09-30, 15:55)Fra-HTPC Wrote: Think I figured part of it out, the script doesn't seem to empty the target folder when it is run.
It certainly over writes existing files and adds anything new, but doesn't (always?) remove .tbn files for movies not in the library anymore.

Looking at the library and target folder side by side, I still had .tbn files for movies removed from the library, even after running clean database and the script again.

Manually deleted all .tbn files in the target folder, re ran the Artwork Organiser script, noted that the total count of files dropped by about 30, so it must have been leaving some behind?


Doubtin myself now, just spotted fanart for a movie that isn't in the library anymore and there is no .tbn in the target folder for it, confused now

It should delete the folders before creating and filling it again. At least that's the behaviour I've experienced. My pyhon knowledge is next to nil, but looking at the script, I think it at least tries to delete the folders:

Code:
def _delete_directories( self ):
        if xbmcvfs.exists( self.directory ):
            try:
                shutil.rmtree( self.directory )
            except:
                pass
LibreElec on an Intel NUC (DC3217IYE). Onkyo NR-717. Canton Movie CD-1000. LG 55B6V.

If it ain't broke: break it, fix it, repeat
  •  Previous
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 17
  • Next 
  Thread Closed



[Release] Artwork Organizer Script00