•  Previous
  • 1
  • 45
  • 46
  • 47(current)
  • 48
  • 49
  • 148
  • Next 
 
Thread Rating:
  • 8 Vote(s) - 4.75 Average
New MythTV add-on using libcmyth
(2012-04-26, 08:57)chrisgibbs Wrote:
(2012-04-26, 00:44)tsp42 Wrote: Fixed. I also found the reason why LiveTV wasn't working on Linux. Turned out that the mutex used on Linux in libcmyth is not reentrant so liveTV seeking caused the thread to deadlock. The mutex on windows is reentrant so no deadlock occurred.

Great work. I can confirm this has also resolved my issue.

Thanks for the commit.

Yep, live TV working again. Thank you!

I have, however, found that switching channels (without pressing stop in between) now seems to sometimes freeze XBMC for a couple of minutes, and then return to a non-playing state. I tried this both using "Up"/"Down" arrows within full screen, and selecting a channel directly in the TV channel view. This is on the same mythbackend system that didn't have such issues last week. Is anybody else seeing this?

Reply
(2012-04-26, 17:06)fiveisalive Wrote:
(2012-04-26, 08:57)chrisgibbs Wrote:
(2012-04-26, 00:44)tsp42 Wrote: Fixed. I also found the reason why LiveTV wasn't working on Linux. Turned out that the mutex used on Linux in libcmyth is not reentrant so liveTV seeking caused the thread to deadlock. The mutex on windows is reentrant so no deadlock occurred.

Great work. I can confirm this has also resolved my issue.

Thanks for the commit.

Yep, live TV working again. Thank you!

I have, however, found that switching channels (without pressing stop in between) now seems to sometimes freeze XBMC for a couple of minutes, and then return to a non-playing state. I tried this both using "Up"/"Down" arrows within full screen, and selecting a channel directly in the TV channel view. This is on the same mythbackend system that didn't have such issues last week. Is anybody else seeing this?

Live tv working for me too thanks! but I have the same problem with changing channel as above, xbmc crashes. Pressing stop and changing from epg is okay. I also see the same behaviour with the time shift buttons reported earlier , ie being in the wrong order when being selected.
Reply
okay got it to compile but now it crashes every little thing i do like listen to music / try watch a video here is the log maybe some one can tell me what is wrong with it.
xbmc.log
Reply
(2012-04-26, 23:16)darkwizard Wrote: okay got it to compile but now it crashes every little thing i do like listen to music / try watch a video here is the log maybe some one can tell me what is wrong with it.
xbmc.log

seems like you have the same problem as these guys:

http://forum.xbmc.org/showthread.php?tid=127306

one guy claims to have cured it by deleting (or copying it to a new filename) his ~/.asoundrc file and rebooting. Can't hurt to try...
Reply
Does this work for xbmcbuntu 11? EDEN?
Reply
(2012-04-27, 16:47)kburkart Wrote: Does this work for xbmcbuntu 11? EDEN?

Well technically this is post-Eden (or pre-Frodo whichever way you want to look at it....). If you have the dependencies installed on *nix or windows then it should compile for you.

When you clone the git repo, there are instruction in the readme files for the various platforms about the dependencies needed. On top of normal dependencies you need the libboost filesystem and regex libraries (1.46 is verified to work). On xbmcbuntu, you just follow the README.ubuntu instructions in your cloned repo to get all the dependencies and then compile as per the rest of the instructions. If you intend to compile a lot, I recommend installing ccache - it'll make future compiles a lot quicker.....

jim
Reply
(2012-04-27, 16:59)Jimmer Wrote:
(2012-04-27, 16:47)kburkart Wrote: Does this work for xbmcbuntu 11? EDEN?

Well technically this is post-Eden (or pre-Frodo whichever way you want to look at it....). If you have the dependencies installed on *nix or windows then it should compile for you.

When you clone the git repo, there are instruction in the readme files for the various platforms about the dependencies needed. On top of normal dependencies you need the libboost filesystem and regex libraries (1.46 is verified to work). On xbmcbuntu, you just follow the README.ubuntu instructions in your cloned repo to get all the dependencies and then compile as per the rest of the instructions. If you intend to compile a lot, I recommend installing ccache - it'll make future compiles a lot quicker.....

jim

Thx
Reply
Has anyone got this working as a diskless headend? If so could you explain how to set it up. Thx
Reply
(2012-04-26, 20:48)bilbonvidia Wrote:
(2012-04-26, 17:06)fiveisalive Wrote:
(2012-04-26, 08:57)chrisgibbs Wrote: Great work. I can confirm this has also resolved my issue.

Thanks for the commit.

Yep, live TV working again. Thank you!

I have, however, found that switching channels (without pressing stop in between) now seems to sometimes freeze XBMC for a couple of minutes, and then return to a non-playing state. I tried this both using "Up"/"Down" arrows within full screen, and selecting a channel directly in the TV channel view. This is on the same mythbackend system that didn't have such issues last week. Is anybody else seeing this?

Live tv working for me too thanks! but I have the same problem with changing channel as above, xbmc crashes. Pressing stop and changing from epg is okay. I also see the same behaviour with the time shift buttons reported earlier , ie being in the wrong order when being selected.
Could you and fiveisalive pastebin a debug log from when it happends. The addtion of the forward/reverse buttons tothe skin was a bit rushed. That's why the order is wrong. Will have to fix it.
Libcmyth MythTV addon for xbmc-pvr [source] [forum thread]
Reply
http://pastebin.com/VszJXeSB

Changing from channel one to channel two using the remote. The log looks similar to me as the original error with live tv not working at all.

Thanks again
Reply
(2012-04-29, 21:45)tsp42 Wrote:
(2012-04-26, 20:48)bilbonvidia Wrote:
(2012-04-26, 17:06)fiveisalive Wrote: Yep, live TV working again. Thank you!

I have, however, found that switching channels (without pressing stop in between) now seems to sometimes freeze XBMC for a couple of minutes, and then return to a non-playing state. I tried this both using "Up"/"Down" arrows within full screen, and selecting a channel directly in the TV channel view. This is on the same mythbackend system that didn't have such issues last week. Is anybody else seeing this?

Live tv working for me too thanks! but I have the same problem with changing channel as above, xbmc crashes. Pressing stop and changing from epg is okay. I also see the same behaviour with the time shift buttons reported earlier , ie being in the wrong order when being selected.
Could you and fiveisalive pastebin a debug log from when it happends. The addtion of the forward/reverse buttons tothe skin was a bit rushed. That's why the order is wrong. Will have to fix it.


I can also confirm that this error is happening to me too. Do you have enough to work with the existing debug logs or would you like more?
Reply
I just upgraded to 0.25, so I'm now waiting for support for that..
Reply
(2012-05-01, 09:45)chrisgibbs Wrote:
(2012-04-29, 21:45)tsp42 Wrote:
(2012-04-26, 20:48)bilbonvidia Wrote: Live tv working for me too thanks! but I have the same problem with changing channel as above, xbmc crashes. Pressing stop and changing from epg is okay. I also see the same behaviour with the time shift buttons reported earlier , ie being in the wrong order when being selected.
Could you and fiveisalive pastebin a debug log from when it happends. The addtion of the forward/reverse buttons tothe skin was a bit rushed. That's why the order is wrong. Will have to fix it.
I can also confirm that this error is happening to me too. Do you have enough to work with the existing debug logs or would you like more?
It's enough with bilbonvidia's log thanks. Just need time to find the error now.
Libcmyth MythTV addon for xbmc-pvr [source] [forum thread]
Reply
testing the pvr build on my laptop and noticed that the show title's are getting cropped at one character. my mythfrontend shows them fine, mythbox addon does too. my myth server is running .24+fixes. i'm a longtime mythtv user and just recently decided to move to XBMC for my frontend. from what i've seen so far, the pvr function is looking great. certainly prettier than mythbox; keep up the good work

Image

Reply
Was just wondering if it is possible to just compile the cmyth addon and add it to my current PVR install? I have the compiled version of XBMC from pulse-eight. Any pointers appreciated if it is at all possible....

Cheers
Bruce
Reply
  •  Previous
  • 1
  • 45
  • 46
  • 47(current)
  • 48
  • 49
  • 148
  • Next 



New MythTV add-on using libcmyth4.758