Can't get one to one pixel mapping with ATI APU?
#1
Sad 
So, tonight I assembled my ATI A4-3600, loaded windows, loaded drivers and hooked it up to my 65" Panasonic Plasma TV.

And... I have a problem (and this is exactly why I hesitated on going the HTPC route in the first place).

In Windows, if I go into the ATI Fusion control panel, I can set overscan to 0 and it looks like it is CLOSE to 1:1 pixel mapping, but there is still a very slight border around windows. This might or might not be normal (probably is normal).

My TV supports 1 to 1 pixel mapping and is set to mode JUST (which is 1 to 1) and HDMI mode 2 (which is 1 to 1). These settings all give me perfect full 1080P screen with my Boxee Box, Blu-ray player and TiVo.

However, when I fire up XBMC, and I play back a movie, I am getting the movie playing windowed on the screen. What am I missing to get this working properly? It's rather frustrating as I have spent hours changing settings in the ATI control panel, re-checking my TV settings, etc. I can go in and calibrate XBMC to "zoom" in the playback, but this should not be necessary on a brand new 2011 model 1080P Plasma set. It should be displaying properly as full screen (at least for 1080P content).

Any advice would be much appreciated, before I pitch this thing out the window.
Reply
#2
Is xbmc changing your framerate or resolution during video playback?

Unfortunately, all ATI gpu's (or apu for that matter) are by default set to overscan. When you change that setting, it only changes for the specific res+framerate combo, but all others are still set to overscan. For instance your desktop in windows is 1080p 60Hz and you set overscan to 0. Everything's fine until you start playback in xbmc and it changes it to 1080p 24Hz and you get overscan.

You have two options:

1) Disable changing framerate within xbmc and let it play everything at 60fps and make sure overscan is disabled for 1080p 60Hz,

or

2) In windows, keep changing the refresh rate and resolution while setting overscan to 0 in catalyst for each combo.

It's annoying that catalyst has overscan set by default. It is even more annoying that you can't set overscan to 0 for every framerate/res combo at once.
Reply
#3
Thanks very much. You are right, it is really annoying and I would not have purchased an ATI solution if I knew this ahead of time. Are there any other settings that I need to adjust? Strangely I lost the "match display to source" option somewhere along the way with the tweaking I am doing. I think that even with overscan of zero I am getting a small black border, I will have to test out some more to know for sure.

Thanks again for your help.
Reply
#4
this is weird because, those new releases are meant for media playback in my opinion,,,
there's gotta be something to tweak somewhere,,
think u can ask Tech Support in the mean time?
Reply
#5
i found this online while searching

Quote:It turns out the Catalyst Control Centre is the answer.

In CCC there should be an option for DTV and under that an option for UnderScan/OverScan. Drag this to 0% and you should get what you're looking for.

(Note: Underscanning effectively tries to fit the whole image in less pixels, creating fuzziness and blurring. Not only will this make the image fit the whole screen, there is a Significant improvement in quality. Bonus!)

Image
Reply
#6
also this
Quote:There is a CCC (Catalyst Control Center) option that fix the trouble (essentially 1080p50 (50 Hz) must be changed in 1080p60 (60 Hz)).

In the CCC version 2011. 0126... it is:

Digital Flat Panel -> HDTV Support -> "HDTV modes supported by this display" frame/section -> change selection from 1080p50 in 1080p60 -> click on "Apply" -> Enjoy!
Reply
#7
and this who knows

Quote:HERE'S THE SOLUTION TO THE ATI BLACK BARS PROBLEM

It took months for me to find this on the web,
so I thought I would share it here,
the first hit for 'ATI Black Bars windows 7' on Google.

1) Open Catalyst Control Center

2) Use the drop down box at the top to click on Desktops and Displays

3) At the very bottom where your monitors are displayed, click on the little black arrow and click "Configure". Note that if configure does not appear, you are clicking on the wrong black triangle (you must use the one in the very bottom section).

4) This will bring up properties for that display. Choose "Full Screen" or "Maintain aspect ratio", whatever your preference. If you are getting black bars on all sides, you are likely on "Centered".

5) IF THE OPTIONS ARE GREYED OUT, as they were when I first tried this, the workaround is to lower your display resolution before attempting the above. Once you have changed the setting, you can return your display resolution back to whatever you like and the setting will remain as your display changes (movies, games, etc)
Reply
#8
Hi Eskro, aptalca hit it on the head. The problem is that the ATI drivers automatically have overscan for each video mode... which means that if you want your videos to play back in their native resolutions and frame-rates (which I think a lot of people with a high end TV or video processor would want to do) then you have to go into the CCC and switch it to EACH video resolution and then set the overscan.

I did it for about five resolutions and it seems to have cleared up some of the issues. However, I have a bunch of vides that I have converted to 720P with Handbrake using the ATV2 pre-set. These are still showing up windowed and I cannot figure out why.

//edit

The reason might be that these videos are 720P/29.970 FPS and apparently the ATI CCC does not have an HDTV "mode" that it knows about for 720P/30, only 720P/60.

If someone knows of a way to get the overscan corrected for 720P/30 then I will probably be okay... right now those movies are still letterboxed.

I'm starting to think that perhaps I would have been better off with an i3 and an Nvidia GPU... sheesh!

Here's the info on one of the episodes in question;

Code:
* * * Media Inspector 0.7.443 file analysis report.
* * * Media Inspector is 2011 by Diego Massanti - http://mediainfo.massanti.com
* * * MediaInfoLib by Jerome Martinez - http://mediainfo.sourceforge.net
Created on: Oct 7, 2011 12:27:47 AM MDT
Report for file: True Blood S03E01.mkv

General / Container Stream #1
    Total Video Streams for this File.................1
    Total Audio Streams for this File.................1
    Total Subtitle Streams for this File..............1
    Video Codecs Used.................................AVC
    Audio Codecs Used.................................AC3
    SubTitle Codecs Used..............................S_HDMV/PGS
    Available Sutbitle Languages......................English
    File Format.......................................Matroska
    Play Time.........................................51mn 33s
    Total File Size...................................1.34 GiB
    Total Stream BitRate..............................3 718 Kbps
    Encoded with......................................mkvmerge v4.2.0 ('No Talking') built on Jul 28 2010 18:38:23
    Encoding Library..................................libebml v1.0.0 + libmatroska v1.0.0
Video Stream #1
    Codec (Human Name)................................AVC
    Codec (FourCC)....................................V_MPEG4/ISO/AVC
    Codec [email protected]
    Frame Width.......................................1 280 pixels
    Frame Height......................................720 pixels
    Frame Rate........................................29.970 fps
    Total Frames......................................92702
    Display Aspect Ratio..............................16:9
    Scan Type.........................................Progressive
    Color Space.......................................YUV
    Codec Settings (Summary)..........................CABAC / 4 Ref Frames
    QF (like Gordian Knot)............................0.109
    Codec Settings (CABAC)............................Yes
    Codec Settings (Reference Frames).................4
    Video Stream Length...............................51mn 33s 160ms
    Video Stream BitRate..............................3 004 Kbps
    Bit Depth.........................................8 bits
    Video Stream Size.................................1.08 GiB (81%)
    Video Encoder.....................................x264 - core 112
    Video Encoder (Settings)..........................cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=300 / keyint_min=29 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=20.0 / qcomp=0.60 / qpmin=3 / qpmax=51 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
    Video Stream Language.............................English
    Color Primaries...................................BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
    Transfer Characteristics..........................BT.709-5, BT.1361
    Matrix Coefficients...............................BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177
Audio Stream #1
    Codec.............................................AC-3
    Codec (FourCC)....................................A_AC3
    Audio Stream Length...............................51mn 33s 152ms
    Audio Stream BitRate..............................640 Kbps
    Audio Stream BitRate Mode.........................CBR
    Number of Audio Channels..........................6
    Audio Channel's Positions.........................Front: L C R, Side: L R, LFE
    Sampling Rate.....................................48.0 KHz
    Bit Depth.........................................16 bits
    Audio Stream Size.................................236 MiB (17%)
Subtitle Stream #1
    Language..........................................English
    Format............................................PGS
    Codec ID..........................................S_HDMV/PGS
    Codec Info........................................The same subtitle format used on BDs/HD-DVDs
Menu / Chapters Stream #1
Reply
#9
but hold on here,,,
i know what your saying but,
cant you set CCC to "Maintain aspect ratio"
and see how it handles your different files?

Quote:HERE'S THE SOLUTION TO THE ATI BLACK BARS PROBLEM

It took months for me to find this on the web,
so I thought I would share it here,
the first hit for 'ATI Black Bars windows 7' on Google.

1) Open Catalyst Control Center

2) Use the drop down box at the top to click on Desktops and Displays

3) At the very bottom where your monitors are displayed, click on the little black arrow and click "Configure". Note that if configure does not appear, you are clicking on the wrong black triangle (you must use the one in the very bottom section).

4) This will bring up properties for that display. Choose "Full Screen" or "Maintain aspect ratio", whatever your preference. If you are getting black bars on all sides, you are likely on "Centered".

5) IF THE OPTIONS ARE GREYED OUT, as they were when I first tried this, the workaround is to lower your display resolution before attempting the above. Once you have changed the setting, you can return your display resolution back to whatever you like and the setting will remain as your display changes (movies, games, etc)
Reply
#10
Actually the setting you are referring to is not in that place in the new CCC drivers. However, I had checked that and it was grayed out and set to "full screen". I think that the CCC drivers detect that you are hooked up to a TV and enforce this.

In any event, the setting in question was located in XBMC itself, there is a video playback option (only visible during video playback) that chooses how XBMC deals with formats like 720, and by default it was in a windowed mood. When I set it to "normal" it went full screen.

However, I have another problem, which is that when playing back videos that are anything other than the original refresh and resolution, when the refresh/resolution switches, the video becomes completely corrupted. Since "match refresh rate to source" is a requirement of mine, I will have to see if there is a solution to this, or I will have to get rid of it.

Honestly, I'm not very impressed with these ATI drivers in any event. Overscan on all resolutions on by default, heavy video processing on by default... it's just not geared to a home theater enthusiast so I can not recommend it at this time. It should not be this much work just to get basic things going like they ought to.
Reply
#11
your right voip-ninja, %100, im sorry you did not enjoy your purchase
and hope that you'll get everything sorted so you can start
enjoying your HTPC!

ATI should know that those APU's could attract HTPC users
and they should have made efforts in 'making stuff' that works without issues,,,
Reply
#12
I am probably more picky than most. Performance is not bad (I will make a video). It is a little less snappy than I would like, and AMD chipset has some problems with HDMI resume from standby if the rest of the HDMI devices are not up already.

Also, AMD does fine with presenting HD material at correct color space and luminance, but it will crush dark levels on SD material from what I can tell.

This would make a totally satisfactory solution for many people.
Reply



Logout Mark Read Team Forum Stats Members Help
Can't get one to one pixel mapping with ATI APU?0
This forum uses Lukasz Tkacz MyBB addons.