Forced subtitles
#1
Do forced subtitles work for MKV's? At the moment I either have no subtitles at all or have to enable them for the entire duration and I cannot see a setting anywhere.
Reply
#2
bilbonvidia Wrote:Do forced subtitles work for MKV's? At the moment I either have no subtitles at all or have to enable them for the entire duration and I cannot see a setting anywhere.
Yes.

No need for a setting, if the mkv has the subtitles track marked as 'forced' they will be shown in preference to other subtitle tracks.

If you only use 'forced' subtitles - disable subtitles from the Audio OSD while playing a movie and then choose the setting 'set as default for all movies', forced subs will then be loaded, provided the 'forced' flag had been set in the mkv mux.
Reply
#3
Does anyone know if Eden will eventually honor forced subtitles in bd structure, like it is implemeted with mkv, where they show even when subs are turend off? I played a main movie bd iso of x-men first class but don't get forced subs to display.
Reply
#4
I also do no get forced subtitles on any MKV movies Sad I highly doubt all the movies I have tried don't have the forced flags set properly.
Reply
#5
Eden still does not show m2ts forced subtitles properly. Neither does VLC for that matter....
Reply
#6
to further add to this comment, I tried a nice little test.

I used "The Hunt for Red October" Blu-Ray, region 1, US. It has forced subtitles for the russian language parts.

It also has 2 other subtitle tracks -

1. subtitles for the entire movie script, english and russian
2. subtitles for the entire movie script, english and russian INCLUDING hard of hearing additional content.


First trial -
I ripped straight from the bluray using dvdfab bluray COPY (not ripper) and copied only the mainmovie including the truehd audio and the 2 english subtitle tracks. This creates an m2ts structure like the bluray disc.
This is how i have done all my blurays so far, works great - except it will not show forced subtitles. If i choose either of the 2 subtitle tracks listed under dvdfab i get the listed effects above - all the speech in the movie is shown in subtitle, not just the russian parts which is the desired outcome.

So it is safe to assume that either DVDFab does not correctly copy the forced subtitle track, or XBMC does not pick up the forced subtitle track flags properly.

That being said, I took the bluray folder that was just copied to my hard drive containing the said m2ts and used that as my source in DVDFab to rip that into an mkv selecting the option under bluray RIPPER "display only forced subpicture"

Playing this new mkv in xbmc will show the desired "forced subtitles" as long as i select enable subtitles in the audio window of xbmc.

So, the mkv has the ability to show the desired russian only forced subtitles.....provided that I select enable subtitles for this particular file. It is supposed to show these subtitles regardless of the selection under the audio panel in xbmc as far as I know, but at least i get them - ILL TAKE IT!!!

This further proves another thing - the file that was originally copied from the bluray into the m2ts format has the proper forced subtitles inside, or else the mkv file (made from the m2ts) wouldnt show them.

This means that DVDFab either creates the m2ts bluray file in an incorrect way (not sure how exactly, but wrong enough that xbmc isnt catching it)
OR
xbmc just doesnt support forced subtitles yet in the m2ts bluray format.

I'm leaning towards the second option, that xbmc is having trouble with that format because its obvious the subtitle track is still in there, or else the mkv wouldnt have been able to display it.

I feel ive eliminated many of the variables that have come to mind from other posts elsewhere in the forum describing this problem with other discs like avatar, etc... and i feel its the m2ts file format and xbmc not getting along quite well enough. The flags work in the mkv file, but its a different subtitle system altogether.

Does any of the XBMC Gurus have an opinion on this subject? It may be beneficial to have a wiki on which file is best supported by xbmc so that people who are newer to this awesome software wont hit these stumbling blocks and know how to rip properly the first time. Could be time saving for all sides of the equation!
Reply
#7
mliegey Wrote:Playing this new mkv in xbmc will show the desired "forced subtitles" as long as i select enable subtitles in the audio window of xbmc.

If you had to enable subtitles in XBMC then its not working because movies in an mkv with forced subtitles with the "forced flag" get enabled automatically what your describing is having forced subtitles set as the default track

If the forced subtitle track doesn't have the forced flag then they don't get enabled automatically
Current HTPC Lian-Li PC-C37 • Gigabyte GA-E7AUM-DS2H • Intel C2D E8400 E0 Stepping • OCZ Vertex SSD • 4GB Corsair TwinX XMS2 DDR2 • Corsair HX650W Modular PSU (Free Upgrade) • LG CH08LS10 Blu-Ray Drive • Scythe Big Shuriken • Acousti DustPROOF 70mm Fan
Reply
#8
>>X<< Wrote:If you had to enable subtitles in XBMC then its not working because movies in an mkv with forced subtitles with the "forced flag" get enabled automatically what your describing is having forced subtitles set as the default track

If the forced subtitle track doesn't have the forced flag then they don't get enabled automatically

Yeah, i thought so - thats why I just wound up saying ill take what i can get....

Wierd thing is i will select to keep the other 2 subtitle tracks in the mkv but it will only show the one - which happens to be the forced subtitle track, and not either of the 2 other ones. Its the desired outcome, however, like you said it shouldnt be necessary to activate subtitles in the menu to get the forced subtitles.

Its a wierd outcome i cannot find a way around, at least with this particular bluray movie title.
Reply
#9
If its an mkv just run it through "mkvmerge" (MKVtoolnix) and set the forced flag to "yes" on the sub track you want as forced assuming its not already set in which case it will already be set to "Yes" when you select that sub track which I doubt is the case if its not working in XBMC
Current HTPC Lian-Li PC-C37 • Gigabyte GA-E7AUM-DS2H • Intel C2D E8400 E0 Stepping • OCZ Vertex SSD • 4GB Corsair TwinX XMS2 DDR2 • Corsair HX650W Modular PSU (Free Upgrade) • LG CH08LS10 Blu-Ray Drive • Scythe Big Shuriken • Acousti DustPROOF 70mm Fan
Reply
#10
>>X<< Wrote:If its an mkv just run it through "mkvmerge" (MKVtoolnix) and set the forced flag to "yes" on the sub track you want as forced assuming its not already set in which case it will already be set to "Yes" when you select that sub track which I doubt is the case if its not working in XBMC
No need to 'run it through' mkvmerge. Open the mkvmerge and choose 'Header Editor' the default and forced settings can be changed from there without the need to totally remux the file. Just remember to save after changing the flags.
Reply
#11
Cool I learnt something new today Wink

Only ever used it to mux in a few subs so never really looked at all its functions so thanks for the info Smile
Current HTPC Lian-Li PC-C37 • Gigabyte GA-E7AUM-DS2H • Intel C2D E8400 E0 Stepping • OCZ Vertex SSD • 4GB Corsair TwinX XMS2 DDR2 • Corsair HX650W Modular PSU (Free Upgrade) • LG CH08LS10 Blu-Ray Drive • Scythe Big Shuriken • Acousti DustPROOF 70mm Fan
Reply
#12
I'll check it out and report back

thanks guys
Reply
#13
ok i apologize in advance for my noobness - im used to dealing with m2ts files an d this is the first time i am using mkvmerge - i have the particular mkv in question open under the header editor and i see video track 1 and audio track 2, both of which i can adjust the forced flag to say yes (in both cases they were default at no)

Im guessing these are not what i want - i want a third option with a sub track right?

If i click the show subtitles selection as the movie is running in xbmc, the subs will show. I want them to show using the forced flag. Am i missing something?


ps, i tried changing the other video and audio forced flags one at a time to see if i reach the desired effect and they didnt work. but you probably already knew that!
Reply
#14
If there is no option under Header Editor for a subtitle track, then it hasn't been muxed into the mkv file. Do you have a seperate subtitle file in your movie folder?

For this to work you have to have the subtitle contained within the mkv file.

Download mediainfo, open the file in it and post the resultant information - this will tell us if the sub is included or not.
Reply
#15
ok you're right it wasnt muxed in. it was a separate sub file in the same folder as the mkv. so its now muxed in and shows up during playback, although i have a new issue. The text is now off to the right and stretched, as opposed to centered. Im worried that in longer sentences, it will wind up clipping off the right side of the screen. any way to correct this?


EDIT: if I hit backwards and forwards a few times, the subs that were moments ago stretched and off to the right are then magically perfectly centered the way they are supposed to be. What could cause this behavior?


Random thought and question....

does anyone know how to do this but with an m2ts? im imagining its the same deal just a different way of going about it?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Forced subtitles00
This forum uses Lukasz Tkacz MyBB addons.