XBMC freeze Black screen on exit/shutdown
#1
Sad 
Hi,

I am new both to ubuntu and xbmc. I had installed xbmc on ubuntu 10.04 to avoid version issue.

Everything is set and runnng superbly fine except when i try to exit/shutdown xbmc when it simply freezes with a black screen and the big cursor in centre of screen.

Being in full screen, i cannot go anywhere by using ALT+TAB. Even if there is anything else it returns back to the black screen. I simply cannot make xbmc exit or shutdown. Initially i gave 1 hour once and also abour 45 min few times but nothing happened and i had to force shutdown my computer which is not the solution.

I googled for about 10 days and came across many answers - diabling RSS feed /or/ disabling the adjust display referesh rate to match video /or/ selecting different skin.. etc.. but nothing has worked so far and i continue to see people struggling to find a solution even now like me.

Since my family and son uses xbmc to watch cartoons and stuff, terminal route is not in the picture.

There are some senior seasoned professionals in this forum to whom i make a request to please help me with some solution.

Thanks,:mad:

System: Zotax AD02 - Fusion E-350 -AMD Radeon HD 6310/ 8 GB RAM /320 HDD/ All possible updates done - official ATI drivers + Medibuntu /
OS- Ubuntu 10.04
Screen- 42" LED TV
Reply
#2
Hi ,

Can anybody offer any solution Huh?

I need a fix for this.

Thanks,
Reply
#3
I had the same problem with my ATI card and it seems to have been solved turning off vsync (tear free) in the catalyst control panel. Using the vaapi acceleration and setting vsync to playback only in XBMC seems to have fixed it.

If you run Nvidia try the same technique.

Before that I used Guake terminal and created an alias with "sudo pkill X" so that i could easily kill the xserver when this happened.
Reply
#4
Hi Reptilian,

Can you please show me the steps to install and enable VAAPI ?

I'm new to linux so please be more specific. I might do the copy/paste thing of all the commands you may give.

Please detail each step till end.

Thanks,
Reply
#5
Using terminal (I use Ubuntu 11.10 and cannot guarantee these steps will work fro 10.04)

You need to run the Eden nightly build, so if this PPA doesn't work you need to find one that supports 10.04

Code:
sudo add-apt-repository ppa:nathan-renniewaldock/xbmc-nightly
sudo apt-get update && sudo apt-get upgrade

wget http://www.splitted-desktop.com/static/libva/xvba-video/xvba-video_0.8.0-1_amd64.deb

sudo dpkg -i *.deb

sudo ln -s /usr/lib/dri/fglrx_drv_video.so /usr/lib/va/drivers/fglrx_drv_video.so

Open /etc/environment with nano and put this export variable line at the end

Code:
nano /etc/environment
export LIBVA_DRIVER_NAME=fglrx

Reboot.

If you type

vainfo

you should see

Code:
libva: libva version 0.32.0
libva: User requested driver 'fglrx'
libva: Trying to open /usr/lib/dri/fglrx_drv_video.so
libva: va_openDriver() returns 0
vainfo: VA API version: 0.32
vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.8.0
vainfo: Supported profile and entrypoints
      VAProfileH264High               :    VAEntrypointVLD
      VAProfileVC1Advanced            :    VAEntrypointVLD

If you run the latest version of XBMC now (Eden nightly) you can select VAAPI driver in the video settings and hardware acceleration will work. Now turn off the tearing feature in the ATI control panel.

If you get any problems post the error message here.

The usual problem are the files from the xvba-video_0.8.0-1_amd64.deb package not being installed in the correct path


If this is too much try just disabling the tearing and don't worry about the vaapi driver.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XBMC freeze Black screen on exit/shutdown00
This forum uses Lukasz Tkacz MyBB addons.