[Linux] HOW-TO MCE Remote WITHOUT LIRC (Natty)
#31
Removed
Reply
#32
Removed.

(don't know any other way)
Reply
#33
Hi,

I have followed your guide and have now been able to get most keys working but I am having trouble with a couple of things:

1) When I press the power button on the remote I would like the machine to suspend but it currently does nothing.

2) When I resume my machine from sleep the arrow buttons still work but the other buttons (such as OK) no longer work. If I run 'ir-keytable -t' after suspending it says "Not found device rc0". Running 'ir-keytable' seems to indicate that the device has changed from rc0 to rc1. Is there any way to get around this?

Any help will be much appreciated.
Reply
#34
Hi all,

This guide helped me a lot and MCE remote is working fine now except one "small" problem.
VolumeUP and VolumeDown buttons are acting like PageUP and PageDown buttons.

Is there a solution for this issue ?
Reply
#35
Kowalsky Wrote:Hi all,

This guide helped me a lot and MCE remote is working fine now except one "small" problem.
VolumeUP and VolumeDown buttons are acting like PageUP and PageDown buttons.

Is there a solution for this issue ?

Okay I got it Laugh

I'm sure this will help other people so here it goes :

Everything in guide (1st post) is fine, except in my case from all those steps only installing ir-keytable and making the rc6_mce file was needed to make this working.

Anyhow .... back to the volumeup&down issue ... Cool

I really have no idea why the author of the guide had this in that rc6_mce file :
0x800f0410 KEY_PAGEUP # Volume Up
0x800f0411 KEY_PAGEDOWN # Volume Down

That was the problem Huh

Solution :
Change those two lines to this :
0x800f0410 KEY_VOLUMEUP # Volume Up
0x800f0411 KEY_VOLUMEDOWN # Volume Down

That's it, save the file and enjoy Nod
Reply
#36
Thanks for a brilliant guide. I have fought with LIRC for several months on two different computers, just couldn't get it right.

But this worked instantly and my remote is now as responsive as it should!

I have only one button not working as I'd like: the power button
it practically does nothing when I press it in the XBMC main menu.

I'm running Ubuntu 11.10 on an ASRock ION 3D

When I run ir-keytable -t and press the button I get the right response:
1330376091.695521: event MSC: scancode = 800f040c
1330376091.695529: event key down: KEY_KPSLASH (0x0062)
1330376091.695530: event sync
1330376091.946235: event key up: KEY_KPSLASH (0x0062)
1330376091.946237: event sync


I have copied the keyboard.xml from this guide completely. Any ideas what to look for to find what's wrong?
Reply
#37
atlemagnussen Wrote:Thanks for a brilliant guide. I have fought with LIRC for several months on two different computers, just couldn't get it right.

But this worked instantly and my remote is now as responsive as it should!

I have only one button not working as I'd like: the power button
it practically does nothing when I press it in the XBMC main menu.

I'm running Ubuntu 11.10 on an ASRock ION 3D

When I run ir-keytable -t and press the button I get the right response:
1330376091.695521: event MSC: scancode = 800f040c
1330376091.695529: event key down: KEY_KPSLASH (0x0062)
1330376091.695530: event sync
1330376091.946235: event key up: KEY_KPSLASH (0x0062)
1330376091.946237: event sync


I have copied the keyboard.xml from this guide completely. Any ideas what to look for to find what's wrong?

Nevermind. I figured it out.

I had to define the key 800f040c as "KEY_END" in rc6_mce
because of this definition in keyboard.xml: "<end>XBMC.ShutDown()</end>"
Reply
#38
I am a total newby and I need some help.

Trying to follow this guide but I can't even pass the "run ir-keytable" command. When running the command I got the error: /sys/class/rc/: No such file or directory

I have read in a different topic that it could be the issue with not recognizing the IR. However it is recognized as (lsusb):

Bus 004 Device 004: ID 073a:2230 Chaplet Systems, Inc.

Any advice how to get the ir-keytable running without the error would be much appreciated.

Thanks
Reply
#39
(2011-12-03, 00:26)djk29a Wrote: The file that is most relevant to your question is the rc6_mce file under /etc/rc_keymaps. The comments to the right are inserted by the original poster.

Using ir-keytable -t, you would find the keycode that's emitted, and because of how IR keycodes work now, you don't map KEY_OK to something anymore (removal of Lircmap.xml is noted in the first couple sentences). Prior to the newer versions of the Linux kernel, we used to modify that to map keycodes to the XBMC command mappings like Select, Escape, and so on.

In your situation, the line that's relevant for you is:
Code:
0x800f0422 KEY_ENTER                            # Ok
Forget about KEY_OK, it doesn't exist on a regular keyboard, right? You don't have an OK key (unless you're on some really esoteric keyboard that won't work with most consumer PCs).

For another example of how things changed, I added another line to my rc6_keymap file like so:

Code:
0x800f0426 KEY_C # menu button
This line used to map to KEY_EPG (the "Menu" button / program guide button), and now XBMC as well as a bunch of other apps will see it as the 'c' key from the keyboard, which according to the keyboard.xml file brings up the context menu.

Code:
<c>ContextMenu</c>

And if you want to set the repeat frequency / delay, modify the command used in the ir-keytable command.

First off; wsrewart thanks for the details! With your instructions I was able to get both OK and BACK to work.

I later got Volume Up and Volume Down to work by editing keyboard.xml under <global> with:
<pageup>VolumeUp</pageup>
<pagedown>VolumeDown</pagedown>

Looks like this worked because my HP MCE Remote sends:
KEY_PAGEUP (scancode = 800f0410)
KEY_PAGEDOWN (scancode = 800f0411)
for the up and down arrows that are labeled as volume on the physical keys on the remote.

The other two arrow keys I have look like they should be for PageUp and PageDown but when I test them with sudo ir-keytable -t it returns
KEY_CHANNELUP (scancode = 800f0412)
KEY_CHANNELDOWN (scancode = 800f0413)

And there is no <channgelup></channelup> or <channeldown></channeldown> in keyboard.xml. I think this is because these keys do not exist on a standard keyboard.
Could I just add them to keyboard.xml?

What is really troubling is that I can't get NextSubtitle <l>NextSubtitle</> to work or get my MCE remote power button to bring up the shutdown menu.
Currently the power button will close xbmc and the subtitle button = KEY_SUBTITLE does nothing. Even though I set them up the same as VolumeUp and VolumeDown. When I got VolumeUP and VolumeDown to work I thought I was starting to undertsand how rc6_mce and keyboard.xml work together but clearly I don't! Smile

djk29a, I also have the same entries you detailed for the ContextMenu (scancode 800f0426 KEY_EPG) but it also wont work for me. At the moment the Media Center Button (scancode 800f0426 KEY_C) does bring up the context menu.

I'm also new to Linux and I feel I've done ok with your help but I'd really love some more! Any advice would be greatly appreciated.

Thanks all!
(2012-03-02, 00:34)kxm0096 Wrote: I am a total newby and I need some help.

Trying to follow this guide but I can't even pass the "run ir-keytable" command. When running the command I got the error: /sys/class/rc/: No such file or directory

I have read in a different topic that it could be the issue with not recognizing the IR. However it is recognized as (lsusb):

Bus 004 Device 004: ID 073a:2230 Chaplet Systems, Inc.

Any advice how to get the ir-keytable running without the error would be much appreciated.

Thanks

Well, I'm a noob too but I'll suggest one thing that I bet you already did.

From Terlminal type:

cd ~

to get back to home. Then try your command again but add sudo (super user do):

sudo ir-keytable -t

You'll be prompted for your admin password and then it will execute.

If not, are you sure you installed it as in wstwarts instructions from the first post?:

sudo apt-get install ir-keytable
Reply
#40
I would like to say that this topic is really technical and nice...Thank you very much for this.
penny stocks
pennystocks
Reply
#41
(2012-01-28, 15:00)Janiporo Wrote: Seems you can change repeat rates by:
Code:
sudo ir-keytable --delay 500
sudo ir-keytable --period 50

And ofcourse check repeat rate with:
Code:
sudo ir-keytable

But when I change them to 1 or 1410065407 there is absolutely no effect.

I've the same identical problem. Anyone solved yet?
Tnx!!!
Reply
#42
up!

anyone?
Reply
#43
Ok, solved installing LIRC
Reply
#44
I have followed this and am getting everything working but the --delay and --period options on ir-keytable have no effect for me either. Anyone found a solution?
Reply
#45
This bug is still present. It is very annoying, I am tring to configure LIRC but I can not get irw to recognize MCEusb. IRW does nothing The kernel does recognize the MCE, but half my buttons dont work, most notably "OK" and "Back".

I had this same problem before when I used Ubuntu, however I was able to get it working with LIRC. I am using Arch now and it seems alot harder to configure. I do not know what I am doing wrong.
Reply



Logout Mark Read Team Forum Stats Members Help
[Linux] HOW-TO MCE Remote WITHOUT LIRC (Natty)2
This forum uses Lukasz Tkacz MyBB addons.