[Linux] HOW-TO MCE Remote WITHOUT LIRC (Natty)
Anyone that comes across this, I solved it by editing /etc/rc_keymaps/rc6_mce


0x800f0422 KEY_OK
0x800f0423 KEY_EXIT


0x800f0422 KEY_ENTER
0x800f0423 KEY_BACK

IN THERE! No screwing around with lirc. For more information and detail, I got it from

Nice guide! I followed a similar one to get the MCE remote working without LIRC etc.

Using this type of setup with ir-keytable, how do you add new custom buttons ? Other than what is already listed in the rc6_mce file or in my case the imon_mce file.

More details here.


I am using the rc6_mce keymap file on a HTPC upstairs in my bedroom. This is my modified keymap file if it helps anyone? I found I had to change things like KEY_OK to KEY_ENTER and KEY_FASTFORWARD to KEY_F etc for things to start working, used the keyboard shortcuts here.

I also had to edit the keyboard.xml in some places, for example to get the DVD button on the MCE remote to open the Videos library in XBMC I had to do this:

rc6_mce keymap:- Rename KEY_DVD to KEY_F6

0x800f0424 KEY_F6 #DVD button - F6 ShowVideoMenu

keyboard.xml:- Add a new line in to the keyboard.xml file

<F6>ActivateWindow(Videos,MovieTitles)</F6> <!-- MCE DVD menu -->

You can see the list of all Actions you can use in the keyboard.xml file here.

# table rc6_mce, type: RC6
0x800f0400 KEY_0        #Numeric_0 button
0x800f0401 KEY_1        #Numeric_1 button
0x800f0402 KEY_2        #Numeric_2 button
0x800f0403 KEY_3        #Numeric_3 button
0x800f0404 KEY_4        #Numeric_4 button
0x800f0405 KEY_5        #Numeric_5 button
0x800f0406 KEY_6        #Numeric_6 button
0x800f0407 KEY_7        #Numeric_7 button
0x800f0408 KEY_8        #Numeric_8 button
0x800f0409 KEY_9        #Numeric_9 button
0x800f040a KEY_BACKSPACE    #Delete button - Backspace
0x800f040b KEY_ENTER        #ENTER button - OK/Enter
0x800f040c KEY_SUSPEND        #Was KEY_SLEEP - PC Power Button
0x800f040d KEY_ESC        #MEDIA button/MCE Green button - Home
0x800f040e KEY_MUTE        #Mute button
0x800f040f KEY_I        #Info button - Information
0x800f0410 KEY_VOLUMEUP        #Volume Up
0x800f0411 KEY_VOLUMEDOWN    #Volume Down
0x800f0412 KEY_PAGEUP        #ChannelUp button - PageUp
0x800f0413 KEY_PAGEDOWN        #ChannelDown button - PageDown
0x800f0414 KEY_F        #FastForward
0x800f0415 KEY_R        #Rewind
0x800f0416 KEY_PLAY        #Play Button
0x800f0417 KEY_RECORD        #Record button - Turns off PC
0x800f0418 KEY_PLAYPAUSE    #Was KEY_PAUSE - Pause Button
0x800f0419 KEY_X        #Stop
0x800f041a KEY_F1        #Next button
0x800f041b KEY_F2        #Previous button
0x800f041c KEY_NUMERIC_POUND    ## button NOT WORKING
0x800f041d KEY_NUMERIC_STAR    #* button NOT WORKING
0x800f041e KEY_UP        #Up Direction
0x800f041f KEY_DOWN        #Down Direction
0x800f0420 KEY_LEFT        #Back/Exit
0x800f0421 KEY_RIGHT        #Right Direction
0x800f0422 KEY_ENTER        #OK button - OK/Enter
0x800f0423 KEY_BACK        #Back/Exit
0x800f0424 KEY_F6        #DVD button - F6 ShowVideoMenu
0x800f0425 KEY_TUNER        #Not Working Live TV button
0x800f0426 KEY_C        #EPG/Guide button - Context Menu
0x800f0427 KEY_ZOOM             #Unknown
0x800f0432 KEY_MODE             #Button is on Linksys DMA remote - Symbol = L (Linksys Menu button)
0x800f0433 KEY_PRESENTATION     #Unknown
0x800f0434 KEY_EJECTCD          #Unknown
0x800f043a KEY_BRIGHTNESSUP     #Unknown
0x800f0446 KEY_TV               #Unknown
0x800f0447 KEY_F3        #AUDIO button - F3 - XBMC Music
0x800f0448 KEY_PVR        #Not Working Record TV button
0x800f0449 KEY_F4        #CAMERA button - F4 XBMC Pictures
0x800f044a KEY_F5        #VIDEO button - F5 XBMC Videos
0x800f044c KEY_LANGUAGE         #Button is on Linksys DMA remote - Symbol = Radiating Speaker
0x800f044d KEY_TITLE            #Button is on Linksys DMA remote - Symbol = Square with a line inside it at the bottom
0x800f044e KEY_PRINT            #Unknown
0x800f0450 KEY_RADIO            #Not Working Radio button
0x800f045a KEY_T        #Subtitle button - Toggle Subtitles
0x800f045b KEY_RED        #Red button
0x800f045c KEY_GREEN        #Green button
0x800f045d KEY_YELLOW        #Yellow button
0x800f045e KEY_BLUE        #Blue button
0x800f0465 KEY_POWER2           #TV Power button
0x800f046e KEY_PLAYPAUSE    #Not used ?    
0x800f046f KEY_PLAYER           #Unknown
0x800f0480 KEY_BRIGHTNESSDOWN   #Unknown
0x800f0481 KEY_PLAYPAUSE    #Not used ?
Also anyone using a Logitech Harmony remote in MCE mode and got the discrete PowerOn / PowerOff commands working? Would love to hear how you get that working. Only PowerToggle works which is not as reliable.

Old topic, I know but it really helped me.

I use a Harmony One and can only use PowerToggle but that has nothing to do with the remote. It is how my HTPC, an AsRock ION 3D 152d, works. Maybe youre PC is also like that.

@wstewart (if you are still around)
Thanks! This works so much better than lirc. I have been anoyed be the unresponsiveness of my remote for two years and thanks to you I'm a happy camper now Laugh

Running Ubuntu 12.04.4 lts and XBMC 12.3
For anyone interested I got period and comma working with the rc6_mce keymap, by reassigning the following two keys

0x800f041a KEY_DOT # Skip Next
0x800f041b KEY_COMMA # Skip Previous

The period was the tricky one, because "KEY_PERIOD" was not recognized by ir-keytable as valid. It wasn't until I looked into the include/uapi/linux/input.h and saw that PERIOD was actually DOT. Then it worked.
(2011-11-07, 07:33)wstewart Wrote: In this how-to, I will describe how I got an MCE remote to work without using LIRC. As you may know, many of the LIRC drivers have been migrated into the kernel. This how-to is based on a few others:

Man, KUDOS and a HUGE THANKS for this post. After several upgrades to kodi-alpha my MCE remote stopped working. I had a feeling the team might have ditched Lirc, and as soon as I killded the lirc daemon, some of the keys on remote started working... others (OK., BACK) have not. Thanks to you, I now have removed LIRC completely and after a reboot it all stays persistent.

Again, huge KUDOS for writing this post!!! I hope you'll get my thanks. And if you drink beer, I could send you some over PayPal. This is how grateful I am.
So does this guide still apply to Kodi? Just moved from openelec to Kodi, remote works out of the box (Harmony, HP MCE receiver, Asrock 330) but I can't wakeup after suspend using remote any longer.
Thanks a lot for your helpfull post!!!

I'd just tunned my remote and works fine thanks to your guide!!


Linux N3150DC-ITX 4.2.0-30-generic #36-Ubuntu SMP Fri Feb 26 00:58:07 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Ubuntu 15.10
17.0-ALPHA1 Git:baacdd2 Media Center Kodi
HP OVU422000 usb ir
Harmony Remote One+ emulating Microsoft Media Center
Thanks for the thread, OP!

It's oldish but still current Smile Much better then lirc instructions.

I have a quck question to people using Harmony remote:

How do you set it in Logitech software?

I have Harmony 650 and set as Windows Media Center SE.

I got 95% of buttons working but 4 are stubborn:
MENU, EXIT and SKIP_NEXT (I guess, below FF) and SKIP_PREV (below REV).

How did you make them working?


Logout Mark Read Team Forum Stats Members Help
[Linux] HOW-TO MCE Remote WITHOUT LIRC (Natty)2
This forum uses Lukasz Tkacz MyBB addons.