Occasional error MCE Remote Control Kit USB
#1
Hello,
System: XBMC Live 10.1 installed to harddrive.

I have a Hauppauge mce remote control kit usb.
Image

Code:
[email protected]:~$ lsusb
Bus 002 Device 003: ID 15c2:ffdc SoundGraph Inc. iMON PAD Remote Controller
Bus 002 Device 002: ID 0609:0334 SMK Manufacturing, Inc.

Everything works as expected out of the box, but occasionally (twice a day) the receiver seems to be creating random key presses? It only happens after a button is pressed on the remote. For instance sometimes the onscreen display for ”vol down” is shown, its as if the button on the remote appears jammed down (even though its not - because the red light on the usb receiver is NOT lit, thus not receiving a signal.)

also it seems that sometimes the keystokes that it generates are not even possible to be generated by the remote, for instance the "-" dash is repeated constantly and gets sent to xbmc - it obviously only gets noticed if you go to a text input field and then it fills up the text field with "---------------------------". The character it chooses to repeat seems random!

I am of the opinion that the receiver is generating these itself or maybe some incompatibility with lirc (and maybe LCDproc as I have a imon VFD)
This is a standard out of the box install with the only addition of LCDproc. There are no error in syslog or dmesg. I have purged LCDproc in the hope of fixing with no luck. Is there a config or parameter that needs to be added to increase compatibility with this receiver?

…any ideas on how to fix would be much appreciated. Or if you have added an additional bits to /etc/modprobe.d/lirc for this receiver I would be eternally grateful.


nzcarrick
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Occasional error MCE Remote Control Kit USB00
This forum uses Lukasz Tkacz MyBB addons.