VSXu
#16
Ignore my last post. I got around it by copying the file to a different path.. I'm now having issues running it but I believe this is because I'm trying to install it onto raspbmc so it isn't locating certain files.
Reply
#17
Work this visualisation on arm cpu ?
Reply
#18
Hello Vohl.

Did you install VSXU first?
See https://github.com/vovoid/vsxu
Reply
#19
Will you submit this new visualization as a patch for XBMC mainline inclusion?

http://wiki.xbmc.org/index.php?title=HOW...it_a_patch
Reply
#20
@mikaelfinstad would this plugin work for rpi ?
Reply
#21
+1 I would have it in Android
Reply
#22
Hi has anyone got this to work on Raspbmc? Every time I install the VSXU from github.com/vovoid/vsxu and follow the instructions I get this error.

[email protected]:/vsxu/build# make
Scanning dependencies of target vsxu_engine
[ 1%] Building CXX object engine/CMakeFiles/vsxu_engine.dir/src/vsxfst/Common/StringConvert.cpp.o
cc1plus: error: bad value (nocona) for -mtune switch
make[2]: *** [engine/CMakeFiles/vsxu_engine.dir/src/vsxfst/Common/StringConvert.cpp.o] Error 1
make[1]: *** [engine/CMakeFiles/vsxu_engine.dir/all] Error 2
make: *** [all] Error 2
[email protected]:/vsxu/build# make install

Does anyone know what causes this error? Am I missing a dependency to make this work? I've tried searching this up and cc1plus is part of g++ which I have installed. nocona seems to be an acceptable command for cc1plus. Any help would be appreciated.
Reply
#23
There is only opengl glue. No point in trying on arm toys unless you plan to port it.
Reply
#24
K thanks didn't realize pi was arm. Thought that if it was Linux base it would be ok. Oh well back to the hunt for a good visualization.
Reply
#25
i have updated this to use vsxu 0.5.0 and added proper preset support in my fork https://github.com/notspiff/visualization.vsxu

also debian/ubuntu packaging if somebody wants to package it up. you'd have to copy the vsxu packages from ppa:vovoid/vsxu-release for ubuntu, debian you'd probably have to package vsxu first.

a lot of the presets break here. i'm not sure if it is a code issue or a hardware issue or upstream bugs. i'd love if some more peeps could report on their findings in that regard.
Reply
#26
Looks like nobody cares but; i have fixed (submitted upstream and accepted) a vsxu upstream bug which affected multiple preset dirs. So for a fully working addon you need what will become vsxu 0.6
Reply
#27
(2014-12-10, 19:28)ironic_monkey Wrote: Looks like nobody cares...

Just found this thread while searching for some new visuals, as I dont't like the default ones. So I do care (now)!

I installed VSXu from the git repo, and followed the instructions on your github page to install the addon from mifi(?). That didn't work (mifi's addon does not support the VSXu version from git?).

I also tried to install the files from your git repo, but it keeps complaining about a missing "kodi-config.cmake".
Reply
#28
you need to install some kodi dev packages. on ubuntu, using one of our ppas: sudo apt-get install kodi-addon-dev kodi-visualization-dev
Reply
#29
you also need to cherry-pick a commit that hasn't hit mainline yet; https://github.com/Montellese/xbmc/commi...8f688f7e04
Reply
#30
Some screenshots of this running in Kodi would be nice to drum up interest.

Just stumbled on this myself as well.
Reply



Logout Mark Read Team Forum Stats Members Help
VSXu0
This forum uses Lukasz Tkacz MyBB addons.